aboutsummaryrefslogtreecommitdiffstats
path: root/www/youtube_dl
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-08-29 00:34:35 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-08-29 00:34:35 +0800
commit0e4cdbe4dce7281d9d6f2c1f9f211e51c2c90e7f (patch)
tree5cc348e2b9e15eeb939c1f2298a6339a423de3fe /www/youtube_dl
parent6ea8b67d5814fd76512d8e7b147d8f86a7bb8d2d (diff)
downloadfreebsd-ports-gnome-0e4cdbe4dce7281d9d6f2c1f9f211e51c2c90e7f.tar.gz
freebsd-ports-gnome-0e4cdbe4dce7281d9d6f2c1f9f211e51c2c90e7f.tar.zst
freebsd-ports-gnome-0e4cdbe4dce7281d9d6f2c1f9f211e51c2c90e7f.zip
- Update USES=python: it works fine with Python 3.x [1]
- Fix shebang [2] - Bump PORTREVISION for package change With hat: python [1] Reported by: ohauer [2]
Diffstat (limited to 'www/youtube_dl')
-rw-r--r--www/youtube_dl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index b60991f7c239..fc716d11ffd4 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -2,6 +2,7 @@
PORTNAME= youtube_dl
PORTVERSION= 2014.08.10
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= https://yt-dl.org/downloads/${PORTVERSION}/
DISTNAME= youtube-dl-${PORTVERSION}
@@ -16,8 +17,9 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-USES= python:2,run
ALL_TARGET= youtube-dl
+MAKE_ARGS= PYTHON=${PYTHON_CMD}
+USES= python:run
OPTIONS_DEFINE= BASH RTMPDUMP FFMPEG
OPTIONS_DEFAULT=RTMPDUMP