aboutsummaryrefslogtreecommitdiffstats
path: root/www/youtube_dl
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2008-02-13 18:57:54 +0800
committeraraujo <araujo@FreeBSD.org>2008-02-13 18:57:54 +0800
commit08385c4311221b62ab252eb47a88113cb3c68129 (patch)
tree1637bacdf1410656cf253b466adeb9dba06436bb /www/youtube_dl
parent8443a9ee90b21ac767dc6d7c26161b20999fcdc4 (diff)
downloadfreebsd-ports-gnome-08385c4311221b62ab252eb47a88113cb3c68129.tar.gz
freebsd-ports-gnome-08385c4311221b62ab252eb47a88113cb3c68129.tar.zst
freebsd-ports-gnome-08385c4311221b62ab252eb47a88113cb3c68129.zip
- Fixed some problems with conv2avi.
- Bump PORTREVISION. PR: ports/120301 Submitted by: Mel <mel@rachie.is-a-geek.net>, Pankov Pavel <pankov_p@mail.ru> (maintainer) Approved by: stas (mentor, implicit)
Diffstat (limited to 'www/youtube_dl')
-rw-r--r--www/youtube_dl/Makefile1
-rw-r--r--www/youtube_dl/files/conv2avi.patch81
2 files changed, 38 insertions, 44 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index 096cebcd6b18..9ca11cba506a 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= youtube_dl
PORTVERSION= 2008.01.24
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.arrakis.es/~rggi3/youtube-dl/
DISTNAME= youtube-dl-${PORTVERSION}
diff --git a/www/youtube_dl/files/conv2avi.patch b/www/youtube_dl/files/conv2avi.patch
index 4e19c7243325..715be2fca095 100644
--- a/www/youtube_dl/files/conv2avi.patch
+++ b/www/youtube_dl/files/conv2avi.patch
@@ -1,44 +1,37 @@
-Index: www/youtube_dl/files/conv2avi.patch
-===================================================================
-RCS file: www/youtube_dl/files/conv2avi.patch
-diff -N www/youtube_dl/files/conv2avi.patch
---- /dev/null 1 Jan 1970 00:00:00 -0000
-+++ www/youtube_dl/files/conv2avi.patch 31 Jan 2008 19:32:45 -0000
-@@ -0,0 +1,37 @@
-+--- youtube-dl.orig Wed Jan 30 14:18:50 2008
-++++ youtube-dl Thu Jan 31 21:36:49 2008
-+@@ -208,6 +208,7 @@
-+ cmdl_parser.add_option('-t', '--title', action='store_true', dest='use_title', help='use title in file name')
-+ cmdl_parser.add_option('-l', '--literal', action='store_true', dest='use_literal', help='use literal title in file name')
-+ cmdl_parser.add_option('-n', '--netrc', action='store_true', dest='use_netrc', help='use .netrc authentication data')
-++cmdl_parser.add_option('-a', '--avi', action='store_true', dest='use_avi', help='output file in avi format')
-+ cmdl_parser.add_option('-g', '--get-url', action='store_true', dest='get_url', help='print final video URL only')
-+ cmdl_parser.add_option('-2', '--title-too', action='store_true', dest='get_title', help='used with -g, print title too')
-+ (cmdl_opts, cmdl_args) = cmdl_parser.parse_args()
-+@@ -382,6 +383,26 @@
-+
-+ except KeyboardInterrupt:
-+ sys.exit('\n')
-++
-++# Convert to avi if needed
-++if cmdl_opts.use_avi:
-++ if cmdl_opts.outfile is None:
-++ avi_filename = '%s.avi' % video_filename[:-4]
-++ else:
-++ avi_filename = '%s.avi' % video_filename
-++
-++ try:
-++ os.system('%%CONV2AVI_CMD%% "%s" "%s" > %s 2> %s' % (video_filename, avi_filename, os.path.devnull, os.path.devnull))
-++ cond_print('Video file converted to %s\n' % avi_filename)
-++ except OSError:
-++ sys.exit('Error: unable to convert file.\n')
-++ except KeyboardInterrupt:
-++ sys.exit('\n')
-++
-++ try:
-++ os.unlink(video_filename)
-++ except OSError:
-++ sys.exit('Error: unable to remove downloaded file.\n')
-+
-+ # Finish
-+ sys.exit()
+--- youtube-dl.orig Wed Jan 30 14:18:50 2008
++++ youtube-dl Thu Jan 31 21:36:49 2008
+@@ -208,6 +208,7 @@
+ cmdl_parser.add_option('-t', '--title', action='store_true', dest='use_title', help='use title in file name')
+ cmdl_parser.add_option('-l', '--literal', action='store_true', dest='use_literal', help='use literal title in file name')
+ cmdl_parser.add_option('-n', '--netrc', action='store_true', dest='use_netrc', help='use .netrc authentication data')
++cmdl_parser.add_option('-a', '--avi', action='store_true', dest='use_avi', help='output file in avi format')
+ cmdl_parser.add_option('-g', '--get-url', action='store_true', dest='get_url', help='print final video URL only')
+ cmdl_parser.add_option('-2', '--title-too', action='store_true', dest='get_title', help='used with -g, print title too')
+ (cmdl_opts, cmdl_args) = cmdl_parser.parse_args()
+@@ -382,6 +383,26 @@
+
+ except KeyboardInterrupt:
+ sys.exit('\n')
++
++# Convert to avi if needed
++if cmdl_opts.use_avi:
++ if cmdl_opts.outfile is None:
++ avi_filename = '%s.avi' % video_filename[:-4]
++ else:
++ avi_filename = '%s.avi' % video_filename
++
++ try:
++ os.system('%%CONV2AVI_CMD%% "%s" "%s" > %s 2> %s' % (video_filename, avi_filename, os.path.devnull, os.path.devnull))
++ cond_print('Video file converted to %s\n' % avi_filename)
++ except OSError:
++ sys.exit('Error: unable to convert file.\n')
++ except KeyboardInterrupt:
++ sys.exit('\n')
++
++ try:
++ os.unlink(video_filename)
++ except OSError:
++ sys.exit('Error: unable to remove downloaded file.\n')
+
+ # Finish
+ sys.exit()