aboutsummaryrefslogtreecommitdiffstats
path: root/www/zend-framework
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-07-19 22:09:32 +0800
committersat <sat@FreeBSD.org>2007-07-19 22:09:32 +0800
commit9d5820a768a610faa4a3db128d2190fbba1d3803 (patch)
tree774180526bea0133ee917616bf2d4634fc6c7ca2 /www/zend-framework
parent64cbb5090341ad29207c9ffde024ca306a5757be (diff)
downloadfreebsd-ports-gnome-9d5820a768a610faa4a3db128d2190fbba1d3803.tar.gz
freebsd-ports-gnome-9d5820a768a610faa4a3db128d2190fbba1d3803.tar.zst
freebsd-ports-gnome-9d5820a768a610faa4a3db128d2190fbba1d3803.zip
- Update to 1.0.0
- Add options for installing PHP dependencies - Restore pkg-plist directives to create empty directories - Clean up a bit PR: ports/114362 Submitted by: Greg Larkin <glarkin@sourcehosting.net> (maintainer)
Diffstat (limited to 'www/zend-framework')
-rw-r--r--www/zend-framework/Makefile64
-rw-r--r--www/zend-framework/distinfo6
-rw-r--r--www/zend-framework/pkg-plist28
3 files changed, 60 insertions, 38 deletions
diff --git a/www/zend-framework/Makefile b/www/zend-framework/Makefile
index cc4d8b5bd4e8..5ca0b45c8e49 100644
--- a/www/zend-framework/Makefile
+++ b/www/zend-framework/Makefile
@@ -1,86 +1,82 @@
# New ports collection makefile for: zend-framework
-# Date created: 31 October 2006
-# Whom: Greg Larkin <glarkin@sourcehosting.net>
+# Date created: 31 October 2006
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
#
# $FreeBSD$
#
PORTNAME= ZendFramework
-PORTVERSION= 1.0.0rc3
+PORTVERSION= 1.0.0
CATEGORIES= www
-MASTER_SITES= http://framework.zend.com/releases/${DISTNAME}/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/rc3/-RC3/}
+MASTER_SITES= http://framework.zend.com/releases/${DISTNAME}/ GENTOO/distfiles
MAINTAINER= glarkin@sourcehosting.net
COMMENT= A framework for developing PHP web applications
NO_BUILD= yes
-USE_PHP= pcre
+USE_PHP= pcre spl
WANT_PHP_WEB= yes
IGNORE_WITH_PHP=4
USE_GETTEXT= yes
SUB_FILES= pkg-message
-SUB_LIST= DATADIR=${DATADIR} LOCALBASE=${LOCALBASE}
-
-WRKSRC= ${WRKDIR}/${DISTNAME}
OPTIONS= MYSQL "Install MySQL PDO support" Off \
DBLIB "Install DBLIB PDO support" Off \
PGSQL "Install PostgreSQL PDO support" Off \
OCI "Install Oracle OCI 8 PDO support" Off \
ODBC "Install ODBC PDO support" Off \
- SQLITE "Install SQLite v3 PDO support" Off
+ SQLITE "Install SQLite v3 PDO support" Off \
+ REQPHP "Install required PHP dependencies" On \
+ OPTPHP "Install optional PHP dependencies" Off
.include <bsd.port.pre.mk>
-DB_DEFINED= no
+# Add all of the required and/or optional PHP extension dependencies,
+# if chosen by the user.
+#
+# See http://framework.zend.com/manual/en/requirements.extensions.html for
+# a table of what PHP extensions are required for what ZF classes.
+
+.if defined(WITH_REQPHP)
+USE_PHP+= ctype curl dom gd iconv mbstring memcache \
+ session simplexml soap xml zlib
+.endif
+.if defined(WITH_OPTPHP)
+USE_PHP+= bcmath bitset json posix
+.endif
.if defined(WITH_MYSQL)
-DB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_mysql.so:${PORTSDIR}/databases/php5-pdo_mysql
-DB_DEFINED= yes
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_mysql.so:${PORTSDIR}/databases/php5-pdo_mysql
.endif
.if defined(WITH_DBLIB)
-DB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_dblib.so:${PORTSDIR}/databases/php5-pdo_dblib
-DB_DEFINED= yes
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_dblib.so:${PORTSDIR}/databases/php5-pdo_dblib
.endif
.if defined(WITH_PGSQL)
-DB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
-DB_DEFINED= yes
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
.endif
.if defined(WITH_OCI)
-DB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_oci.so:${PORTSDIR}/databases/php5-pdo_oci
-DB_DEFINED= yes
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_oci.so:${PORTSDIR}/databases/php5-pdo_oci
.endif
.if defined(WITH_ODBC)
-DB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php5-pdo_odbc
-DB_DEFINED= yes
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php5-pdo_odbc
.endif
.if defined(WITH_SQLITE)
-DB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_sqlite.so:${PORTSDIR}/databases/php5-pdo_sqlite
-DB_DEFINED= yes
-.endif
-
-.if ${DB_DEFINED} == "yes"
-USE_PHP+= pdo
-RUN_DEPENDS+= ${DB_DEPENDS}
+USE_PHP+= pdo_sqlite
.endif
-# Fix USE_PHP after bsd.port.pre.mk
-.include "${PORTSDIR}/Mk/bsd.php.mk"
-
do-install:
@${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/* ${DATADIR}
+ ${CP} -R ${WRKSRC}/ ${DATADIR}
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${DATADIR}
- ${FIND} ${DATADIR} -type f -print | ${XARGS} -n1 ${CHMOD} 644
- ${FIND} ${DATADIR} -type d -print | ${XARGS} -n1 ${CHMOD} 755
+ ${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ ${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/zend-framework/distinfo b/www/zend-framework/distinfo
index 5fe98c346de8..d1eb1b3f4ea3 100644
--- a/www/zend-framework/distinfo
+++ b/www/zend-framework/distinfo
@@ -1,3 +1,3 @@
-MD5 (ZendFramework-1.0.0-RC3.tar.gz) = eacc785c81eb7016ae7900b6779760fc
-SHA256 (ZendFramework-1.0.0-RC3.tar.gz) = d6f608e59309960d6c404515730a5a86125c85b2a880055b39d44f3cacaeaab4
-SIZE (ZendFramework-1.0.0-RC3.tar.gz) = 3292519
+MD5 (ZendFramework-1.0.0.tar.gz) = 4aa461003287113d6757ba370ee9a7c2
+SHA256 (ZendFramework-1.0.0.tar.gz) = 2fb2a39ad7b51b9ce7911512509d0a22a0b8549de585d9c2b062d778671ffc10
+SIZE (ZendFramework-1.0.0.tar.gz) = 3295764
diff --git a/www/zend-framework/pkg-plist b/www/zend-framework/pkg-plist
index 105f452fce37..765c4e3a7475 100644
--- a/www/zend-framework/pkg-plist
+++ b/www/zend-framework/pkg-plist
@@ -216,6 +216,7 @@
%%DATADIR%%/library/Zend/Controller/Plugin/Broker.php
%%DATADIR%%/library/Zend/Controller/Plugin/ErrorHandler.php
%%DATADIR%%/library/Zend/Controller/Request/Abstract.php
+%%DATADIR%%/library/Zend/Controller/Request/Apache404.php
%%DATADIR%%/library/Zend/Controller/Request/Exception.php
%%DATADIR%%/library/Zend/Controller/Request/Http.php
%%DATADIR%%/library/Zend/Controller/Response/Abstract.php
@@ -1170,7 +1171,6 @@
%%DATADIR%%/library/Zend/Uri.php
%%DATADIR%%/library/Zend/Uri/Exception.php
%%DATADIR%%/library/Zend/Uri/Http.php
-%%DATADIR%%/library/Zend/Uri/Mailto.php
%%DATADIR%%/library/Zend/Validate.php
%%DATADIR%%/library/Zend/Validate/Abstract.php
%%DATADIR%%/library/Zend/Validate/Alnum.php
@@ -1314,6 +1314,7 @@
%%DATADIR%%/tests/Zend/Controller/FrontTest.php
%%DATADIR%%/tests/Zend/Controller/Plugin/BrokerTest.php
%%DATADIR%%/tests/Zend/Controller/Plugin/ErrorHandlerTest.php
+%%DATADIR%%/tests/Zend/Controller/Request/Apache404Test.php
%%DATADIR%%/tests/Zend/Controller/Request/HttpTest.php
%%DATADIR%%/tests/Zend/Controller/Response/HttpTest.php
%%DATADIR%%/tests/Zend/Controller/Router/RewriteTest.php
@@ -1421,6 +1422,7 @@
%%DATADIR%%/tests/Zend/Db/Table/Row/Pdo/SqliteTest.php
%%DATADIR%%/tests/Zend/Db/Table/Row/StaticTest.php
%%DATADIR%%/tests/Zend/Db/Table/Row/TestCommon.php
+%%DATADIR%%/tests/Zend/Db/Table/Row/TestMockRow.php
%%DATADIR%%/tests/Zend/Db/Table/Row/TestMyRow.php
%%DATADIR%%/tests/Zend/Db/Table/Rowset/Db2Test.php
%%DATADIR%%/tests/Zend/Db/Table/Rowset/MysqliTest.php
@@ -1970,6 +1972,30 @@
%%DATADIR%%/tests/Zend/_files/_testDir1/ClassNonexistent.php
%%DATADIR%%/tests/Zend/_files/_testDir1/Interface1.php
%%DATADIR%%/tests/Zend/_files/_testDir2/Class2.php
+@exec mkdir -p %D/%%DATADIR%%/incubator/demos/Zend/Acl
+@exec mkdir -p %D/%%DATADIR%%/incubator/demos/Zend/Service/Audioscrobbler
+@exec mkdir -p %D/%%DATADIR%%/incubator/library/Zend/Cache/Backend
+@exec mkdir -p %D/%%DATADIR%%/incubator/library/Zend/Controller/Action/Helper
+@exec mkdir -p %D/%%DATADIR%%/incubator/library/Zend/Filter
+@exec mkdir -p %D/%%DATADIR%%/incubator/library/Zend/Registry
+@exec mkdir -p %D/%%DATADIR%%/incubator/library/Zend/Service
+@exec mkdir -p %D/%%DATADIR%%/incubator/tests/Zend/Cache
+@exec mkdir -p %D/%%DATADIR%%/incubator/tests/Zend/Filter/_files
+@exec mkdir -p %D/%%DATADIR%%/incubator/tests/Zend/Http
+@exec mkdir -p %D/%%DATADIR%%/incubator/tests/Zend/Registry
+@exec mkdir -p %D/%%DATADIR%%/incubator/tests/Zend/Service
+@exec mkdir -p %D/%%DATADIR%%/incubator/tests/Zend/Soap/Wsdl
+@exec mkdir -p %D/%%DATADIR%%/library/Zend/View/Filter
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/filters
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/helpers
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/default/controllers
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/foo/views/helpers
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/views/filters
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/views/helpers
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Db/Table/_files
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Memory/_files
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Search/Lucene/Storage/_tempFiles
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Search/Lucene/_files/_index
@dirrm %%DATADIR%%/tests/Zend/_files/_testDir2
@dirrm %%DATADIR%%/tests/Zend/_files/_testDir1/Class1
@dirrm %%DATADIR%%/tests/Zend/_files/_testDir1