aboutsummaryrefslogtreecommitdiffstats
path: root/www/ziproxy/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-10-01 20:33:37 +0800
committerpav <pav@FreeBSD.org>2010-10-01 20:33:37 +0800
commite1ff50a18f5230702279f344d1f5d4b4ada42687 (patch)
treec77e7466ffa1e4d3556ea75c499a7c871f998b28 /www/ziproxy/Makefile
parent88d717a14f766f5bc89af02309d89510c7ca1602 (diff)
downloadfreebsd-ports-gnome-e1ff50a18f5230702279f344d1f5d4b4ada42687.tar.gz
freebsd-ports-gnome-e1ff50a18f5230702279f344d1f5d4b4ada42687.tar.zst
freebsd-ports-gnome-e1ff50a18f5230702279f344d1f5d4b4ada42687.zip
- Update to 3.2.0
PR: ports/150782 Submitted by: Pavel Pankov <pankov_p@mail.ru> (maintainer)
Diffstat (limited to 'www/ziproxy/Makefile')
-rw-r--r--www/ziproxy/Makefile41
1 files changed, 29 insertions, 12 deletions
diff --git a/www/ziproxy/Makefile b/www/ziproxy/Makefile
index 8e4cfa98b2fa..c53e9d58b3d0 100644
--- a/www/ziproxy/Makefile
+++ b/www/ziproxy/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= ziproxy
-PORTVERSION= 3.1.3
+PORTVERSION= 3.2.0
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -38,41 +38,43 @@ USE_RC_SUBR= ziproxy
SUB_FILES+= pkg-message
-OPTIONS+= JPEG2000 "Build with JPEG2000 support" on
+OPTIONS+= JPEG2000 "Build with JPEG2000 support" on \
+ SASL "Build with SASL auth support" on \
+ NAMESERVERS "Enable Nameservers config option" on
ERROR_FILES= 400.html 403.html 404.html 407.html 408.html 409.html \
500.html 503.html
SAMPLE_CONFIG_FILES= bo_exception.list change_tos.list deny.list http.passwd \
noprocess.list replace.list replace_ct.list \
- ziproxy.conf
+ ziproxy.conf sasl/ziproxy.conf
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%DATADIR%%|${DATADIR}|g' \
${WRKSRC}/etc/ziproxy/ziproxy.conf
post-install:
- @${MKDIR} ${PREFIX}/etc/ziproxy
+ ${MKDIR} ${PREFIX}/etc/ziproxy/sasl
.for FILE in ${SAMPLE_CONFIG_FILES}
- @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/${FILE} ${PREFIX}/etc/ziproxy/${FILE}.sample
+ ${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/${FILE} ${PREFIX}/etc/ziproxy/${FILE}.sample
.endfor
- @if [ ! -f ${PREFIX}/etc/ziproxy/ziproxy.conf ]; then \
+ if [ ! -f ${PREFIX}/etc/ziproxy/ziproxy.conf ]; then \
${CP} -p ${WRKSRC}/etc/ziproxy/ziproxy.conf ${PREFIX}/etc/ziproxy/ziproxy.conf ; \
fi
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
.for FILE in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/${DOC}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/${FILE}
.endfor
.endif
- @${MKDIR} ${DATADIR}/error
+ ${MKDIR} ${DATADIR}/error
.for FILE in ${ERROR_FILES}
- @${INSTALL_DATA} ${WRKSRC}/var/ziproxy/error/${FILE} ${DATADIR}/error/${FILE}
+ ${INSTALL_DATA} ${WRKSRC}/var/ziproxy/error/${FILE} ${DATADIR}/error/${FILE}
.endfor
- @${INSTALL_SCRIPT} ${WRKSRC}/src/tools/ziproxy_genhtml_stats.sh ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/tools/ziproxy_genhtml_stats.sh ${PREFIX}/bin
@${CAT} ${PKGMESSAGE}
@@ -81,6 +83,21 @@ post-install:
.if !defined(WITHOUT_JPEG2000)
CONFIGURE_ARGS+= --with-jasper
LIB_DEPENDS+= jasper.4:${PORTSDIR}/graphics/jasper
+.else
+CONFIGURE_ARGS+= --without-jasper
+.endif
+
+.if !defined(WITHOUT_SASL)
+CONFIGURE_ARGS+= --with-sasl2
+LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+.else
+CONFIGURE_ARGS+= --without-sasl2
+.endif
+
+.if !defined(WITHOUT_NAMESERVERS)
+CONFIGURE_ARGS+= --enable-nameservers
+.else
+CONFIGURE_ARGS+= --disable-nameservers
.endif
.include <bsd.port.post.mk>