aboutsummaryrefslogtreecommitdiffstats
path: root/www/znavigator
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-05 06:57:37 +0800
committeredwin <edwin@FreeBSD.org>2002-11-05 06:57:37 +0800
commit64a5e0f37f47ca9274d3cc6633ed687cc7dc23ca (patch)
tree664d2ba6932861fa84d22c638a1035a3fcd6a962 /www/znavigator
parent8d98f5042d9d3f5d1c76b52d1826c997af60472d (diff)
downloadfreebsd-ports-gnome-64a5e0f37f47ca9274d3cc6633ed687cc7dc23ca.tar.gz
freebsd-ports-gnome-64a5e0f37f47ca9274d3cc6633ed687cc7dc23ca.tar.zst
freebsd-ports-gnome-64a5e0f37f47ca9274d3cc6633ed687cc7dc23ca.zip
Half of these ones missed yesterday while converting to USE_REINPLACE.
The other half needs perl to build. Noticed on bento and others (full mailbox :-)
Diffstat (limited to 'www/znavigator')
-rw-r--r--www/znavigator/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/znavigator/Makefile b/www/znavigator/Makefile
index f7f4852ae7d2..97d7bb8372e2 100644
--- a/www/znavigator/Makefile
+++ b/www/znavigator/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= nbm@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
NO_BUILD= YES
+USE_REINPLACE= yes
# You can change this in the environment if you like.
SZOPEBASEDIR?= www/Zope
@@ -38,7 +39,8 @@ do-install:
${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}/
@${CP} ${ZOPEPRODUCTSRC}/demo/navigator_demo.zexp \
${ZOPEBASEDIR}/import
- @perl -pe 's#%%PREFIX%%#${PREFIX}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
+ @${REINPLACE_CMD} -e \
+ 's#%%PREFIX%%#${PREFIX}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>