aboutsummaryrefslogtreecommitdiffstats
path: root/www/zope-guf
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2001-08-16 20:21:47 +0800
committerwjv <wjv@FreeBSD.org>2001-08-16 20:21:47 +0800
commitef852dbcd03a1ffe6dc2ad03dcbc6a798460a34a (patch)
tree6e46c10c24a8bf662a0419a5e2b64ef2f50f0220 /www/zope-guf
parent6ec02b522712179721ffd7ce3fa04fe6f2636424 (diff)
downloadfreebsd-ports-gnome-ef852dbcd03a1ffe6dc2ad03dcbc6a798460a34a.tar.gz
freebsd-ports-gnome-ef852dbcd03a1ffe6dc2ad03dcbc6a798460a34a.tar.zst
freebsd-ports-gnome-ef852dbcd03a1ffe6dc2ad03dcbc6a798460a34a.zip
Add zope-guf 1.2.4, a roll-your-own user folder product for Zope.
Diffstat (limited to 'www/zope-guf')
-rw-r--r--www/zope-guf/Makefile48
-rw-r--r--www/zope-guf/distinfo1
-rw-r--r--www/zope-guf/pkg-comment1
-rw-r--r--www/zope-guf/pkg-descr15
-rw-r--r--www/zope-guf/pkg-message4
-rw-r--r--www/zope-guf/pkg-plist29
6 files changed, 98 insertions, 0 deletions
diff --git a/www/zope-guf/Makefile b/www/zope-guf/Makefile
new file mode 100644
index 000000000000..a3d634528b94
--- /dev/null
+++ b/www/zope-guf/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: zope-zpt
+# Date created: 15 August 2001
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= guf
+PORTVERSION= 1.2.4
+CATEGORIES= www zope
+MASTER_SITES= http://www.zope.org/Members/Zen/GenericUserFolder/
+PKGNAMEPREFIX= zope-
+DISTNAME= ${ZOPEPRODUCTNAME}-${PORTVERSION:S|.|-|g}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= wjv@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
+
+USE_PYTHON= yes
+DIST_SUBDIR= zope
+
+# You can change this in the environment if you like
+SZOPEBASEDIR?= www/Zope
+
+# Don't change these
+ZOPEBASEDIR= ${PREFIX}/${SZOPEBASEDIR}
+ZOPEPRODUCTNAME= GenericUserFolder
+ZOPEPRODUCTDIR= lib/python/Products
+
+PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+CPIO= cpio --quiet -pdum -R
+
+do-build:
+ @ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+ @ cd ${WRKSRC} && find * | ${CPIO} ${BINOWN}:${BINGRP} \
+ ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/zope-guf/distinfo b/www/zope-guf/distinfo
new file mode 100644
index 000000000000..6aa018642015
--- /dev/null
+++ b/www/zope-guf/distinfo
@@ -0,0 +1 @@
+MD5 (zope/GenericUserFolder-1-2-4.tgz) = 471348e54d1c4977b75d05513fa1bce3
diff --git a/www/zope-guf/pkg-comment b/www/zope-guf/pkg-comment
new file mode 100644
index 000000000000..fcc894d5314c
--- /dev/null
+++ b/www/zope-guf/pkg-comment
@@ -0,0 +1 @@
+A roll-your-own user folder product for Zope
diff --git a/www/zope-guf/pkg-descr b/www/zope-guf/pkg-descr
new file mode 100644
index 000000000000..a9caf821990f
--- /dev/null
+++ b/www/zope-guf/pkg-descr
@@ -0,0 +1,15 @@
+GenericUserFolder (GUF) is a Zope product which allows you to "roll your own"
+Zope user folders.
+
+Using GUF you can authenticate users of Zope-based applications using SQL
+databases, NIS, LDAP, or whatever other technology you can conceive, limited
+only by your ability to write the code to interface with that technology.
+
+NOTE: GUF is regarded as being deprecated in favour of the LoginManager
+ product. However, due to the relative complexity of LoginManager (and
+ the straightforward simplicity of GUF), GUF is still widely used.
+
+Author: <zen@cs.rmit.edu.au>
+WWW: http://www.zope.org/Members/Zen/GenericUserFolder/
+
+-- Johann Visagie <wjv@FreeBSD.org>
diff --git a/www/zope-guf/pkg-message b/www/zope-guf/pkg-message
new file mode 100644
index 000000000000..125f97569081
--- /dev/null
+++ b/www/zope-guf/pkg-message
@@ -0,0 +1,4 @@
+===> Zope GenericUserFolder post-port installation instructions:
+
+ To complete the installation of this port, you need to estart Zope. This
+ may be done from the Zope Control Panel in the Zope management interface.
diff --git a/www/zope-guf/pkg-plist b/www/zope-guf/pkg-plist
new file mode 100644
index 000000000000..5d47f62df7e1
--- /dev/null
+++ b/www/zope-guf/pkg-plist
@@ -0,0 +1,29 @@
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/CHANGES.txt
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/GenericUserFolder.py
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/GenericUserFolder.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/LICENCE.txt
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/Makefile
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/README.txt
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/User.py
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/User.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/WALKTHROUGH.txt
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/__init__.py
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/__init__.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/addGenericUserFolder.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/folder.gif
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/manage_cache.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/manage_listUsers.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/manage_properties.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/manage_userInfo.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/templates/dumb/docLogin.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/templates/dumb/docLoginSuccess.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/templates/dumb/docLogout.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/templates/dumb/userAuthenticate.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/templates/dumb/userDomains.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/templates/dumb/userList.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/templates/dumb/userRoles.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/user.gif
+%%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/version.txt
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/templates/dumb
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder/templates
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/GenericUserFolder