aboutsummaryrefslogtreecommitdiffstats
path: root/www/zope
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2001-03-04 18:32:18 +0800
committernbm <nbm@FreeBSD.org>2001-03-04 18:32:18 +0800
commitc32437a2576660c179ea613c015d8b5b25133885 (patch)
treea52979041ca5932d21d9f3d9f71fc9006ce35654 /www/zope
parent677dde1e59222f3efdb0b3b13443c1c8a87f2dd2 (diff)
downloadfreebsd-ports-gnome-c32437a2576660c179ea613c015d8b5b25133885.tar.gz
freebsd-ports-gnome-c32437a2576660c179ea613c015d8b5b25133885.tar.zst
freebsd-ports-gnome-c32437a2576660c179ea613c015d8b5b25133885.zip
Apply a Zope hotfix, fixing a potential security problem.
From the Zope hotfix: This hotfix addresses and important security issue that affects Zope versions up to and including Zope 2.3.1 b1. The issue is related to ZClasses in that a user with through-the-web scripting capabilities on a Zope site can view and assign class attributes to ZClasses, possibly allowing them to make inappropriate changes to ZClass instances. This patch also fixes problems in the ObjectManager, PropertyManager, and PropertySheet classes related to mutability of method return values which could be perceived as a security problem. We *highly* recommend that any Zope site running versions of Zope up to and including 2.3.1 b1 have this hotfix product installed to mitigate these issues if the site is accessible by untrusted users who have through-the-web scripting privileges.
Diffstat (limited to 'www/zope')
-rw-r--r--www/zope/Makefile9
-rw-r--r--www/zope/distinfo1
-rw-r--r--www/zope/pkg-plist3
3 files changed, 10 insertions, 3 deletions
diff --git a/www/zope/Makefile b/www/zope/Makefile
index 7861136d948f..e2effe5d6d72 100644
--- a/www/zope/Makefile
+++ b/www/zope/Makefile
@@ -7,12 +7,14 @@
PORTNAME= zope
PORTVERSION= 2.3.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www python
-MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
+MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/ \
+ http://www.zope.org/Products/Zope/Hotfix_2001-02-23/
DISTNAME= Zope-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ Hotfix_2001-02-23.tgz
MAINTAINER= nbm@FreeBSD.org
@@ -61,6 +63,7 @@ do-install: #
@${ECHO} "===> Please be patient, some builds need their time."
@${ECHO} "===> Copying..."
@${CP} -Rp ${WRKSRC}/* ${ZOPEBASEDIR}/
+ @${CP} -Rp ${WRKDIR}/lib ${ZOPEBASEDIR}/
@#
@${CHMOD} -R u+w ${ZOPEBASEDIR}
@(cd ${ZOPEBASEDIR} && ${PYTHON15} w_pcgi.py)
diff --git a/www/zope/distinfo b/www/zope/distinfo
index ba0860d00120..a24b333e3e75 100644
--- a/www/zope/distinfo
+++ b/www/zope/distinfo
@@ -1 +1,2 @@
MD5 (zope/Zope-2.3.0-src.tgz) = ffd467bc9da04564af10452a4bb520d1
+MD5 (zope/Hotfix_2001-02-23.tgz) = 9794180dd3d46e176cf150345f62e353
diff --git a/www/zope/pkg-plist b/www/zope/pkg-plist
index 8ef59c54606a..68e3697e5920 100644
--- a/www/zope/pkg-plist
+++ b/www/zope/pkg-plist
@@ -616,6 +616,9 @@ etc/rc.d/zope.sh
%%ZOPEBASEDIR%%/lib/python/Products/ExternalMethod/help/ExternalMethod.pyc
%%ZOPEBASEDIR%%/lib/python/Products/ExternalMethod/version.txt
%%ZOPEBASEDIR%%/lib/python/Products/ExternalMethod/www/function.gif
+%%ZOPEBASEDIR%%/lib/python/Products/Hotfix_2001-02-23/README.txt
+%%ZOPEBASEDIR%%/lib/python/Products/Hotfix_2001-02-23/__init__.py
+%%ZOPEBASEDIR%%/lib/python/Products/Hotfix_2001-02-23/__init__.pyc
%%ZOPEBASEDIR%%/lib/python/Products/MIMETools/MIMETag.py
%%ZOPEBASEDIR%%/lib/python/Products/MIMETools/MIMETag.pyc
%%ZOPEBASEDIR%%/lib/python/Products/MIMETools/README.txt