aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2009-03-26 22:03:41 +0800
committerosa <osa@FreeBSD.org>2009-03-26 22:03:41 +0800
commit0114b3cd1de3b90a284c68e1e110350f209ca9d0 (patch)
tree34c9f9b08e21a01c8c7db1761e6341417c728c0b /www
parent06a0cab2e417a67a523de323aa45de96431d208c (diff)
downloadfreebsd-ports-gnome-0114b3cd1de3b90a284c68e1e110350f209ca9d0.tar.gz
freebsd-ports-gnome-0114b3cd1de3b90a284c68e1e110350f209ca9d0.tar.zst
freebsd-ports-gnome-0114b3cd1de3b90a284c68e1e110350f209ca9d0.zip
Add support for http_gzip_static module.
Do not bump PORTREVISION. Patch from: MZ aka zuborg at advancedhosters dot com
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 4a280fa6ece3..ded7c901c90a 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -26,6 +26,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_DAV_MODULE "Enable http_webdav module" off \
HTTP_FANCYINDEX_MODULE "Enable http_fancyindex module" off \
HTTP_FLV_MODULE "Enable http_flv module" off \
+ HTTP_GZIP_STATIC_MODULE "Enable http_gzip_static module" off \
HTTP_PERL_MODULE "Enable http_perl module" off \
HTTP_RANDOM_INDEX_MODULE "Enable http_random_index module" off \
HTTP_REALIP_MODULE "Enable http_realip module" off \
@@ -125,6 +126,10 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-fancyindex-${NGINX_FANCYINDEX_MODUL
CONFIGURE_ARGS+=--with-http_flv_module
.endif
+.if defined(WITH_HTTP_GZIP_STATIC_MODULE)
+CONFIGURE_ARGS+=--with-http_gzip_static_module
+.endif
+
.if defined(WITH_HTTP_PERL_MODULE)
CATEGORIES+= perl5
CONFIGURE_ARGS+=--with-http_perl_module