aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-03-02 11:33:14 +0800
committerwen <wen@FreeBSD.org>2011-03-02 11:33:14 +0800
commit0c7fc26bbf42e9a0bf05c3f0747ad8128abce47e (patch)
tree75590ae0430ebeaeddacec067994d421824a5032 /www
parentf8d86dca0f32d33a1ecdb56b287206d440f97dcb (diff)
downloadfreebsd-ports-gnome-0c7fc26bbf42e9a0bf05c3f0747ad8128abce47e.tar.gz
freebsd-ports-gnome-0c7fc26bbf42e9a0bf05c3f0747ad8128abce47e.tar.zst
freebsd-ports-gnome-0c7fc26bbf42e9a0bf05c3f0747ad8128abce47e.zip
Dancer::Plugin::Feed provides an easy way to generate RSS or Atom feed.
This module relies on XML::Feed. WWW: http://search.cpan.org/dist/Dancer-Plugin-Feed/ PR: ports/155173 Submitted by: Grzegorz Blach <magik@roorback.net>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer-Plugin-Feed/Makefile26
-rw-r--r--www/p5-Dancer-Plugin-Feed/distinfo2
-rw-r--r--www/p5-Dancer-Plugin-Feed/pkg-descr4
-rw-r--r--www/p5-Dancer-Plugin-Feed/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7b0640f3d249..b69f9d65d4bf 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -908,6 +908,7 @@
SUBDIR += p5-DBIx-Class-HTMLWidget
SUBDIR += p5-Dancer
SUBDIR += p5-Dancer-Plugin-DataFu
+ SUBDIR += p5-Dancer-Plugin-Feed
SUBDIR += p5-Data-TreeDumper-Renderer-DHTML
SUBDIR += p5-Data-Validate-URI
SUBDIR += p5-FAQ-OMatic
diff --git a/www/p5-Dancer-Plugin-Feed/Makefile b/www/p5-Dancer-Plugin-Feed/Makefile
new file mode 100644
index 000000000000..ac1d6efb90d9
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Feed/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Dancer-Plugin-Feed
+# Date created: 01 March 2011
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer-Plugin-Feed
+PORTVERSION= 0.1
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/H/HO/HOBBESTIG/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= magik@roorback.net
+COMMENT= Dancer plugin for generating RSS or Atom feeds
+
+RUN_DEPENDS= p5-Dancer>=1.175:${PORTSDIR}/www/p5-Dancer \
+ p5-XML-Feed>0:${PORTSDIR}/textproc/p5-XML-Feed
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Dancer::Plugin::Feed.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Plugin-Feed/distinfo b/www/p5-Dancer-Plugin-Feed/distinfo
new file mode 100644
index 000000000000..eea38a66a32a
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Feed/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-Feed-0.1.tar.gz) = c035e5714415a43b3c6599f7e35ff3b64f82ae365321d8a4e7a5bd8ba6004e99
+SIZE (Dancer-Plugin-Feed-0.1.tar.gz) = 3445
diff --git a/www/p5-Dancer-Plugin-Feed/pkg-descr b/www/p5-Dancer-Plugin-Feed/pkg-descr
new file mode 100644
index 000000000000..bd3416e27440
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Feed/pkg-descr
@@ -0,0 +1,4 @@
+Dancer plugin which provides an easy way to generate RSS or Atom feed.
+This module relies on XML::Feed.
+
+WWW: http://search.cpan.org/dist/Dancer-Plugin-Feed/
diff --git a/www/p5-Dancer-Plugin-Feed/pkg-plist b/www/p5-Dancer-Plugin-Feed/pkg-plist
new file mode 100644
index 000000000000..29658e058737
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Feed/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Feed/.packlist
+%%SITE_PERL%%/Dancer/Plugin/Feed.pm
+@dirrmtry %%SITE_PERL%%/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/Dancer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Feed
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer