aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2003-02-06 17:13:17 +0800
committerdirk <dirk@FreeBSD.org>2003-02-06 17:13:17 +0800
commit0ff6d1309a8949872406731ae402a1958be15495 (patch)
tree868cefec085ed53dbce0fd526efde335bbd5f68d /www
parent0fd4883e0efbb6259b15a3654f95b4f9f0a650b1 (diff)
downloadfreebsd-ports-gnome-0ff6d1309a8949872406731ae402a1958be15495.tar.gz
freebsd-ports-gnome-0ff6d1309a8949872406731ae402a1958be15495.tar.zst
freebsd-ports-gnome-0ff6d1309a8949872406731ae402a1958be15495.zip
Follow mod_php4:
Help "make describe" to find dependencies properly.
Diffstat (limited to 'www')
-rw-r--r--www/mod_php3/Makefile8
-rw-r--r--www/mod_php3/scripts/configure.php6
2 files changed, 14 insertions, 0 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index 1fa644893745..3f3428d5d5f3 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -103,4 +103,12 @@ post-clean:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
+# XXX:
+# Has to be kept in sync with the defaults in configure.php
+.ifndef(WITHOUT_MYSQL)
+.ifmake describe
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+.endif
+.endif
+
.include <bsd.port.mk>
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index f46e1ffa0547..737e0381ab7f 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -92,6 +92,7 @@ while [ "$1" ]; do
\"MySQL\")
echo "LIB_DEPENDS+= mysqlclient.10:\${PORTSDIR}/databases/mysql323-client"
echo "CONFIGURE_ARGS+=--with-mysql=\${PREFIX}"
+ MYSQL=1
;;
\"PostgreSQL\")
echo "POSTGRESQL_PORT?= databases/postgresql7"
@@ -179,3 +180,8 @@ done
if [ "${LIBS}" ]; then
echo "CONFIGURE_ENV+= LIBS='${LIBS}'"
fi
+
+if [ -z "${MYSQL}" ]; then
+ echo "WITHOUT_MYSQL= 1"
+fi
+