aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-12-29 03:18:04 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-12-29 03:18:04 +0800
commit127a5be0223d0e7ec0bb1627a868164d5acc1260 (patch)
tree88721a5d5850aeb5cd92d4332633e2e0ef055cb2 /www
parent5d7acd643b01eb2f78feb1f951da6b5a22d148e9 (diff)
downloadfreebsd-ports-gnome-127a5be0223d0e7ec0bb1627a868164d5acc1260.tar.gz
freebsd-ports-gnome-127a5be0223d0e7ec0bb1627a868164d5acc1260.tar.zst
freebsd-ports-gnome-127a5be0223d0e7ec0bb1627a868164d5acc1260.zip
- Pet portlint
- Fix LICENSE - Remove bogus (in presence of USE_GITHUB) USES=tar* - Switch to options helpers Approved by: portmgr blanket
Diffstat (limited to 'www')
-rw-r--r--www/bareos-webui/Makefile31
1 files changed, 10 insertions, 21 deletions
diff --git a/www/bareos-webui/Makefile b/www/bareos-webui/Makefile
index 03c56bb30fc2..62193ab876b7 100644
--- a/www/bareos-webui/Makefile
+++ b/www/bareos-webui/Makefile
@@ -2,22 +2,21 @@
# $FreeBSD$
PORTNAME= bareos-webui
+PORTVERSION= 16.2.4
DISTVERSIONPREFIX= Release/
-DISTVERSION= 16.2.4
-PORTREVISION= 0
CATEGORIES= www sysutils
MAINTAINER= acm@FreeBSD.org
-COMMENT= A PHP-Frontend to manage Bareos over the web
+COMMENT= PHP-Frontend to manage Bareos over the web
-LICENSE= AGPLv3 # or later
+LICENSE= AGPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= bareos
GH_PROJECT= bareos-webui
-USES= tar:tgz
+USES= php
USE_PHP= openssl
NO_BUILD= yes
NO_ARCH= yes
@@ -32,19 +31,9 @@ OPTIONS_DEFINE= MYSQL PGSQL ZENDFRAMEWORK
OPTIONS_DEFAULT= PGSQL
ZENDFRAMEWORK_DESC= Install zend framework
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= pdo_mysql
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pdo_pgsql
-.endif
-
-.if ${PORT_OPTIONS:MZENDFRAMEWORK}
-RUN_DEPENDS= ${LOCALBASE}/share/ZendFramework/bin/classmap_generator.php:www/zend-framework
-.endif
+MYSQL_USE= PHP=pdo_mysql
+PGSQL_USE= PHP=pdo_pgsql
+ZENDFRAMEWORK_RUN_DEPENDS= ${LOCALBASE}/share/ZendFramework/bin/classmap_generator.php:www/zend-framework
post-extract:
${RM} ${WRKSRC}/config/autoload/.gitignore
@@ -56,9 +45,9 @@ post-patch:
do-install:
@${ECHO} "Installing in ${BAREOSWEB_HOME}"
- ${MKDIR} ${STAGEDIR}${ETCDIR}/bareos-dir.d/console
- ${MKDIR} ${STAGEDIR}${ETCDIR}/bareos-dir.d/profile
- ${MKDIR} ${STAGEDIR}${BAREOSWEB_HOME}
+ @${MKDIR} ${STAGEDIR}${ETCDIR}/bareos-dir.d/console
+ @${MKDIR} ${STAGEDIR}${ETCDIR}/bareos-dir.d/profile
+ @${MKDIR} ${STAGEDIR}${BAREOSWEB_HOME}
cd ${WRKSRC} && ${COPYTREE_SHARE} "config data module public vendor" \
${STAGEDIR}${BAREOSWEB_HOME}
${INSTALL_DATA} ${WRKSRC}/*.php ${STAGEDIR}${BAREOSWEB_HOME}