aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-31 18:10:44 +0800
committermiwi <miwi@FreeBSD.org>2009-05-31 18:10:44 +0800
commit1359c9bf5da1d54286fb4e0c09096b05188fd775 (patch)
tree59ad5dda1ef6f5c2ff32c7257d60b10169c606e5 /www
parent2d6c1c335f7da84184c928e71005108a81b7a49c (diff)
downloadfreebsd-ports-gnome-1359c9bf5da1d54286fb4e0c09096b05188fd775.tar.gz
freebsd-ports-gnome-1359c9bf5da1d54286fb4e0c09096b05188fd775.tar.zst
freebsd-ports-gnome-1359c9bf5da1d54286fb4e0c09096b05188fd775.zip
e107 is a content management system written in PHP and using the
popular open source MySQL database system for content storage. It's completely free, totally customisable and in constant development. WWW: http://www.e107.org/ PR: ports/135090 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/e107/Makefile53
-rw-r--r--www/e107/distinfo3
-rw-r--r--www/e107/files/pkg-message.in32
-rw-r--r--www/e107/pkg-descr5
5 files changed, 94 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 39a7a68e5bca..2a0d2d98bf6d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -175,6 +175,7 @@
SUBDIR += drupal6-views
SUBDIR += dtse
SUBDIR += dummyflash
+ SUBDIR += e107
SUBDIR += eaccelerator
SUBDIR += efront
SUBDIR += eldav.el
diff --git a/www/e107/Makefile b/www/e107/Makefile
new file mode 100644
index 000000000000..6fcb66a86c9c
--- /dev/null
+++ b/www/e107/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: e107
+# Date created: 31 May, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= e107
+PORTVERSION= 0.7.15
+CATEGORIES= www
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_v${PORTVERSION}_full
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A content management system written in PHP
+
+USE_PHP= mysql xml
+WRKSRC= ${WRKDIR}/e107
+
+.include <bsd.port.pre.mk>
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= E107DIR=${E107DIR}
+E107DIR= www/e107
+
+post-extract:
+ @cd ${WRKDIR} && ${MKDIR} ${WRKSRC}
+ @cd ${WRKDIR} && ${MV} *.php ${WRKSRC}
+ @cd ${WRKDIR} && ${MV} e107_* ${WRKSRC}
+ @cd ${WRKDIR} && ${MV} e107.htaccess ${WRKSRC}
+ @cd ${WRKDIR} && ${MV} favicon.ico ${WRKSRC}
+ @cd ${WRKDIR} && ${MV} robots.txt ${WRKSRC}
+
+pre-install:
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s#${WRKSRC}#${E107DIR}#g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s#${WRKSRC}#@dirrm ${E107DIR}#g" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @${CHMOD} -R 755 ${WWWDIR}
+
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' \
+ >> ${TMPPLIST}
+ @${ECHO_CMD} '@exec ${CHMOD} -R 755 ${WWWDIR}' \
+ >> ${TMPPLIST}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/e107/distinfo b/www/e107/distinfo
new file mode 100644
index 000000000000..9b8db6158c5f
--- /dev/null
+++ b/www/e107/distinfo
@@ -0,0 +1,3 @@
+MD5 (e107_v0.7.15_full.tar.gz) = 0a6ab0f1753ac827588614b654334642
+SHA256 (e107_v0.7.15_full.tar.gz) = 0abb0cccc2adbb18aa9336e77ccb312095322d1111a78f96105627d8fb30d54a
+SIZE (e107_v0.7.15_full.tar.gz) = 3219604
diff --git a/www/e107/files/pkg-message.in b/www/e107/files/pkg-message.in
new file mode 100644
index 000000000000..f72a9454ad64
--- /dev/null
+++ b/www/e107/files/pkg-message.in
@@ -0,0 +1,32 @@
+POST-INSTALL CONFIGURATION FOR e107
+=====================================
+
+1) Create a user and a database for e107 to store all
+ its tables in (or choose an existing database).
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ ### Add the AcceptPathInfo directive only for Apache 2.0.30 or later.
+ Alias /e107 %%PREFIX%%/%%E107DIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%E107DIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+
+3) Visit your e107 site with a browser (i.e.,
+ http://your.server.com/e107/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up e107, creating an admin account, etc.
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://wiki.e107.org/?title=HOWTO:Install_e107
+ http://wiki.e107.org/?title=HOWTO:Install_troubleshoot
+
+Enjoying it !
+
+=========================================================
diff --git a/www/e107/pkg-descr b/www/e107/pkg-descr
new file mode 100644
index 000000000000..c02ece06cddd
--- /dev/null
+++ b/www/e107/pkg-descr
@@ -0,0 +1,5 @@
+e107 is a content management system written in PHP and using the
+popular open source MySQL database system for content storage.
+It's completely free, totally customisable and in constant development.
+
+WWW: http://www.e107.org/