aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-03 02:39:46 +0800
committererwin <erwin@FreeBSD.org>2005-12-03 02:39:46 +0800
commit14cc8c3a51e725f9c09a8c065aa6952db5629088 (patch)
treedc8bf5f9e0563989c7331f92e8115667ff38fcf3 /www
parent30fabfdd26edc3c12f76988b0514c98ac252e834 (diff)
downloadfreebsd-ports-gnome-14cc8c3a51e725f9c09a8c065aa6952db5629088.tar.gz
freebsd-ports-gnome-14cc8c3a51e725f9c09a8c065aa6952db5629088.tar.zst
freebsd-ports-gnome-14cc8c3a51e725f9c09a8c065aa6952db5629088.zip
This plugin allows your controller class to dispatch XMLRPC methods from
its own class. WWW: http://search.cpan.org/dist/Catalyst-Plugin-XMLRPC/ PR: ports/89844 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-XMLRPC/Makefile30
-rw-r--r--www/p5-Catalyst-Plugin-XMLRPC/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-XMLRPC/pkg-descr4
-rw-r--r--www/p5-Catalyst-Plugin-XMLRPC/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 860842025bd5..dbc1d42eb07d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -509,6 +509,7 @@
SUBDIR += p5-Catalyst-Plugin-Static
SUBDIR += p5-Catalyst-Plugin-SubRequest
SUBDIR += p5-Catalyst-Plugin-Textile
+ SUBDIR += p5-Catalyst-Plugin-XMLRPC
SUBDIR += p5-Catalyst-View-HTML-Template
SUBDIR += p5-Catalyst-View-TT
SUBDIR += p5-Class-DBI-FromForm
diff --git a/www/p5-Catalyst-Plugin-XMLRPC/Makefile b/www/p5-Catalyst-Plugin-XMLRPC/Makefile
new file mode 100644
index 000000000000..5df65d40b533
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-XMLRPC/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-XMLRPC
+# Date created: 2 Dec 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-XMLRPC
+PORTVERSION= 0.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SR/SRI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Dispatch XMLRPC with Catalyst
+
+BUILD_DEPENDS= p5-Catalyst>=5.01:${PORTSDIR}/www/p5-Catalyst \
+ p5-RPC-XML>=0.45:${PORTSDIR}/net/p5-RPC-XML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::XMLRPC.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-XMLRPC/distinfo b/www/p5-Catalyst-Plugin-XMLRPC/distinfo
new file mode 100644
index 000000000000..4df25b28f727
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-XMLRPC/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-XMLRPC-0.06.tar.gz) = 71ac8c2d1ea026190092a72b65291cb7
+SHA256 (Catalyst-Plugin-XMLRPC-0.06.tar.gz) = 7f70491214a4b17f712e96de3f11101814b8962573f559d1f34a5e64a3fb5adc
+SIZE (Catalyst-Plugin-XMLRPC-0.06.tar.gz) = 3916
diff --git a/www/p5-Catalyst-Plugin-XMLRPC/pkg-descr b/www/p5-Catalyst-Plugin-XMLRPC/pkg-descr
new file mode 100644
index 000000000000..8d523f9d159a
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-XMLRPC/pkg-descr
@@ -0,0 +1,4 @@
+This plugin allows your controller class to dispatch XMLRPC methods from
+its own class.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-XMLRPC/
diff --git a/www/p5-Catalyst-Plugin-XMLRPC/pkg-plist b/www/p5-Catalyst-Plugin-XMLRPC/pkg-plist
new file mode 100644
index 000000000000..d0850b6a9105
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-XMLRPC/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Catalyst/Plugin/XMLRPC.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/XMLRPC/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/XMLRPC 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true