aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-10-04 08:08:39 +0800
committeredwin <edwin@FreeBSD.org>2007-10-04 08:08:39 +0800
commit20b96b7fbcb96822c60f131033529f90bb4d89e6 (patch)
tree6ee1e660490687dbacdb28dd53de6408b30cd779 /www
parent33de379b2b19f34cf6e1c6ecd3e605aec60ca530 (diff)
downloadfreebsd-ports-gnome-20b96b7fbcb96822c60f131033529f90bb4d89e6.tar.gz
freebsd-ports-gnome-20b96b7fbcb96822c60f131033529f90bb4d89e6.tar.zst
freebsd-ports-gnome-20b96b7fbcb96822c60f131033529f90bb4d89e6.zip
Remove support for OSVERSION < 5
Diffstat (limited to 'www')
-rw-r--r--www/linuxpluginwrapper/Makefile14
-rw-r--r--www/lynx-current/Makefile6
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid25/Makefile2
-rw-r--r--www/squid30/Makefile2
-rw-r--r--www/squid31/Makefile2
-rw-r--r--www/ssserver/Makefile10
7 files changed, 11 insertions, 27 deletions
diff --git a/www/linuxpluginwrapper/Makefile b/www/linuxpluginwrapper/Makefile
index 9b941465971d..3ac1f56b2bd9 100644
--- a/www/linuxpluginwrapper/Makefile
+++ b/www/linuxpluginwrapper/Makefile
@@ -38,12 +38,6 @@ RUN_DEPENDS+= ${X11BASE}/Adobe/Acrobat7.0/ENU/Browser/intellinux/nppdf.so:${PORT
WITH_PLUGINS= 1
.endif
-.if defined(WITH_PLUGINS)
-.if ${OSVERSION} < 500000
-USE_MOTIF= yes
-.endif
-.endif
-
ONLY_FOR_ARCHS= i386
MAKE_ENV= EXAMPLESDIR=${EXAMPLESDIR} INSTALL_DATA="${INSTALL_DATA}" INSTALL_PROGRAM="${INSTALL_PROGRAM}"
@@ -51,7 +45,7 @@ CONFLICTS= flashpluginwrapper-*
USE_XLIB= yes
PLIST_SUB= LINUXBASE=${LINUXBASE}
PKGMESSAGE= ${WRKDIR}/pkg-message
-.if !defined(WITH_PLUGINS) || ${OSVERSION} < 500000
+.if !defined(WITH_PLUGINS)
PLIST= ${WRKDIR}/pkg-plist
.endif
@@ -61,10 +55,8 @@ LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD6
LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD6
.elif ${OSVERSION} >= 503001
LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD5-stable
-.elif ${OSVERSION} >= 500000
-LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD5-current
.else
-LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD4.x
+LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD5-current
.endif
.if ${OSVERSION} < 501105
@@ -78,7 +70,7 @@ CFLAGS+= -DDEBUG=1
.endif
.if !defined(PACKAGE_BUILDING)
-.if ${OSVERSION} < 490102 || ${OSVERSION} >= 500000 && ${OSVERSION} < 501107
+.if ${OSVERSION} < 501107
pre-everything::
@if ! strings ${RTLD} | ${GREP} libmap.conf > /dev/null 2>&1; then \
${ECHO_MSG} 'Please enable libmap.conf(5) feature for rtld(1).'; \
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index 75d286c2e39c..72398a4f470a 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -48,11 +48,7 @@ CONFIGURE_ARGS+= --with-screen=ncursesw
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.endif
-.if ${OSVERSION} >= 400014
-CONFIGURE_ARGS+= --enable-ipv6
-.else
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
+CONFIGURE_ARGS+=--enable-ipv6
MAKE_FLAGS= helpdir=${L_HELP} docdir=${L_DOC} -f
MAKEFILE= makefile
INSTALL_TARGET= install-full
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 29e4f322b7b0..5b2299e43284 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -346,7 +346,7 @@ IGNORE= pf available only in FreeBSD 5.3 and newer
# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} >= 470000 && ${OSVERSION} < 500000) || (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
+.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
IGNORE= the IPFilter headers are not part of the base system
.else
CONFIGURE_ARGS+= --enable-ipf-transparent
diff --git a/www/squid25/Makefile b/www/squid25/Makefile
index 91f96e13a20a..99a8c20cccac 100644
--- a/www/squid25/Makefile
+++ b/www/squid25/Makefile
@@ -313,7 +313,7 @@ IGNORE= pf available only in FreeBSD 5.3 and newer
# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} >= 470000 && ${OSVERSION} < 500000) || (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
+.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
IGNORE= IPFilter headers are not part of the base system
.else
CONFIGURE_ARGS+= --enable-ipf-transparent
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 96cfb4ea43cb..73ef1c292acd 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -341,7 +341,7 @@ IGNORE= pf available only in FreeBSD 5.3 and newer
# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} >= 470000 && ${OSVERSION} < 500000) || (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
+.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
IGNORE= the IPFilter headers are not part of the base system
.else
CONFIGURE_ARGS+= --enable-ipf-transparent
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 96cfb4ea43cb..73ef1c292acd 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -341,7 +341,7 @@ IGNORE= pf available only in FreeBSD 5.3 and newer
# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} >= 470000 && ${OSVERSION} < 500000) || (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
+.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
IGNORE= the IPFilter headers are not part of the base system
.else
CONFIGURE_ARGS+= --enable-ipf-transparent
diff --git a/www/ssserver/Makefile b/www/ssserver/Makefile
index ac7172b132df..58b50b1e6e07 100644
--- a/www/ssserver/Makefile
+++ b/www/ssserver/Makefile
@@ -13,17 +13,13 @@ MASTER_SITES= http://www.kryltech.com/download/FreeBSD.x86.3/
MAINTAINER= support@kryltech.com
COMMENT= Adds the search capability to a Web site
+LIB_DEPENDS= c.3:${PORTSDIR}/misc/compat3x
+
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
INSTALL_RWDATA= ${INSTALL} ${COPY} -o ${SHAREOWN} -g ${SHAREGRP} -m 666
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 400000
-LIB_DEPENDS+= c.3:${PORTSDIR}/misc/compat3x
-.endif
-
do-install:
@${MKDIR} ${PREFIX}/www/cgi-bin/ssserverdata
@${INSTALL_PROGRAM} ${WRKSRC}/ssserver ${PREFIX}/www/cgi-bin
@@ -89,4 +85,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>