aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2009-04-21 19:37:33 +0800
committerosa <osa@FreeBSD.org>2009-04-21 19:37:33 +0800
commit26bdf553de6cc0d25d8f12946ae1f88ae2a02594 (patch)
tree06ca93c377fa9bb09c3731673c433421167aed97 /www
parentc50fdbea14722e6c0b4106833aa63b5ba8414136 (diff)
downloadfreebsd-ports-gnome-26bdf553de6cc0d25d8f12946ae1f88ae2a02594.tar.gz
freebsd-ports-gnome-26bdf553de6cc0d25d8f12946ae1f88ae2a02594.tar.zst
freebsd-ports-gnome-26bdf553de6cc0d25d8f12946ae1f88ae2a02594.zip
Update from 0.7.51 to 0.7.52.
Update third-party upload module from 2.0.8 to 2.0.9 and remove needless extra patch. Add support for third-party modules: o Phusion Passenger(tm) 2.2.1 o mogilefs 1.0.1 <nginx development ChangeLog> *) Feature: the first native Windows binary release. *) Bugfix: in processing HEAD method while caching. *) Bugfix: in processing the "If-Modified-Since", "If-Range", etc. client request header lines while caching. *) Bugfix: now the "Set-Cookie" and "P3P" header lines are hidden in cacheable responses. *) Bugfix: if nginx was built with the ngx_http_perl_module and with a perl which supports threads, then during a master process exit the message "panic: MUTEX_LOCK" might be issued. *) Bugfix: nginx could not be built --without-http-cache; the bug had appeared in 0.7.48. *) Bugfix: nginx could not be built on platforms different from i386, amd64, sparc, and ppc; the bug had appeared in 0.7.42. </ChangeLog>
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile36
-rw-r--r--www/nginx-devel/distinfo18
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_upload_module.c27
3 files changed, 40 insertions, 41 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 673f0773a122..a6592693f1e5 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.7.51
+PORTVERSION= 0.7.52
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -27,6 +27,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_FANCYINDEX_MODULE "Enable http_fancyindex module" off \
HTTP_FLV_MODULE "Enable http_flv module" off \
HTTP_GZIP_STATIC_MODULE "Enable http_gzip_static module" off \
+ HTTP_MOGILEFS_MODULE "Enable mogilefs module" off \
HTTP_PERL_MODULE "Enable http_perl module" off \
HTTP_RANDOM_INDEX_MODULE "Enable http_random_index module" off \
HTTP_REALIP_MODULE "Enable http_realip module" off \
@@ -47,6 +48,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
MAIL_POP3_MODULE "Enable POP3 proxy module" off \
MAIL_SMTP_MODULE "Enable SMTP proxy module" off \
MAIL_SSL_MODULE "Enable mail_ssl module" off \
+ PASSENGER_MODULE "Enable passenger module" off \
WWW "Enable html sample files" on
WANT_GNOME= yes
@@ -132,6 +134,13 @@ CONFIGURE_ARGS+=--with-http_flv_module
CONFIGURE_ARGS+=--with-http_gzip_static_module
.endif
+.if defined(WITH_HTTP_MOGILEFS_MODULE)
+NGINX_MOGILEFS_MODULE_VERSION= 1.0.1
+MASTER_SITES+= http://www.grid.net.ru/nginx/download/:mogilefs
+DISTFILES+= nginx_mogilefs_module-${NGINX_MOGILEFS_MODULE_VERSION}.tar.gz:mogilefs
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_mogilefs_module-${NGINX_MOGILEFS_MODULE_VERSION}
+.endif
+
.if defined(WITH_HTTP_PERL_MODULE)
CATEGORIES+= perl5
CONFIGURE_ARGS+=--with-http_perl_module
@@ -171,8 +180,8 @@ CONFIGURE_ARGS+=--with-http_sub_module
.endif
.if defined(WITH_HTTP_UPLOAD_MODULE)
-NGINX_UPLOAD_MODULE_VERSION= 2.0.8
-MASTER_SITES+= http://grid.net.ru/nginx/download/:upload
+NGINX_UPLOAD_MODULE_VERSION= 2.0.9
+MASTER_SITES+= http://www.grid.net.ru/nginx/download/:upload
DISTFILES+= nginx_upload_module-${NGINX_UPLOAD_MODULE_VERSION}.tar.gz:upload
CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_upload_module-${NGINX_UPLOAD_MODULE_VERSION}
.endif
@@ -222,6 +231,14 @@ LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+=--with-pcre
.endif
+.if defined(WITH_PASSENGER_MODULE)
+USE_RAKE= yes
+PASSENGER_VERSION= 2.2.1
+MASTER_SITES+= RF/passenger/:passenger
+DISTFILES+= passenger-${PASSENGER_VERSION}.tar.gz:passenger
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
+.endif
+
.if defined(WITH_WWW)
PLIST_SUB+= WWWDATA=""
.else
@@ -257,11 +274,14 @@ CONFIGURE_ARGS+=--with-mail_ssl_module
PLIST_SUB+= NGINX_TMPDIR=${NGINX_TMPDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
pre-everything::
-.if defined(WITH_HTTP_UPSTREAM_FAIR)
@${ECHO_MSG}
+.if defined(WITH_HTTP_UPSTREAM_FAIR)
@${ECHO_MSG} "Enable http_ssl module to build upstream_fair with SSL support"
- @${ECHO_MSG}
.endif
+.if defined(WITH_PASSENGER_MODULE)
+ @${ECHO_MSG} "This port install Passenger module only"
+.endif
+ @${ECHO_MSG}
post-patch:
@${REINPLACE_CMD} 's!%%HTTP_PORT%%!${HTTP_PORT}!; \
@@ -276,9 +296,9 @@ post-patch:
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_fancyindex_module.c
.endif
-.if defined(WITH_HTTP_UPLOAD_MODULE)
- @${PATCH} ${PATCH_ARGS} < \
- ${PATCHDIR}/extra-patch-ngx_http_upload_module.c
+.if defined(WITH_PASSENGER_MODULE)
+ @${REINPLACE_CMD} 's!g++!${CXX}!' \
+ ${WRKDIR}/passenger-${PASSENGER_VERSION}/Rakefile
.endif
do-build:
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 79e55ff2a7b2..10e08478f338 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,18 +1,21 @@
-MD5 (nginx-0.7.51.tar.gz) = c2455e4c8656b72eb31abcf6a9798df7
-SHA256 (nginx-0.7.51.tar.gz) = f155372c309ccd1cfc3bcdd2e7e705cdbbbeb034dbe7b3393604d4755daed818
-SIZE (nginx-0.7.51.tar.gz) = 580960
+MD5 (nginx-0.7.52.tar.gz) = 46ed0881cccaadb9b6a37bee0936efa0
+SHA256 (nginx-0.7.52.tar.gz) = 1fe21795c6ec5255a76a3929cbfb4ee92cf8bdaeba4081d6b479ccac38c104dc
+SIZE (nginx-0.7.52.tar.gz) = 582234
MD5 (nginx-accesskey-2.0.3.tar.gz) = 9b5304346d5139b1841f5baa01ab0cbe
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
MD5 (nginx-fancyindex-0.1_beta5.tar.bz2) = ac371c8c03e7235f1e8e8c187a5a93cb
SHA256 (nginx-fancyindex-0.1_beta5.tar.bz2) = 155c0fac05a7f6c013b5cc368926d71d5da73e4e5a9f2506b2e5114eee8680a2
SIZE (nginx-fancyindex-0.1_beta5.tar.bz2) = 12211
+MD5 (nginx_mogilefs_module-1.0.1.tar.gz) = c45947ec9aebe83398d4c9604e843023
+SHA256 (nginx_mogilefs_module-1.0.1.tar.gz) = f862d48e50683a808bb8e305474d1b9800800bd0ea64ebcc258a4c7f3ecd9bfb
+SIZE (nginx_mogilefs_module-1.0.1.tar.gz) = 6834
MD5 (ngx_http_response-0.3.tar.gz) = 178a8f13a41388ef50b3726fa9fede50
SHA256 (ngx_http_response-0.3.tar.gz) = 0835584029f053051c624adbe33a826ab0205c9d85a02af6019e6b57607e9045
SIZE (ngx_http_response-0.3.tar.gz) = 2244
-MD5 (nginx_upload_module-2.0.8.tar.gz) = 308d43743158263b0d5016aeffadaaa7
-SHA256 (nginx_upload_module-2.0.8.tar.gz) = eaacf4dd4d254df5f2666e13f07edd8c1c7e51ddfe625b88e422583cfbcb6165
-SIZE (nginx_upload_module-2.0.8.tar.gz) = 17497
+MD5 (nginx_upload_module-2.0.9.tar.gz) = bd8ee6011e3e24805c8ead617211a04b
+SHA256 (nginx_upload_module-2.0.9.tar.gz) = 3c43e185f85a5a719de2cd02083ae0802a8fd2645c79a78c7d37c3d1f0361f9f
+SIZE (nginx_upload_module-2.0.9.tar.gz) = 18232
MD5 (nginx_uploadprogress_module-0.5.tar.gz) = 04cca031be26a0a37a24b8b2d475c77a
SHA256 (nginx_uploadprogress_module-0.5.tar.gz) = b025bf8ea2e1cf405dd72587d52eb48135cb7b0843a2dbfcf91c8f562701d75c
SIZE (nginx_uploadprogress_module-0.5.tar.gz) = 11578
@@ -25,3 +28,6 @@ SIZE (ngx_http_upstream_keepalive-0.1.tar.gz) = 4978
MD5 (nginx_mod_zip-1.1.4.tar.gz) = be934138446793ca783ebfcc1a74883d
SHA256 (nginx_mod_zip-1.1.4.tar.gz) = d152861779a7b04634e6e0b87a53707ccad06e00bba65246b9005ddc8d0f654b
SIZE (nginx_mod_zip-1.1.4.tar.gz) = 17446
+MD5 (passenger-2.2.1.tar.gz) = ebdc6ec4c3b841efc1b065f3a226b007
+SHA256 (passenger-2.2.1.tar.gz) = 88d8db88a836b81d70ec590d287c6bc564472c0a952a1101a90807c1a76329f7
+SIZE (passenger-2.2.1.tar.gz) = 1770447
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_upload_module.c b/www/nginx-devel/files/extra-patch-ngx_http_upload_module.c
deleted file mode 100644
index 7f2131490168..000000000000
--- a/www/nginx-devel/files/extra-patch-ngx_http_upload_module.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- ../nginx_upload_module-2.0.8/ngx_http_upload_module.c.orig 2009-03-24 10:43:49.000000000 +0300
-+++ ../nginx_upload_module-2.0.8/ngx_http_upload_module.c 2009-03-24 11:06:15.000000000 +0300
-@@ -208,6 +208,10 @@
- void *conf);
- static void ngx_upload_cleanup_handler(void *data);
-
-+static ngx_path_init_t ngx_http_upload_temp_path = {
-+ ngx_string(NGX_HTTP_PROXY_TEMP_PATH), { 1, 2, 0 }
-+};
-+
- /*
- * upload_init_ctx
- *
-@@ -1145,10 +1149,10 @@
-
- ngx_conf_merge_str_value(conf->url, prev->url, "");
-
-- ngx_conf_merge_path_value(conf->store_path,
-+ ngx_conf_merge_path_value(cf,
-+ &conf->store_path,
- prev->store_path,
-- NGX_HTTP_PROXY_TEMP_PATH, 1, 2, 0,
-- ngx_garbage_collector_temp_handler, cf);
-+ &ngx_http_upload_temp_path);
-
- ngx_conf_merge_uint_value(conf->store_access,
- prev->store_access, 0600);