aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-06-23 02:44:17 +0800
committerrakuco <rakuco@FreeBSD.org>2014-06-23 02:44:17 +0800
commit2a03266e09a78fe0ac3f6eed4070b82aeb4a4727 (patch)
treebc3326f1f208637cbd73223c1ead452c75fa1482 /www
parent7921f077eca6ebf287ebdd6fe8435a38794a82ef (diff)
downloadfreebsd-ports-gnome-2a03266e09a78fe0ac3f6eed4070b82aeb4a4727.tar.gz
freebsd-ports-gnome-2a03266e09a78fe0ac3f6eed4070b82aeb4a4727.tar.zst
freebsd-ports-gnome-2a03266e09a78fe0ac3f6eed4070b82aeb4a4727.zip
Update to 1.1.1.
PR: 191271 Submitted by: gaod@hychen.org (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/pecl-solr/Makefile5
-rw-r--r--www/pecl-solr/distinfo4
-rw-r--r--www/pecl-solr/files/patch-config.m443
-rw-r--r--www/pecl-solr/files/patch-php_solr.c10
4 files changed, 18 insertions, 44 deletions
diff --git a/www/pecl-solr/Makefile b/www/pecl-solr/Makefile
index 32fa78534006..66437033eca0 100644
--- a/www/pecl-solr/Makefile
+++ b/www/pecl-solr/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= solr
-PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTVERSION= 1.1.1
CATEGORIES= www
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -13,7 +12,7 @@ MAINTAINER= gaod@hychen.org
COMMENT= The Apache Solr PHP extension
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- xml2:${PORTSDIR}/textproc/libxml2
+ xml2:${PORTSDIR}/textproc/libxml2
USE_PHP= json
USE_PHPEXT= yes
diff --git a/www/pecl-solr/distinfo b/www/pecl-solr/distinfo
index 28936115d99c..71a1cf8d681f 100644
--- a/www/pecl-solr/distinfo
+++ b/www/pecl-solr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (solr-1.0.2.tgz) = d5868daab01290f820b4b754e3c560dc6e983f82d9f6640b3146cede4d9a8581
-SIZE (solr-1.0.2.tgz) = 101292
+SHA256 (solr-1.1.1.tgz) = 2acc9026bdac5adf46e42e7faf95272f1bcd2c5ba447f7259efb03499749a138
+SIZE (solr-1.1.1.tgz) = 111188
diff --git a/www/pecl-solr/files/patch-config.m4 b/www/pecl-solr/files/patch-config.m4
index 0254417537ea..43d3ebcd966a 100644
--- a/www/pecl-solr/files/patch-config.m4
+++ b/www/pecl-solr/files/patch-config.m4
@@ -1,36 +1,11 @@
---- config.m4.orig 2011-11-29 10:49:53.000000000 +0800
-+++ config.m4 2013-01-27 23:53:10.000000000 +0800
-@@ -56,8 +56,8 @@ else
- fi
-
- PHP_ADD_INCLUDE($CURL_DIR/include)
--PHP_EVAL_LIBLINE($CURL_LIBS, CURL_SHARED_LIBADD)
--PHP_ADD_LIBRARY_WITH_PATH(curl, $CURL_DIR/$PHP_LIBDIR, CURL_SHARED_LIBADD)
-+PHP_EVAL_LIBLINE($CURL_LIBS, SOLR_SHARED_LIBADD)
-+PHP_ADD_LIBRARY_WITH_PATH(curl, $CURL_DIR/$PHP_LIBDIR, SOLR_SHARED_LIBADD)
-
- PHP_ARG_ENABLE(solr, whether to enable the Solr extension,
- [ --enable-solr Enable solr support])
-@@ -72,11 +72,11 @@ dnl Setting up the apache Solr extension
- if test "$PHP_SOLR" != "no"; then
-
- if test "$PHP_CURL" = "no"; then
-- AC_MSG_ERROR([SOAP extension requires curl extension, add --with-curl])
-+ AC_MSG_ERROR([SOLR extension requires curl extension, add --with-curl])
- fi
+--- config.m4.orig 2014-06-22 18:58:51.253187297 +0800
++++ config.m4 2014-06-22 19:01:04.313188083 +0800
+@@ -82,7 +82,7 @@
+
+ PHP_ADD_INCLUDE($CURL_DIR/include)
+ PHP_EVAL_LIBLINE($CURL_LIBS, SOLR_SHARED_LIBADD)
+- PHP_ADD_LIBRARY_WITH_PATH(curl, $CURL_DIR/lib, SOLR_SHARED_LIBADD)
++ PHP_ADD_LIBRARY_WITH_PATH(curl, $CURL_DIR/$PHP_LIBDIR, SOLR_SHARED_LIBADD)
if test "$PHP_LIBXML" = "no"; then
-- AC_MSG_ERROR([SOAP extension requires LIBXML extension, add --enable-libxml])
-+ AC_MSG_ERROR([SOLR extension requires LIBXML extension, add --enable-libxml])
- fi
-
- PHP_SETUP_LIBXML(SOLR_SHARED_LIBADD, [
-@@ -100,7 +100,7 @@ if test "$PHP_SOLR" != "no"; then
- solr_functions_response.c \
- solr_functions_debug.c],
- $ext_shared)
-- PHP_SUBST(SOAP_SHARED_LIBADD)
-+ PHP_SUBST(SOLR_SHARED_LIBADD)
- ], [
- AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
- ])
+ AC_MSG_ERROR([Solr extension requires LIBXML extension, add --enable-libxml])
diff --git a/www/pecl-solr/files/patch-php_solr.c b/www/pecl-solr/files/patch-php_solr.c
index 48a84f539fa1..d07ffb51872f 100644
--- a/www/pecl-solr/files/patch-php_solr.c
+++ b/www/pecl-solr/files/patch-php_solr.c
@@ -1,11 +1,11 @@
---- php_solr.c.orig 2013-01-28 00:00:42.000000000 +0800
-+++ php_solr.c 2013-01-28 00:00:54.000000000 +0800
-@@ -879,8 +879,6 @@ static zend_function_entry solr_utils_me
+--- php_solr.c.orig 2014-06-22 19:01:39.785187204 +0800
++++ php_solr.c 2014-06-22 19:02:20.171185939 +0800
+@@ -901,8 +901,6 @@
/* {{{ solr_module_deps */
static zend_module_dep solr_module_deps[] = {
-- ZEND_MOD_REQUIRED(PHP_CURL_EXTENSION_NAME)
- ZEND_MOD_REQUIRED(PHP_LIBXML_EXTENSION_NAME)
-
+- ZEND_MOD_REQUIRED(PHP_JSON_EXTENSION_NAME)
{ NULL, NULL, NULL }
};
+ /* }}} */