aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2011-04-26 15:08:32 +0800
committerkevlo <kevlo@FreeBSD.org>2011-04-26 15:08:32 +0800
commit2c3c741faa4077b6a23ac13de364bf4f051ea196 (patch)
treef2847014d31d103811c40e28b0d99b66fb81458a /www
parentae6bbcf14fa99c8fdf65d960ca6d04170c211138 (diff)
downloadfreebsd-ports-gnome-2c3c741faa4077b6a23ac13de364bf4f051ea196.tar.gz
freebsd-ports-gnome-2c3c741faa4077b6a23ac13de364bf4f051ea196.tar.zst
freebsd-ports-gnome-2c3c741faa4077b6a23ac13de364bf4f051ea196.zip
Initial import of hotcrp 2.45.
HotCRP is conference management software: it accepts paper submissions and manages the review process.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/hotcrp/Makefile43
-rw-r--r--www/hotcrp/distinfo2
-rw-r--r--www/hotcrp/files/pkg-message.in22
-rw-r--r--www/hotcrp/pkg-descr4
5 files changed, 72 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5168b6eb09f9..06858d41f5d5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -307,6 +307,7 @@
SUBDIR += horde-passwd
SUBDIR += horde-trean
SUBDIR += horde-wicked
+ SUBDIR += hotcrp
SUBDIR += hs-HTTP
SUBDIR += hs-cgi
SUBDIR += hs-fastcgi
diff --git a/www/hotcrp/Makefile b/www/hotcrp/Makefile
new file mode 100644
index 000000000000..06f3fa23aaec
--- /dev/null
+++ b/www/hotcrp/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: hotcrp
+# Date created: 26 April 2011
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hotcrp
+PORTVERSION= 2.45
+CATEGORIES= www
+MASTER_SITES= http://www.cs.ucla.edu/~kohler/hotcrp/
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= A web based conference management software
+
+RUN_DEPENDS= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail \
+ ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime \
+ pdftohtml:${PORTSDIR}/textproc/pdftohtml
+USE_PHP= mysql gd
+
+PEARDIR= ${PREFIX}/share/pear
+
+WWWDOCROOT?= www
+
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${FIND} -s -d ${WWWDIR} -type f -print | \
+ ${SED} -e "s#${PREFIX}/##g" >> ${TMPPLIST}
+ @${FIND} -s -d ${WWWDIR} -type d -print | \
+ ${SED} -E -e "s#${PREFIX}/#@dirrm #g" >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/hotcrp/distinfo b/www/hotcrp/distinfo
new file mode 100644
index 000000000000..8d68ef9c781f
--- /dev/null
+++ b/www/hotcrp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hotcrp-2.45.tar.gz) = 4553215241ed0701d99e50afddf1c8f3778706352984062154c271f16ffbceed
+SIZE (hotcrp-2.45.tar.gz) = 510587
diff --git a/www/hotcrp/files/pkg-message.in b/www/hotcrp/files/pkg-message.in
new file mode 100644
index 000000000000..12f6da39ec02
--- /dev/null
+++ b/www/hotcrp/files/pkg-message.in
@@ -0,0 +1,22 @@
+
+***********************************************************************
+* POST INSTALL CONFIGURATION *
+***********************************************************************
+
+Please note that everything has been installed in %%WWWDIR%%.
+
+Read %%WWWDIR%%/README.
+
+You will probably want to add an alias to your httpd.conf file, something
+like this:
+
+ Alias /hotcrp %%WWWDIR%%/
+ AcceptPathInfo On
+ <Directory %%WWWDIR%%>
+ Options Indexes Includes FollowSymLinks MultiViews
+ AllowOverride All
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+
+And restart Apache.
diff --git a/www/hotcrp/pkg-descr b/www/hotcrp/pkg-descr
new file mode 100644
index 000000000000..4d3d611aa6d6
--- /dev/null
+++ b/www/hotcrp/pkg-descr
@@ -0,0 +1,4 @@
+HotCRP is conference management software: it accepts paper submissions
+and manages the review process.
+
+WWW: http://www.cs.ucla.edu/~kohler/hotcrp/