aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-22 19:20:05 +0800
committermiwi <miwi@FreeBSD.org>2009-03-22 19:20:05 +0800
commit36d6840355b1ccaf89ced7339114acdbeb759fc7 (patch)
treec9ac5aacd8c6d74e00cdfd3fd01b7cc2db06658d /www
parenteb175325791b9d7aaf49f6b2ab3fd7c00e79bbde (diff)
downloadfreebsd-ports-gnome-36d6840355b1ccaf89ced7339114acdbeb759fc7.tar.gz
freebsd-ports-gnome-36d6840355b1ccaf89ced7339114acdbeb759fc7.tar.zst
freebsd-ports-gnome-36d6840355b1ccaf89ced7339114acdbeb759fc7.zip
A plugin for WoozTalk to see and chat with other people
listening to the same music at the same time as you on Imeem. WWW: http://www.wooztalk.com PR: ports/132873 Submitted by: David <tech at wooztalk.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/xpi-imeemonwooztalk/Makefile42
-rw-r--r--www/xpi-imeemonwooztalk/distinfo3
-rw-r--r--www/xpi-imeemonwooztalk/pkg-descr10
-rw-r--r--www/xpi-imeemonwooztalk/pkg-message2
5 files changed, 58 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 562775d27960..f75d1252bde1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1647,6 +1647,7 @@
SUBDIR += xpi-httpfox
SUBDIR += xpi-imagezoom
SUBDIR += xpi-imdbpreview
+ SUBDIR += xpi-imeemonwooztalk
SUBDIR += xpi-imglikeopera
SUBDIR += xpi-infolister
SUBDIR += xpi-informenter
diff --git a/www/xpi-imeemonwooztalk/Makefile b/www/xpi-imeemonwooztalk/Makefile
new file mode 100644
index 000000000000..cda499bb39a6
--- /dev/null
+++ b/www/xpi-imeemonwooztalk/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: xpi-imeemwooztalk
+# Date created: 2009-03-09
+# Whom: David <tech@wooztalk.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= imeemonwooztalk
+PORTVERSION= 0.9.9
+CATEGORIES= www
+MASTER_SITES= http://www.wooztalk.com/download/
+DISTNAME= imeemonwooztalk-freebsd
+
+MAINTAINER= tech@wooztalk.com
+COMMENT= Meet your World Wide Web neighbors on Imeem
+
+XPI_ID= imeemonwooztalk@wooztalk.com
+XPI_FILES= chrome.manifest install.rdf chrome/content/imeem.png \
+ chrome/content/overlay.xul chrome/content/overlay.js \
+ install/libimeem.so install/imeem.png install/imeem_dis.png
+
+XPI_DIRS= chrome/content chrome install
+
+.include "../xpi-adblock/Makefile.xpi"
+
+USE_LDCONFIG+= ${PREFIX}/share/wooztalk/plugins/imeem/
+PLIST_FILES+= share/wooztalk/plugins/imeem/libimeem.so share/wooztalk/plugins/imeem/imeem.png \
+ share/wooztalk/plugins/imeem/imeem_dis.png
+PLIST_FILES+= "@dirrm share/wooztalk/plugins/imeem"
+PLIST_FILES+= "@dirrmtry share/wooztalk/plugins"
+PLIST_FILES+= "@dirrmtry share/wooztalk/"
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/wooztalk
+ @${MKDIR} ${PREFIX}/share/wooztalk/plugins
+ @${MKDIR} ${PREFIX}/share/wooztalk/plugins/imeem
+ @${INSTALL_DATA} ${WRKSRC}/install/* ${PREFIX}/share/wooztalk/plugins/imeem
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/xpi-imeemonwooztalk/distinfo b/www/xpi-imeemonwooztalk/distinfo
new file mode 100644
index 000000000000..b42022ffdf66
--- /dev/null
+++ b/www/xpi-imeemonwooztalk/distinfo
@@ -0,0 +1,3 @@
+MD5 (xpi/imeemonwooztalk-freebsd.xpi) = c19ddd72ca672846ff4f17f4270c1f5c
+SHA256 (xpi/imeemonwooztalk-freebsd.xpi) = 1e332150ba933a31e3baca3e1f2409307ca01675f0a33f5f5078d9021c91c49a
+SIZE (xpi/imeemonwooztalk-freebsd.xpi) = 9766
diff --git a/www/xpi-imeemonwooztalk/pkg-descr b/www/xpi-imeemonwooztalk/pkg-descr
new file mode 100644
index 000000000000..ed9708f29aff
--- /dev/null
+++ b/www/xpi-imeemonwooztalk/pkg-descr
@@ -0,0 +1,10 @@
+WoozTalk is a new innovative and free Internet service that let you see and
+chat with anyone else visiting the same website, listening to the same music,
+or watching the same video at the same time as you!
+
+Thanks to this plugin, you can see and chat with people who are currently
+listening to the same music as you on Imeem.
+
+Please install it thanks to the WoozTalk port in net-im/wooztalk
+
+WWW: http://www.wooztalk.com
diff --git a/www/xpi-imeemonwooztalk/pkg-message b/www/xpi-imeemonwooztalk/pkg-message
new file mode 100644
index 000000000000..42e13522e2cf
--- /dev/null
+++ b/www/xpi-imeemonwooztalk/pkg-message
@@ -0,0 +1,2 @@
+
+Do not forget to install ${PORTSDIR}/net-im/wooztalk to use this plugin