aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-06-28 09:43:24 +0800
committerwxs <wxs@FreeBSD.org>2009-06-28 09:43:24 +0800
commit40f052f183cfd09c5e67f76b6a70ccd2c5600146 (patch)
tree36ed9bf2b06e0aaa52a245522a4f3194c936862a /www
parent35ce7307103c9a2558295f08ba24f59b127f9570 (diff)
downloadfreebsd-ports-gnome-40f052f183cfd09c5e67f76b6a70ccd2c5600146.tar.gz
freebsd-ports-gnome-40f052f183cfd09c5e67f76b6a70ccd2c5600146.tar.zst
freebsd-ports-gnome-40f052f183cfd09c5e67f76b6a70ccd2c5600146.zip
- Update to 1.10.3
- Pass maintainer to submitter PR: ports/135300 Submitted by: Jeremy C. Reed <reed@reedmedia.net> Approved by: Mike Meyer <mwm@mired.org> (old maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/webcheck/Makefile25
-rw-r--r--www/webcheck/distinfo6
-rw-r--r--www/webcheck/pkg-plist42
3 files changed, 44 insertions, 29 deletions
diff --git a/www/webcheck/Makefile b/www/webcheck/Makefile
index 4849b94e04fb..3b42c7aea5a3 100644
--- a/www/webcheck/Makefile
+++ b/www/webcheck/Makefile
@@ -6,37 +6,38 @@
#
PORTNAME= webcheck
-PORTVERSION= 1.0
+PORTVERSION= 1.10.3
CATEGORIES= www python
-MASTER_SITES= http://www.mired.org/webcheck/
-EXTRACT_SUFX= .bz2
+MASTER_SITES= http://arthurdejong.org/webcheck/
+EXTRACT_SUFX= .tar.gz
-MAINTAINER= mwm@mired.org
+MAINTAINER= reed@reedmedia.net
COMMENT= View structure of a web site, get a list of problems like broken links
USE_PYTHON= YES
-USE_BZIP2= YES
-.if defined(NOPORTDOCS)
NO_BUILD= YES
-.endif
-do-build:
- ${AWK} '/^Running Webcheck/ { output=1 } output' \
- < ${WRKSRC}/INSTALL > ${WRKSRC}/USAGE
+MAN1= webcheck.1
+
+# what about fancytooltips?
do-install:
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.py ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.css ${DATADIR}
-.for d in plugins schemes
+ ${INSTALL_DATA} ${WRKSRC}/favicon.ico ${DATADIR}
+.for d in parsers parsers/html plugins schemes
@${MKDIR} ${DATADIR}/${d}
${INSTALL_DATA} ${WRKSRC}/${d}/*.py ${DATADIR}/${d}
.endfor
+ @${MKDIR} ${DATADIR}/fancytooltips
+ ${INSTALL_DATA} ${WRKSRC}/fancytooltips/* ${DATADIR}/fancytooltips
${INSTALL_SCRIPT} ${WRKSRC}/webcheck.py ${DATADIR}
${LN} -sf ${DATADIR}/webcheck.py ${PREFIX}/bin/webcheck
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/USAGE ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
+ @${INSTALL_MAN} ${WRKSRC}/webcheck.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/www/webcheck/distinfo b/www/webcheck/distinfo
index 148ad14ee8a1..e6ddd0b811ca 100644
--- a/www/webcheck/distinfo
+++ b/www/webcheck/distinfo
@@ -1,3 +1,3 @@
-MD5 (webcheck-1.0.bz2) = a679bdd35d26f6b1abd237ceba9d14bc
-SHA256 (webcheck-1.0.bz2) = a9464d334f35df45b632a0b5ca703ccd7710a1257aa33653eee48d5b15b9a824
-SIZE (webcheck-1.0.bz2) = 30935
+MD5 (webcheck-1.10.3.tar.gz) = efb86b009099b71827d9131e13c0db81
+SHA256 (webcheck-1.10.3.tar.gz) = 85e2d56eb8da8bc946dd00278f80893f74b64416c2d292bf13016f29574f068c
+SIZE (webcheck-1.10.3.tar.gz) = 85803
diff --git a/www/webcheck/pkg-plist b/www/webcheck/pkg-plist
index 23c82056b1f9..bca86c8c23ce 100644
--- a/www/webcheck/pkg-plist
+++ b/www/webcheck/pkg-plist
@@ -1,33 +1,47 @@
share/webcheck/config.py
+share/webcheck/crawler.py
share/webcheck/debugio.py
-share/webcheck/htmlparse.py
-share/webcheck/httpcodes.py
-share/webcheck/webcheck.css
+share/webcheck/myurllib.py
+share/webcheck/serialize.py
share/webcheck/webcheck.py
-share/webcheck/myUrlLib.py
+share/webcheck/webcheck.css
+share/webcheck/favicon.ico
+share/webcheck/fancytooltips/fancytooltips.js
+share/webcheck/fancytooltips/readme.txt
+share/webcheck/fancytooltips/fancytooltips.css
+share/webcheck/parsers/__init__.py
+share/webcheck/parsers/css.py
+share/webcheck/parsers/html/__init__.py
+share/webcheck/parsers/html/beautifulsoup.py
+share/webcheck/parsers/html/calltidy.py
+share/webcheck/parsers/html/htmlparser.py
share/webcheck/plugins/__init__.py
+share/webcheck/plugins/about.py
+share/webcheck/plugins/anchors.py
share/webcheck/plugins/badlinks.py
share/webcheck/plugins/external.py
share/webcheck/plugins/images.py
+share/webcheck/plugins/new.py
share/webcheck/plugins/notchkd.py
share/webcheck/plugins/notitles.py
+share/webcheck/plugins/old.py
share/webcheck/plugins/problems.py
-share/webcheck/plugins/rptlib.py
share/webcheck/plugins/sitemap.py
-share/webcheck/plugins/slow.py
-share/webcheck/plugins/whatsnew.py
-share/webcheck/plugins/whatsold.py
-share/webcheck/robotparser.py
+share/webcheck/plugins/size.py
+share/webcheck/plugins/urllist.py
share/webcheck/schemes/__init__.py
-share/webcheck/schemes/filelink.py
-share/webcheck/schemes/ftplink.py
-share/webcheck/schemes/httplink.py
-share/webcheck/version.py
-%%PORTDOCS%%share/doc/webcheck/USAGE
+share/webcheck/schemes/file.py
+share/webcheck/schemes/ftp.py
+share/webcheck/schemes/http.py
+share/webcheck/schemes/https.py
+%%PORTDOCS%%share/doc/webcheck/README
%%PORTDOCS%%@dirrm share/doc/webcheck
@unexec rm -f %D/share/webcheck/*.py[co] %D/share/webcheck/*/*.py[co]
@dirrm share/webcheck/plugins
@dirrm share/webcheck/schemes
+@dirrm share/webcheck/parsers/html
+@dirrm share/webcheck/parsers
+@dirrm share/webcheck/fancytooltips/
@dirrm share/webcheck
@exec ln -fs %D/share/webcheck/webcheck.py %D/bin/webcheck
@unexec rm %D/bin/webcheck