aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2013-11-04 22:29:14 +0800
committerkuriyama <kuriyama@FreeBSD.org>2013-11-04 22:29:14 +0800
commit47e00abfaac2e3efb38625d04277219cf177dfe2 (patch)
tree904dcd22d9bb2f3c5526271e2c119e1ea7071f82 /www
parent7c298aebed3128cec63c8e8029c45eca503fd054 (diff)
downloadfreebsd-ports-gnome-47e00abfaac2e3efb38625d04277219cf177dfe2.tar.gz
freebsd-ports-gnome-47e00abfaac2e3efb38625d04277219cf177dfe2.tar.zst
freebsd-ports-gnome-47e00abfaac2e3efb38625d04277219cf177dfe2.zip
Cookie string generator / parser.
WWW: http://search.cpan.org/dist/Cookie-Baker/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Cookie-Baker/Makefile19
-rw-r--r--www/p5-Cookie-Baker/distinfo2
-rw-r--r--www/p5-Cookie-Baker/pkg-descr3
-rw-r--r--www/p5-Cookie-Baker/pkg-plist3
5 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e9396f2b5088..852b6023fe2a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -837,6 +837,7 @@
SUBDIR += p5-ClearSilver
SUBDIR += p5-Compress-LeadingBlankSpaces
SUBDIR += p5-Continuity
+ SUBDIR += p5-Cookie-Baker
SUBDIR += p5-Corona
SUBDIR += p5-Dancer
SUBDIR += p5-Dancer-Logger-Log4perl
diff --git a/www/p5-Cookie-Baker/Makefile b/www/p5-Cookie-Baker/Makefile
new file mode 100644
index 000000000000..25e86ae90a42
--- /dev/null
+++ b/www/p5-Cookie-Baker/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= Cookie-Baker
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for cookie string generator/parser
+
+RUN_DEPENDS= \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= modbuild
+
+.include <bsd.port.mk>
diff --git a/www/p5-Cookie-Baker/distinfo b/www/p5-Cookie-Baker/distinfo
new file mode 100644
index 000000000000..0e5d1eec0bc5
--- /dev/null
+++ b/www/p5-Cookie-Baker/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Cookie-Baker-0.02.tar.gz) = f5b8fa5da1e54d0da1189431848f9992feb12380182fe014788fabae83d6fe97
+SIZE (Cookie-Baker-0.02.tar.gz) = 11390
diff --git a/www/p5-Cookie-Baker/pkg-descr b/www/p5-Cookie-Baker/pkg-descr
new file mode 100644
index 000000000000..e67b88b79d39
--- /dev/null
+++ b/www/p5-Cookie-Baker/pkg-descr
@@ -0,0 +1,3 @@
+Cookie string generator / parser.
+
+WWW: http://search.cpan.org/dist/Cookie-Baker/
diff --git a/www/p5-Cookie-Baker/pkg-plist b/www/p5-Cookie-Baker/pkg-plist
new file mode 100644
index 000000000000..d489f251ec2f
--- /dev/null
+++ b/www/p5-Cookie-Baker/pkg-plist
@@ -0,0 +1,3 @@
+%%PERL5_MAN3%%/Cookie::Baker.3.gz
+%%SITE_PERL%%/Cookie/Baker.pm
+@dirrmtry %%SITE_PERL%%/Cookie