aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsimon <simon@FreeBSD.org>2005-10-13 04:19:35 +0800
committersimon <simon@FreeBSD.org>2005-10-13 04:19:35 +0800
commit4c97d2ab8bc2ae4702b7adb876d6e9b071e1f44c (patch)
tree30b7368bdd16e995e53b10de31374a3498574187 /www
parent5d5846f3177174ded4110554354eeb20fc58e0a2 (diff)
downloadfreebsd-ports-gnome-4c97d2ab8bc2ae4702b7adb876d6e9b071e1f44c.tar.gz
freebsd-ports-gnome-4c97d2ab8bc2ae4702b7adb876d6e9b071e1f44c.tar.zst
freebsd-ports-gnome-4c97d2ab8bc2ae4702b7adb876d6e9b071e1f44c.zip
Add new port www/sitemapgen:
The sitemap_gen.py script analyzes your web server and generates one or more Sitemap files. These files are XML listings of content you make available on your web server. The files can then be directly submitted to Google. Written by opensource@google.com. WWW: https://www.google.com/webmasters/sitemaps/docs/en/about.html
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/sitemapgen/Makefile35
-rw-r--r--www/sitemapgen/distinfo2
-rw-r--r--www/sitemapgen/pkg-descr8
-rw-r--r--www/sitemapgen/pkg-plist9
5 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index bd2fed82783a..24d637de52ac 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -772,6 +772,7 @@
SUBDIR += simplog
SUBDIR += sitebar
SUBDIR += sitecopy
+ SUBDIR += sitemapgen
SUBDIR += skytemplate
SUBDIR += slash
SUBDIR += smarty
diff --git a/www/sitemapgen/Makefile b/www/sitemapgen/Makefile
new file mode 100644
index 000000000000..b836e781b611
--- /dev/null
+++ b/www/sitemapgen/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: sitemapgen
+# Date Created: 12 Oct 2005
+# Whom: ceri
+#
+# $FreeBSD$
+#
+
+PORTNAME= sitemapgen
+PORTVERSION= 1.3
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= goog-sitemapgen
+DISTNAME= sitemap_gen-${PORTVERSION}
+
+MAINTAINER= ceri@FreeBSD.org
+COMMENT= A Google sitemap generator
+
+USE_PYTHON= yes
+
+NOMAN= yes
+
+do-build:
+
+do-configure:
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sitemap_gen.py ${PREFIX}/bin/sitemap_gen
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for DOC in AUTHORS COPYING ChangeLog PKG-INFO README example_config.xml example_urllist.txt
+ ${INSTALL} ${WRKSRC}/${DOC} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/sitemapgen/distinfo b/www/sitemapgen/distinfo
new file mode 100644
index 000000000000..5a39bbf270ab
--- /dev/null
+++ b/www/sitemapgen/distinfo
@@ -0,0 +1,2 @@
+MD5 (sitemap_gen-1.3.tar.gz) = 641e1b4d9bff39b4fb599a267727b605
+SIZE (sitemap_gen-1.3.tar.gz) = 29975
diff --git a/www/sitemapgen/pkg-descr b/www/sitemapgen/pkg-descr
new file mode 100644
index 000000000000..821aac77a8f6
--- /dev/null
+++ b/www/sitemapgen/pkg-descr
@@ -0,0 +1,8 @@
+The sitemap_gen.py script analyzes your web server and generates one or
+more Sitemap files. These files are XML listings of content you make
+available on your web server. The files can then be directly submitted
+to Google.
+
+Written by opensource@google.com.
+
+WWW: https://www.google.com/webmasters/sitemaps/docs/en/about.html
diff --git a/www/sitemapgen/pkg-plist b/www/sitemapgen/pkg-plist
new file mode 100644
index 000000000000..80c57f547b25
--- /dev/null
+++ b/www/sitemapgen/pkg-plist
@@ -0,0 +1,9 @@
+bin/sitemap_gen
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/PKG-INFO
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/example_config.xml
+%%PORTDOCS%%%%DOCSDIR%%/example_urllist.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%