aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-12-26 05:16:58 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-12-26 05:16:58 +0800
commit4f77ceb812927a89d08cd08959f5063704ec2225 (patch)
treefddcee141b39057cde3916c9ce14d7e85843e44f /www
parentcf254a1bec27add22253e111c9494700b0553f4f (diff)
downloadfreebsd-ports-gnome-4f77ceb812927a89d08cd08959f5063704ec2225.tar.gz
freebsd-ports-gnome-4f77ceb812927a89d08cd08959f5063704ec2225.tar.zst
freebsd-ports-gnome-4f77ceb812927a89d08cd08959f5063704ec2225.zip
- Add NODE and NODE6 option
- Change default from node to node6 - Bump PORTREVISION for dependency change PR: 215412 Submitted by: Bradley T. Hughes <bradleythughes@fastmail.fm>
Diffstat (limited to 'www')
-rw-r--r--www/npm3/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/www/npm3/Makefile b/www/npm3/Makefile
index 345540a4ce40..961e115cf852 100644
--- a/www/npm3/Makefile
+++ b/www/npm3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= npm
PORTVERSION= 3.10.10
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
PKGNAMESUFFIX= 3
@@ -12,11 +13,16 @@ COMMENT= Node package manager
LICENSE= MIT
-RUN_DEPENDS= gmake:devel/gmake \
- node>=0.8.0:www/node
+RUN_DEPENDS= gmake:devel/gmake
CONFLICTS_INSTALL= npm- npm2-
+OPTIONS_SINGLE= BACKEND
+OPTIONS_SINGLE_BACKEND= NODE NODE6
+OPTIONS_DEFAULT=NODE6
+NODE_DESC= Use www/node as backend
+NODE6_DESC= Use www/node6 as backend
+
MAKE_ARGS= npm_config_prefix=${STAGEDIR}${PREFIX}
MANPREFIX= ${PREFIX}/lib/node_modules/npm
NO_ARCH= yes
@@ -34,6 +40,9 @@ SHEBANG_FILES= lib/utils/completion.sh \
scripts/release.sh \
scripts/relocate.sh
+NODE_RUN_DEPENDS= node>=0.8.0:www/node
+NODE6_RUN_DEPENDS= node6>=0.8.0:www/node6
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"