aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-28 04:38:14 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-28 04:38:14 +0800
commit5255175b5223fd2508f2124c0b7585b57e3a3a72 (patch)
tree95835ccc395c93def3aa160658898dbe5efe3fef /www
parent60b8b58c7483afbecd698d31a1e8da1f207dbae3 (diff)
downloadfreebsd-ports-gnome-5255175b5223fd2508f2124c0b7585b57e3a3a72.tar.gz
freebsd-ports-gnome-5255175b5223fd2508f2124c0b7585b57e3a3a72.tar.zst
freebsd-ports-gnome-5255175b5223fd2508f2124c0b7585b57e3a3a72.zip
A simple Simple HTTP and REST client for Ruby, inspired by the Sinatra
microframework style of specifying actions: get, put, post, delete. WWW: https://github.com/archiloque/rest-client PR: ports/153336 Submitted by: Renaud Chaput <renchap at cocoa-x.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-rest-client/Makefile22
-rw-r--r--www/rubygem-rest-client/distinfo2
-rw-r--r--www/rubygem-rest-client/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7f25cd3588da..32f4a1686555 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1608,6 +1608,7 @@
SUBDIR += rubygem-railties
SUBDIR += rubygem-ramaze
SUBDIR += rubygem-redcloth
+ SUBDIR += rubygem-rest-client
SUBDIR += rubygem-rfacebook
SUBDIR += rubygem-rfeedfinder
SUBDIR += rubygem-robots
diff --git a/www/rubygem-rest-client/Makefile b/www/rubygem-rest-client/Makefile
new file mode 100644
index 000000000000..d66841838ab9
--- /dev/null
+++ b/www/rubygem-rest-client/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: rubygem-rest-client
+# Date created: 10 Dec 2010
+# Whom: Renaud Chaput <renchap@cocoa-x.com>
+#
+# $FreeBSD$
+
+PORTNAME= rest-client
+PORTVERSION= 1.6.1
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= renchap@cocoa-x.com
+COMMENT= A simple Simple HTTP and REST client for Ruby
+
+RUN_DEPENDS= rubygem-mime-types>=1.16:${PORTSDIR}/misc/rubygem-mime-types
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/restclient
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-rest-client/distinfo b/www/rubygem-rest-client/distinfo
new file mode 100644
index 000000000000..1df21843349c
--- /dev/null
+++ b/www/rubygem-rest-client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rest-client-1.6.1.gem) = 7db53b5ef2ab200fabe841642c73ffeec9eaf2bb4f1ba9ef597b3b6ddd4ff4e7
+SIZE (rubygem/rest-client-1.6.1.gem) = 55296
diff --git a/www/rubygem-rest-client/pkg-descr b/www/rubygem-rest-client/pkg-descr
new file mode 100644
index 000000000000..0988acd1f6ee
--- /dev/null
+++ b/www/rubygem-rest-client/pkg-descr
@@ -0,0 +1,4 @@
+A simple Simple HTTP and REST client for Ruby, inspired by the Sinatra
+microframework style of specifying actions: get, put, post, delete.
+
+WWW: https://github.com/archiloque/rest-client