aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-06-28 23:36:20 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-06-28 23:36:20 +0800
commit60825918e9a04475c99cc518a710b348b386e782 (patch)
treece261256a056722242bf431da3c23b43f4236e3b /www
parent2ebe344034b0a3832e6f536eeb857c15ea7f42d8 (diff)
downloadfreebsd-ports-gnome-60825918e9a04475c99cc518a710b348b386e782.tar.gz
freebsd-ports-gnome-60825918e9a04475c99cc518a710b348b386e782.tar.zst
freebsd-ports-gnome-60825918e9a04475c99cc518a710b348b386e782.zip
- Add p5-Mobile-UserAgent 1.05
Parses a mobile user agent string into it's basic constituent parts, the most important being vendor and model. One reason for doing this would be to use this information to lookup vendor-model specific device characteristics in a database. WWW: http://search.cpan.org/dist/Mobile-UserAgent/ PR: ports/157943 Submitted by: Dmitry Liakh <dliakh@ukr.net>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Mobile-UserAgent/Makefile24
-rw-r--r--www/p5-Mobile-UserAgent/distinfo2
-rw-r--r--www/p5-Mobile-UserAgent/pkg-descr6
-rw-r--r--www/p5-Mobile-UserAgent/pkg-plist6
5 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 85b36bb280d0..b93375ce0de7 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1116,6 +1116,7 @@
SUBDIR += p5-Maypole-Component
SUBDIR += p5-MediaWiki
SUBDIR += p5-MediaWiki-API
+ SUBDIR += p5-Mobile-UserAgent
SUBDIR += p5-ModPerl-VersionUtil
SUBDIR += p5-Mojolicious
SUBDIR += p5-Mojolicious-Plugin-Database
diff --git a/www/p5-Mobile-UserAgent/Makefile b/www/p5-Mobile-UserAgent/Makefile
new file mode 100644
index 000000000000..9efcb6e8f73d
--- /dev/null
+++ b/www/p5-Mobile-UserAgent/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Mobile-UserAgent
+# Date created: Jun 15 2011
+# Whom: Dmitry Liakh <dliakh@ukr.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mobile-UserAgent
+PORTVERSION= 1.05
+CATEGORIES= www
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dliakh@ukr.net
+COMMENT= Parses a mobile user agent string into its basic constituent parts
+
+RUN_DEPENDS= p5-Class-Singleton>=0:${PORTSDIR}/devel/p5-Class-Singleton
+
+PERL_CONFIGURE= yes
+
+MAN3= Mobile::UserAgent.3 \
+ Mobile::UserAgentFactory.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Mobile-UserAgent/distinfo b/www/p5-Mobile-UserAgent/distinfo
new file mode 100644
index 000000000000..dc69e7c6fd4d
--- /dev/null
+++ b/www/p5-Mobile-UserAgent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Mobile-UserAgent-1.05.tar.gz) = e6938d169d60679affb3a78202a71067d382eef240161d4e09cbe1ff61d9ed35
+SIZE (Mobile-UserAgent-1.05.tar.gz) = 37860
diff --git a/www/p5-Mobile-UserAgent/pkg-descr b/www/p5-Mobile-UserAgent/pkg-descr
new file mode 100644
index 000000000000..9f350f43abc5
--- /dev/null
+++ b/www/p5-Mobile-UserAgent/pkg-descr
@@ -0,0 +1,6 @@
+Parses a mobile user agent string into it's basic constituent parts, the most
+important being vendor and model. One reason for doing this would be to use
+this information to lookup vendor-model specific device characteristics in a
+database.
+
+WWW: http://search.cpan.org/dist/Mobile-UserAgent/
diff --git a/www/p5-Mobile-UserAgent/pkg-plist b/www/p5-Mobile-UserAgent/pkg-plist
new file mode 100644
index 000000000000..9b82be03d25e
--- /dev/null
+++ b/www/p5-Mobile-UserAgent/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Mobile/UserAgent.pm
+%%SITE_PERL%%/Mobile/UserAgentFactory.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mobile/UserAgent/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mobile/UserAgent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mobile
+@dirrmtry %%SITE_PERL%%/Mobile