aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-01-21 07:43:35 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-01-21 07:43:35 +0800
commit630234cfbb3c998bdca2bc6cd2eb46ca52bce83d (patch)
treefb4c9bacd54eda4cc9538a16821946702165675e /www
parent894daa2177e7c92f298524221f04b621aa834dd6 (diff)
downloadfreebsd-ports-gnome-630234cfbb3c998bdca2bc6cd2eb46ca52bce83d.tar.gz
freebsd-ports-gnome-630234cfbb3c998bdca2bc6cd2eb46ca52bce83d.tar.zst
freebsd-ports-gnome-630234cfbb3c998bdca2bc6cd2eb46ca52bce83d.zip
- Show what modules are not installed when configure failed.
- Add required dependencies and unbreak. - Remove unneeded dependencies.
Diffstat (limited to 'www')
-rw-r--r--www/bricolage/Makefile11
-rw-r--r--www/bricolage/files/patch-inst::cpan.pl10
-rw-r--r--www/bricolage/files/patch-inst::modules.pl20
3 files changed, 32 insertions, 9 deletions
diff --git a/www/bricolage/Makefile b/www/bricolage/Makefile
index 1d711d606e66..90a7499fe136 100644
--- a/www/bricolage/Makefile
+++ b/www/bricolage/Makefile
@@ -7,15 +7,14 @@
PORTNAME= bricolage
PORTVERSION= 1.10.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITE_SUBDIR= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A full-featured, open-source content-management and publishing system
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg \
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg \
${SITE_PERL}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM \
${SITE_PERL}/Cache/Cache.pm:${PORTSDIR}/devel/p5-Cache-Cache \
${SITE_PERL}/${PERL_ARCH}/Cache/Mmap.pm:${PORTSDIR}/devel/p5-Cache-Mmap \
@@ -26,20 +25,16 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p
${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump \
${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
${SITE_PERL}/DateTime/TimeZone.pm:${PORTSDIR}/devel/p5-DateTime-TimeZone \
- ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext \
${SITE_PERL}/Term/ReadPassword.pm:${PORTSDIR}/devel/p5-Term-ReadPassword \
${SITE_PERL}/${PERL_ARCH}/Text/LevenshteinXS.pm:${PORTSDIR}/devel/p5-Text-LevenshteinXS \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${SITE_PERL}/Test/Class.pm:${PORTSDIR}/devel/p5-Test-Class \
${SITE_PERL}/Test/File/Contents.pm:${PORTSDIR}/devel/p5-Test-File-Contents \
${SITE_PERL}/Test/MockModule.pm:${PORTSDIR}/devel/p5-Test-MockModule \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
${SITE_PERL}/Image/Info.pm:${PORTSDIR}/graphics/p5-Image-Info \
${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils \
${SITE_PERL}/MIME/Body.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite \
${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
${SITE_PERL}/Text/Diff/HTML.pm:${PORTSDIR}/textproc/p5-Text-Diff-HTML \
${SITE_PERL}/Text/WordDiff.pm:${PORTSDIR}/textproc/p5-Text-WordDiff \
@@ -54,8 +49,6 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
${BUILD_DEPENDS}
-BROKEN= missing dependencies
-
MAKE_JOBS_UNSAFE= yes
USE_APACHE= 13
diff --git a/www/bricolage/files/patch-inst::cpan.pl b/www/bricolage/files/patch-inst::cpan.pl
new file mode 100644
index 000000000000..47e1ec35bf67
--- /dev/null
+++ b/www/bricolage/files/patch-inst::cpan.pl
@@ -0,0 +1,10 @@
+--- inst/cpan.pl.orig 2008-03-10 04:33:51.000000000 +0900
++++ inst/cpan.pl 2010-01-20 08:42:44.824399835 +0900
+@@ -46,6 +46,7 @@
+ my $need;
+ for my $i (0 .. $#$MOD) {
+ next if $MOD->[$i]{found};
++ print "Not found ", $MOD->[$i]->{name}, "\n";
+ $need = 1;
+ last;
+ }
diff --git a/www/bricolage/files/patch-inst::modules.pl b/www/bricolage/files/patch-inst::modules.pl
new file mode 100644
index 000000000000..76b770f3ba49
--- /dev/null
+++ b/www/bricolage/files/patch-inst::modules.pl
@@ -0,0 +1,20 @@
+--- inst/modules.pl.orig 2010-01-20 10:09:51.409328323 +0900
++++ inst/modules.pl 2010-01-20 10:10:27.015274883 +0900
+@@ -101,7 +101,7 @@
+ {
+ local $^W = 0; # ignore warnings from modules
+ my $result = eval "require $name;";
+- return soft_fail("not found.") if $@;
++ return soft_fail("not found ($@).") if $@;
+ print "found.\n";
+ }
+
+@@ -109,7 +109,7 @@
+ print "Checking that $name version is >= $req_version... ";
+ local $^W = 0;
+ eval { $name->VERSION($req_version) };
+- return soft_fail("not ok.") if $@;
++ return soft_fail("not ok ($@).") if $@;
+ print "ok.\n";
+ }
+