aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-22 19:22:04 +0800
committermiwi <miwi@FreeBSD.org>2009-03-22 19:22:04 +0800
commit66814b74170811d3a594448c9919aad7476fd538 (patch)
tree0eb25656390d451c17da49d46fe037fd499908db /www
parent5a74a5a0c4180d186de681d4e5ff83e51cc2b429 (diff)
downloadfreebsd-ports-gnome-66814b74170811d3a594448c9919aad7476fd538.tar.gz
freebsd-ports-gnome-66814b74170811d3a594448c9919aad7476fd538.tar.zst
freebsd-ports-gnome-66814b74170811d3a594448c9919aad7476fd538.zip
A plugin for WoozTalk to see and chat with other people listening
to the same music at the same time as you on Last.fm. WWW: http://www.wooztalk.com PR: ports/132875 Submitted by: David <tech at wooztalk.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/xpi-lastfmonwooztalk/Makefile42
-rw-r--r--www/xpi-lastfmonwooztalk/distinfo3
-rw-r--r--www/xpi-lastfmonwooztalk/pkg-descr10
-rw-r--r--www/xpi-lastfmonwooztalk/pkg-message2
5 files changed, 58 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4814ded06dbd..96bfca543c44 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1655,6 +1655,7 @@
SUBDIR += xpi-jiwaonwooztalk
SUBDIR += xpi-joga
SUBDIR += xpi-jsview
+ SUBDIR += xpi-lastfmonwooztalk
SUBDIR += xpi-leechblock
SUBDIR += xpi-linkification
SUBDIR += xpi-live_http_headers
diff --git a/www/xpi-lastfmonwooztalk/Makefile b/www/xpi-lastfmonwooztalk/Makefile
new file mode 100644
index 000000000000..4c4e43e2c84f
--- /dev/null
+++ b/www/xpi-lastfmonwooztalk/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: xpi-lastfmwooztalk
+# Date created: 2009-03-09
+# Whom: David <tech@wooztalk.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lastfmonwooztalk
+PORTVERSION= 0.9.9
+CATEGORIES= www
+MASTER_SITES= http://www.wooztalk.com/download/
+DISTNAME= lastfmonwooztalk-freebsd
+
+MAINTAINER= tech@wooztalk.com
+COMMENT= Meet your World Wide Web neighbors on Last.fm
+
+XPI_ID= lastfmonwooztalk@wooztalk.com
+XPI_FILES= chrome.manifest install.rdf chrome/content/lastfm.png \
+ chrome/content/overlay.xul chrome/content/overlay.js \
+ install/liblastfm.so install/lastfm.png install/lastfm_dis.png
+
+XPI_DIRS= chrome/content chrome install
+
+.include "../xpi-adblock/Makefile.xpi"
+
+USE_LDCONFIG+= ${PREFIX}/share/wooztalk/plugins/lastfm/
+PLIST_FILES+= share/wooztalk/plugins/lastfm/liblastfm.so share/wooztalk/plugins/lastfm/lastfm.png \
+ share/wooztalk/plugins/lastfm/lastfm_dis.png
+PLIST_FILES+= "@dirrm share/wooztalk/plugins/lastfm"
+PLIST_FILES+= "@dirrmtry share/wooztalk/plugins"
+PLIST_FILES+= "@dirrmtry share/wooztalk/"
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/wooztalk
+ @${MKDIR} ${PREFIX}/share/wooztalk/plugins
+ @${MKDIR} ${PREFIX}/share/wooztalk/plugins/lastfm
+ @${INSTALL_DATA} ${WRKSRC}/install/* ${PREFIX}/share/wooztalk/plugins/lastfm
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/xpi-lastfmonwooztalk/distinfo b/www/xpi-lastfmonwooztalk/distinfo
new file mode 100644
index 000000000000..bd7bfc467cca
--- /dev/null
+++ b/www/xpi-lastfmonwooztalk/distinfo
@@ -0,0 +1,3 @@
+MD5 (xpi/lastfmonwooztalk-freebsd.xpi) = 26ff8a7b1bc59738941dbba1f88aea5a
+SHA256 (xpi/lastfmonwooztalk-freebsd.xpi) = 7d77ab1bf91baf87747f9b26e484ff8b4eabe9c14f1ef13f9c03a87239c2c0c5
+SIZE (xpi/lastfmonwooztalk-freebsd.xpi) = 10712
diff --git a/www/xpi-lastfmonwooztalk/pkg-descr b/www/xpi-lastfmonwooztalk/pkg-descr
new file mode 100644
index 000000000000..b857f1f4ca16
--- /dev/null
+++ b/www/xpi-lastfmonwooztalk/pkg-descr
@@ -0,0 +1,10 @@
+WoozTalk is a new innovative and free Internet service that let you see and
+chat with anyone else visiting the same website, listening to the same music,
+or watching the same video at the same time as you!
+
+Thanks to this plugin, you can see and chat with people who are currently
+listening to the same music as you on Last.fm.
+
+Please install it thanks to the WoozTalk port in net-im/wooztalk
+
+WWW: http://www.wooztalk.com
diff --git a/www/xpi-lastfmonwooztalk/pkg-message b/www/xpi-lastfmonwooztalk/pkg-message
new file mode 100644
index 000000000000..42e13522e2cf
--- /dev/null
+++ b/www/xpi-lastfmonwooztalk/pkg-message
@@ -0,0 +1,2 @@
+
+Do not forget to install ${PORTSDIR}/net-im/wooztalk to use this plugin