aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-02-16 09:24:35 +0800
committersat <sat@FreeBSD.org>2007-02-16 09:24:35 +0800
commit74fabbc4069ca1ebe2182a0ff8350e93633f263c (patch)
treeca750a7f575617f7ede935bd44c90b77717f8e7b /www
parentaccb8d5ea28e8611b291a36b10311ac8e2a7f006 (diff)
downloadfreebsd-ports-gnome-74fabbc4069ca1ebe2182a0ff8350e93633f263c.tar.gz
freebsd-ports-gnome-74fabbc4069ca1ebe2182a0ff8350e93633f263c.tar.zst
freebsd-ports-gnome-74fabbc4069ca1ebe2182a0ff8350e93633f263c.zip
Add port www/castget:
castget is a simple, command-line based RSS enclosure downloader. It is primarily intended for automatic, unattended downloading of podcasts. * Simple configuration. * Per-channel tagging of downloaded MP3 files using ID3v2. * Per-channel download directories. * Supports all RSS versions and Media RSS. WWW: http://www.nongnu.org/castget/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/castget/Makefile31
-rw-r--r--www/castget/distinfo3
-rw-r--r--www/castget/pkg-descr9
4 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 872692e84f3e..81ce2f9a7d53 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -61,6 +61,7 @@
SUBDIR += cadaver
SUBDIR += calamaris
SUBDIR += campsite
+ SUBDIR += castget
SUBDIR += caudium12
SUBDIR += cgi-lib
SUBDIR += cgi-lib.pl
diff --git a/www/castget/Makefile b/www/castget/Makefile
new file mode 100644
index 000000000000..f7fe50f1fbb1
--- /dev/null
+++ b/www/castget/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: castget
+# Date created: 16 February 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= castget
+PORTVERSION= 0.9.6
+CATEGORIES= www
+MASTER_SITES= SAVANNAH CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Command-line podcast downloader
+
+LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
+ curl.4:${PORTSDIR}/ftp/curl
+
+USE_LDCONFIG= yes
+USE_GNOME= glib20 libxml2
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --disable-static
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/castget include/libcastget.h lib/libcastget.la lib/libcastget.so lib/libcastget.so.0
+MAN1= castget.1
+MAN5= castgetrc.5
+
+.include <bsd.port.mk>
diff --git a/www/castget/distinfo b/www/castget/distinfo
new file mode 100644
index 000000000000..76883d948624
--- /dev/null
+++ b/www/castget/distinfo
@@ -0,0 +1,3 @@
+MD5 (castget-0.9.6.tar.gz) = 2008fe7dc592592843619cd64d05a989
+SHA256 (castget-0.9.6.tar.gz) = da28c023b79cbd305603bcaa045023dc57a9b1b6b7cab9a9d201f7d8eca4d34a
+SIZE (castget-0.9.6.tar.gz) = 345039
diff --git a/www/castget/pkg-descr b/www/castget/pkg-descr
new file mode 100644
index 000000000000..af1059f39fdd
--- /dev/null
+++ b/www/castget/pkg-descr
@@ -0,0 +1,9 @@
+castget is a simple, command-line based RSS enclosure downloader. It is
+primarily intended for automatic, unattended downloading of podcasts.
+
+* Simple configuration.
+* Per-channel tagging of downloaded MP3 files using ID3v2.
+* Per-channel download directories.
+* Supports all RSS versions and Media RSS.
+
+WWW: http://www.nongnu.org/castget/