aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-01-03 10:33:24 +0800
committerbeech <beech@FreeBSD.org>2008-01-03 10:33:24 +0800
commit84665df1d0bc7192f8d4ecc6d810452a7f20a1c5 (patch)
tree79ce2622553906600edbd380c1bb174717cffef3 /www
parent9439d5676ffcfd7c2c2a636adc5d9b2e2163496e (diff)
downloadfreebsd-ports-gnome-84665df1d0bc7192f8d4ecc6d810452a7f20a1c5.tar.gz
freebsd-ports-gnome-84665df1d0bc7192f8d4ecc6d810452a7f20a1c5.tar.zst
freebsd-ports-gnome-84665df1d0bc7192f8d4ecc6d810452a7f20a1c5.zip
- Update to 2.2.0
- Use SF macro PR: ports/118772 Submitted by: TAKATSU Tomonari <tota@rtfm.jp> (maintainer) Approved by: linimon (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/tdiary/Makefile27
-rw-r--r--www/tdiary/distinfo6
-rw-r--r--www/tdiary/files/tdiaryinst.rb.in1
-rw-r--r--www/tdiary/pkg-descr2
4 files changed, 13 insertions, 23 deletions
diff --git a/www/tdiary/Makefile b/www/tdiary/Makefile
index 18de067d26d4..27fad4bbab86 100644
--- a/www/tdiary/Makefile
+++ b/www/tdiary/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= tdiary
-PORTVERSION= 2.0.4
+PORTVERSION= 2.2.0
CATEGORIES?= www ruby
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+MASTER_SITES= SF \
http://www.tdiary.org/download/
-MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-full-${PORTVERSION}
MAINTAINER= tota@rtfm.jp
@@ -23,13 +22,11 @@ CONFLICTS?= tdiary-devel-[0-9]* \
PKGMESSAGE= ${WRKDIR}/pkg-message
USE_RUBY= yes
-.if !defined(WITHOUT_RUBY_FEATURES)
-USE_RUBY_FEATURES= fileutils
-.endif
-
-RUBY_SHEBANG_FILES= index.rb update.rb misc/convert2.rb misc/plugin/squeeze.rb \
- misc/plugin/windex.rb \
- misc/plugin/trackback/tb.rb misc/style/etdiary/etdiary_test.rb
+RUBY_SHEBANG_FILES= index.rb update.rb misc/convert2.rb \
+ misc/plugin/amazon/amazonimg.rb misc/plugin/pingback/pb.rb \
+ misc/plugin/squeeze.rb misc/plugin/trackback/tb.rb \
+ misc/plugin/xmlrpc/xmlrpc.rb misc/style/etdiary/etdiary_test.rb \
+ tdiary/wiki_style_test.rb
PLIST_FILES= ${TDIARYDIR:S|${LOCALBASE}/||}/tdiaryinst.rb
TDIARYDIR= ${EXAMPLESDIR}
@@ -43,16 +40,10 @@ TDIARY_LANG= en
.if defined(WITH_TDIARY_UCONV)
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/uconv.so:${PORTSDIR}/japanese/ruby-uconv
.endif
-.if defined(WITH_TDIARY_NORA)
+.if !defined(WITHOUT_TDIARY_NORA)
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/web/escape_ext.so:${PORTSDIR}/www/ruby-nora
.endif
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VERSION_CODE} < 167
-IGNORE= only works with Ruby 1.6.7 or later
-.endif
-
do-install:
@-${MKDIR} ${TDIARYDIR}
@${SED} -e 's,#!/usr/bin/env ruby,#!${RUBY},' \
@@ -74,4 +65,4 @@ post-install:
@${SED} -e 's|%%EXAMPLESDIR%%|${EXAMPLESDIR}|' < ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/tdiary/distinfo b/www/tdiary/distinfo
index 518781d263f4..f228f0ac4e9d 100644
--- a/www/tdiary/distinfo
+++ b/www/tdiary/distinfo
@@ -1,3 +1,3 @@
-MD5 (tdiary-full-2.0.4.tar.gz) = 8c6a5768cdbcedaa5e643ef79d8713a7
-SHA256 (tdiary-full-2.0.4.tar.gz) = 850f7b78ff0bfd35f533226f69064cc189628dda96e823d924ec28f5931acfe6
-SIZE (tdiary-full-2.0.4.tar.gz) = 2128834
+MD5 (tdiary-full-2.2.0.tar.gz) = 3fffc82a8ff3972a3bb036ed74202220
+SHA256 (tdiary-full-2.2.0.tar.gz) = 7b9089a2a879df283f5958caa34e632434a06daa321ccfe3c498bf59241e7f9b
+SIZE (tdiary-full-2.2.0.tar.gz) = 3862083
diff --git a/www/tdiary/files/tdiaryinst.rb.in b/www/tdiary/files/tdiaryinst.rb.in
index cbe73c0f5bde..0f517f73c8d0 100644
--- a/www/tdiary/files/tdiaryinst.rb.in
+++ b/www/tdiary/files/tdiaryinst.rb.in
@@ -218,7 +218,6 @@ class TdiaryInstall
def copyBaseFile
FileUtils16.cp_r("#{@tdiarymaster}/doc", "#{@passwd.dir}/#{@httpdir}/#{@diarydir}", :preserve, *@fileutilOptions)
- FileUtils16.cp_r("#{@tdiarymaster}/erb", "#{@passwd.dir}/#{@httpdir}/#{@diarydir}", :preserve, *@fileutilOptions)
FileUtils16.cp_r("#{@tdiarymaster}/misc", "#{@passwd.dir}/#{@httpdir}/#{@diarydir}", :preserve, *@fileutilOptions)
FileUtils16.cp_r("#{@tdiarymaster}/plugin", "#{@passwd.dir}/#{@httpdir}/#{@diarydir}", :preserve, *@fileutilOptions)
FileUtils16.cp_r("#{@tdiarymaster}/skel", "#{@passwd.dir}/#{@httpdir}/#{@diarydir}", :preserve, *@fileutilOptions)
diff --git a/www/tdiary/pkg-descr b/www/tdiary/pkg-descr
index a77a3171f821..2246d56f6dcb 100644
--- a/www/tdiary/pkg-descr
+++ b/www/tdiary/pkg-descr
@@ -1,7 +1,7 @@
tDiary is a Web-based interface system that works as a personal diary.
It is possible for diary readers to add comments to your diary.
- - require Ruby 1.6.7 or later
+ - require Ruby 1.8.0 or later
- currently supported: Japanese, English, Traditional-Chinese
tDiary is developed on http://sourceforge.net/projects/tdiary/ .