aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-09-02 02:32:45 +0800
committerflo <flo@FreeBSD.org>2011-09-02 02:32:45 +0800
commit8b81f957e69f66de20bf90b9d932c4aee5d65500 (patch)
treeb346b8255c00350bfdddd16ae38aa407e3a101d5 /www
parent2c430bd573a62911c3d4db11ac0dafbcec37701e (diff)
downloadfreebsd-ports-gnome-8b81f957e69f66de20bf90b9d932c4aee5d65500.tar.gz
freebsd-ports-gnome-8b81f957e69f66de20bf90b9d932c4aee5d65500.tar.zst
freebsd-ports-gnome-8b81f957e69f66de20bf90b9d932c4aee5d65500.zip
- add $command_args for all calls to $command in rc.d/squid (ports/156737)
- Bump PORTREVISION for this change. PR: ports/160372 Submitted by: Thomas-Martin Seck <tmseck@web.de>
Diffstat (limited to 'www')
-rw-r--r--www/squid30/Makefile1
-rw-r--r--www/squid30/files/squid.in6
2 files changed, 4 insertions, 3 deletions
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 7c8f1163a3b7..009371d99f1a 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -61,6 +61,7 @@
PORTNAME= squid
PORTVERSION= 3.0.${SQUID_STABLE_VER}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://mirrors.ccs.neu.edu/Squid/ \
diff --git a/www/squid30/files/squid.in b/www/squid30/files/squid.in
index c38878660b8c..fdbae3b7924a 100644
--- a/www/squid30/files/squid.in
+++ b/www/squid30/files/squid.in
@@ -41,7 +41,7 @@
#
squid_checkrunning() {
- ${command} ${squid_flags} -k check 2>/dev/null
+ ${command} ${command_args} ${squid_flags} -k check 2>/dev/null
}
squid_setfib() {
@@ -55,7 +55,7 @@ squid_setfib() {
squid_stop() {
echo "Stopping ${name}."
- ${command} ${squid_flags} -k shutdown
+ ${command} ${command_args} ${squid_flags} -k shutdown
run_rc_command poll
}
@@ -66,7 +66,7 @@ rcvar=${name}_enable
command=%%PREFIX%%/sbin/squid
extra_commands=reload
-reload_cmd="${command} ${squid_flags} -k reconfigure"
+reload_cmd="${command} ${command_args} ${squid_flags} -k reconfigure"
start_precmd="squid_setfib"
stop_precmd="squid_checkrunning"
stop_cmd="squid_stop"