aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-01-10 03:53:48 +0800
committerrakuco <rakuco@FreeBSD.org>2014-01-10 03:53:48 +0800
commit8e2ac725bb818044893d64d66a85a8023a6f3fb6 (patch)
treeef2ad71519ff862728c74c2871b9a4e47e629f7d /www
parentee0eb44e6254c2b681c5c843bd43130de6517ff1 (diff)
downloadfreebsd-ports-gnome-8e2ac725bb818044893d64d66a85a8023a6f3fb6.tar.gz
freebsd-ports-gnome-8e2ac725bb818044893d64d66a85a8023a6f3fb6.tar.zst
freebsd-ports-gnome-8e2ac725bb818044893d64d66a85a8023a6f3fb6.zip
- Unbreak.
Remove a useless check for sig_atomic_t that never worked because configure.ac calls AC_CHECK_SIZEOF without telling it to include signal.h Submitted upstream as https://github.com/cherokee/webserver/pull/1100 - Use the new LIB_DEPENDS syntax. PR: ports/180647 PR: ports/179726
Diffstat (limited to 'www')
-rw-r--r--www/cherokee/Makefile12
-rw-r--r--www/cherokee/files/patch-configure42
2 files changed, 47 insertions, 7 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 82f3904b4a35..519245465ad7 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -11,8 +11,6 @@ MASTER_SITE_SUBDIR=cherokee/1.2/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast and flexible web server
-BROKEN= Does not configure
-
USES= gettext gmake pathfix pkgconfig
USE_OPENSSL= yes
USE_LDCONFIG= yes
@@ -92,7 +90,7 @@ PLIST_SUB+= LDAP="@comment "
.endif
.if ${PORT_OPTIONS:MGEOIP}
-LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+=--with-geoip=yes
PLIST_SUB+= GEOIP=""
.else
@@ -101,9 +99,9 @@ PLIST_SUB+= GEOIP="@comment "
.endif
.if ${PORT_OPTIONS:MFFMPEG}
-LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg \
- avcodec:${PORTSDIR}/multimedia/ffmpeg \
- avutil:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavformat.so:${PORTSDIR}/multimedia/ffmpeg \
+ libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
+ libavutil.so:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+=--with-ffmpeg=yes
.else
CONFIGURE_ARGS+=--with-ffmpeg=no
@@ -119,7 +117,7 @@ PLIST_SUB+= NLS="@comment "
.if ${PORT_OPTIONS:MINTPCRE}
CONFIGURE_ARGS+=--enable-internal-pcre
.else
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
.endif
.if ${PORT_OPTIONS:MRRDTOOL}
diff --git a/www/cherokee/files/patch-configure b/www/cherokee/files/patch-configure
new file mode 100644
index 000000000000..3ef6e1370045
--- /dev/null
+++ b/www/cherokee/files/patch-configure
@@ -0,0 +1,42 @@
+--- configure.orig 2014-01-09 21:48:12.000000000 +0200
++++ configure 2014-01-09 21:48:32.000000000 +0200
+@@ -15471,39 +15471,6 @@
+ # version HP92453-01 B.11.11.23709.GP, which incorrectly rejects
+ # declarations like `int a3[[(sizeof (unsigned char)) >= 0]];'.
+ # This bug is HP SR number 8606223364.
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking size of sig_atomic_t" >&5
+-$as_echo_n "checking size of sig_atomic_t... " >&6; }
+-if ${ac_cv_sizeof_sig_atomic_t+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- if ac_fn_c_compute_int "$LINENO" "(long int) (sizeof (sig_atomic_t))" "ac_cv_sizeof_sig_atomic_t" "$ac_includes_default"; then :
+-
+-else
+- if test "$ac_cv_type_sig_atomic_t" = yes; then
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
+-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
+-as_fn_error 77 "cannot compute sizeof (sig_atomic_t)
+-See \`config.log' for more details" "$LINENO" 5; }
+- else
+- ac_cv_sizeof_sig_atomic_t=0
+- fi
+-fi
+-
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sizeof_sig_atomic_t" >&5
+-$as_echo "$ac_cv_sizeof_sig_atomic_t" >&6; }
+-
+-
+-
+-cat >>confdefs.h <<_ACEOF
+-#define SIZEOF_SIG_ATOMIC_T $ac_cv_sizeof_sig_atomic_t
+-_ACEOF
+-
+-
+-# The cast to long int works around a bug in the HP C Compiler
+-# version HP92453-01 B.11.11.23709.GP, which incorrectly rejects
+-# declarations like `int a3[[(sizeof (unsigned char)) >= 0]];'.
+-# This bug is HP SR number 8606223364.
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking size of time_t" >&5
+ $as_echo_n "checking size of time_t... " >&6; }
+ if ${ac_cv_sizeof_time_t+:} false; then :
/+5 * Update to 1.23lme2009-02-202-4/+4 * - Update to 0.12.4miwi2009-02-202-12/+6 * - Update to 1.2.8.2miwi2009-02-202-13/+6 * - update to 3.15leeym2009-02-203-7/+14 * - Update to 2.47tabthorpe2009-02-202-5/+4 * Support %b in printf-like functions as required to compile the FreeBSDbrooks2009-02-192-0/+14 * Update to 0.17lbr2009-02-192-4/+4 * - Update to 0.79clsung2009-02-192-4/+4 * - Update to 3.10.0clsung2009-02-192-4/+5 * - Add optional support for graphics/osg-devel, which should fix some renderin...amdmi32009-02-191-1/+6 * - Fix build, last commit was wrong.lwhsu2009-02-193-398/+407 * - Unbreaklwhsu2009-02-181-3/+3 * Update to 0.5.2:itetcu2009-02-182-4/+4 * Mark as ignore on sparc64 (arch not detected correctly).linimon2009-02-181-0/+4 * - Remove BROKEN on 8.x - this is devel/gdc problemamdmi32009-02-181-7/+1 * - Mark BROKEN: does not compilepav2009-02-181-0/+2 * - Mark BROKENpav2009-02-181-0/+2 * - Update to 0.14.21glarkin2009-02-182-4/+4 * - Pass maintainership to submittertabthorpe2009-02-175-5/+5 * Upgrade to a snapshot from yesterday (just pre 2.5).brooks2009-02-174-35/+123 * - Enable/Fix the template build of kapptemplate by using gmakemarkus2009-02-173-12/+12 * - Downgrade to 1.104miwi2009-02-172-5/+7 * Upgrade to 4.11.thierry2009-02-172-4/+4 * - Update to 2.0.8nivit2009-02-163-5/+5 * - Fix plistrafan2009-02-162-0/+10 * The itools library offers a collection of packages coveringmiwi2009-02-166-0/+604 * - Update to 4.7.0miwi2009-02-162-12/+5 * - Update to 2.9.0miwi2009-02-161-8/+2 * - Update to 0.38beat2009-02-163-4/+5 * Update to 1.149skv2009-02-162-4/+4 * - Update to 0.30miwi2009-02-162-5/+5 * - Update to 0.04miwi2009-02-162-5/+5 * - Update to 0.2.0miwi2009-02-162-5/+5 * Update to 0.8.1 (bugfix release)makc2009-02-165-23/+52 * Readd mistakenly removed post-install target.makc2009-02-161-0/+1 * - Update to 0.91miwi2009-02-163-5/+6 * - Update to 0.15miwi2009-02-162-5/+5 * - Update to 0.49miwi2009-02-162-4/+4 * Update to 0.70lbr2009-02-162-6/+6 * Update to 0.77lbr2009-02-162-4/+4 * - add LICENSE:dinoex2009-02-165-0/+11 * Update to 0.1.9erwin2009-02-152-4/+4 * - Fix maintainer mail adressmiwi2009-02-151-1/+1 * - Update to 0.11miwi2009-02-152-4/+4 * - Update to 0.9.35miwi2009-02-152-4/+4 * - Update to 0.8.2miwi2009-02-152-4/+4 * - Update to 1.16.0miwi2009-02-152-6/+7 * - Update to 1.105miwi2009-02-152-4/+4 * - update to 0.82leeym2009-02-152-4/+4 * - Update to 0.98.4rafan2009-02-152-4/+4 * Update to 1.412skv2009-02-153-9/+9 * Bump PORTREVISION after QScintilla2 updatemakc2009-02-152-2/+2 * Update PyQt4 ports to 4.4.4, new ports:makc2009-02-1541-605/+607 * Update to 1.61skv2009-02-152-5/+4 * Update to 0.04skv2009-02-153-6/+8 * Update to 3.2.2skv2009-02-156-10/+10 * Update to 0.69lbr2009-02-152-5/+4 * Update to 0.16lbr2009-02-152-4/+4 * - Update to 1.108miwi2009-02-153-14/+12 * - Update to 1.12.0miwi2009-02-152-5/+4 * - Update to 1.12miwi2009-02-156-10/+36 * - Update to 1.0.1miwi2009-02-15