aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-09-19 02:47:46 +0800
committerkris <kris@FreeBSD.org>2004-09-19 02:47:46 +0800
commit8e6a5fac22b2eadd32378144474e37250fd885ee (patch)
treeffa0a26b5bb3df44db20acf832f2952f7e1aac8f /www
parent478b91a3501b2386302f44aa2031b4d9cbc67b5c (diff)
downloadfreebsd-ports-gnome-8e6a5fac22b2eadd32378144474e37250fd885ee.tar.gz
freebsd-ports-gnome-8e6a5fac22b2eadd32378144474e37250fd885ee.tar.zst
freebsd-ports-gnome-8e6a5fac22b2eadd32378144474e37250fd885ee.zip
BROKEN on 5.x: Does not compile
Approved by: portmgr (self)
Diffstat (limited to 'www')
-rw-r--r--www/larbin/Makefile8
-rw-r--r--www/linux-nvu/Makefile2
2 files changed, 9 insertions, 1 deletions
diff --git a/www/larbin/Makefile b/www/larbin/Makefile
index dc61bb357ca1..36a39eb9665b 100644
--- a/www/larbin/Makefile
+++ b/www/larbin/Makefile
@@ -24,6 +24,12 @@ USE_REINPLACE= yes
PATCH_WRKSRC= ${WRKSRC}/src
MAKE_ARGS= CXX=${CXX}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${SED} -e 's,CC=,CC?=,' -e 's,CFLAGS=-O3,CFLAGS+=,' < \
${WRKSRC}/adns/Makefile > ${WRKSRC}/adns/Makefile.new
@@ -59,4 +65,4 @@ post-install:
@${ECHO} ""
@${ECHO} "====================================================================="
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/linux-nvu/Makefile b/www/linux-nvu/Makefile
index e79191a45d13..6009a1c3838a 100644
--- a/www/linux-nvu/Makefile
+++ b/www/linux-nvu/Makefile
@@ -23,6 +23,8 @@ RUN_DEPENDS= \
${LINUXBASE}/usr/lib/libpango-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango \
${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig
+BROKEN= "Conflicting dependencies (linux_base 7.x and 8.x)"
+
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
ONLY_FOR_ARCHS= i386