aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-07-30 08:27:20 +0800
committeredwin <edwin@FreeBSD.org>2004-07-30 08:27:20 +0800
commit96bc42bd50b6e0ce92efd4270778089f470bcddd (patch)
treebca43d2cae585325130423c86f14d1ea7892acdb /www
parentab4d517c82ab9bf88b5b60859e811f704b00c907 (diff)
downloadfreebsd-ports-gnome-96bc42bd50b6e0ce92efd4270778089f470bcddd.tar.gz
freebsd-ports-gnome-96bc42bd50b6e0ce92efd4270778089f470bcddd.tar.zst
freebsd-ports-gnome-96bc42bd50b6e0ce92efd4270778089f470bcddd.zip
[NEW PORT] www/mod_vhs: Allows mass virtual hosting using libhome system with Apache 2.0.x
mod_vhs is an Apache Web Server module allowing mass virtual hosting without the need for file based configuration. The virtual host paths are translated using libhome system to get the corrects path at request time. WWW: http://www.oav.net/projects/mod_vhs/ PR: ports/69616 Submitted by: Xavier Beaudouin <kiwi@oav.net>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_vhs/Makefile40
-rw-r--r--www/mod_vhs/distinfo2
-rw-r--r--www/mod_vhs/pkg-descr5
4 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 349be0eee8f8..79e953c6c626 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -314,6 +314,7 @@
SUBDIR += mod_uid
SUBDIR += mod_v2h
SUBDIR += mod_vdbh
+ SUBDIR += mod_vhs
SUBDIR += mod_watch
SUBDIR += mod_watch4
SUBDIR += mod_webapp
diff --git a/www/mod_vhs/Makefile b/www/mod_vhs/Makefile
new file mode 100644
index 000000000000..327b22a8b0e1
--- /dev/null
+++ b/www/mod_vhs/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: mod_vhs
+# Date created: Sun Jul 25 2004
+# Whom: Xavier Beaudouin <kiwi@oav.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_vhs
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://www.oav.net/projects/mod_vhs/
+DIST_SUBDIR= apache
+
+MAINTAINER= kiwi@oav.net
+COMMENT= Allows mass virtual hosting using libhome system with Apache 2.0.x
+
+LIB_DEPENDS+= home:${PORTSDIR}/misc/libhome
+
+WANT_APACHE= 2
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+AP_INC+= ${LOCALBASE}/include/home
+AP_LIB+= ${LOCALBASE}/lib -lhome
+
+PORTDOCS= AUTHORS README TODO
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+
+post-install:
+.if !defined (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_vhs/distinfo b/www/mod_vhs/distinfo
new file mode 100644
index 000000000000..84e7dc73ed43
--- /dev/null
+++ b/www/mod_vhs/distinfo
@@ -0,0 +1,2 @@
+MD5 (apache/mod_vhs-1.0.tar.gz) = 6479e56d2f54561db3f4b20dd53427ef
+SIZE (apache/mod_vhs-1.0.tar.gz) = 5497
diff --git a/www/mod_vhs/pkg-descr b/www/mod_vhs/pkg-descr
new file mode 100644
index 000000000000..9f6396e07ef6
--- /dev/null
+++ b/www/mod_vhs/pkg-descr
@@ -0,0 +1,5 @@
+mod_vhs is an Apache Web Server module allowing mass virtual hosting without
+the need for file based configuration. The virtual host paths are translated
+using libhome system to get the corrects path at request time.
+
+WWW: http://www.oav.net/projects/mod_vhs/