aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-10-12 01:47:04 +0800
committererwin <erwin@FreeBSD.org>2005-10-12 01:47:04 +0800
commit970a907cb3678a9fc70487fe1a28aff1fd09769f (patch)
tree8f1208a22d63b7d567544b0956ff5bedff1cd81a /www
parent215a2031ff076e67fa6d0ed6530fdeffb002dfcd (diff)
downloadfreebsd-ports-gnome-970a907cb3678a9fc70487fe1a28aff1fd09769f.tar.gz
freebsd-ports-gnome-970a907cb3678a9fc70487fe1a28aff1fd09769f.tar.zst
freebsd-ports-gnome-970a907cb3678a9fc70487fe1a28aff1fd09769f.zip
Add p5-WWW-Mixi 0.33, perl module of Automated interface to the Mixi.
Mixi is most famous as SNS of Japan. PR: ports/84617 Submitted by: TAKAHASHI Kaoru <kaoru@kaisei.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WWW-Mixi/Makefile32
-rw-r--r--www/p5-WWW-Mixi/distinfo2
-rw-r--r--www/p5-WWW-Mixi/pkg-descr4
-rw-r--r--www/p5-WWW-Mixi/pkg-plist9
5 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 380ee137648f..24d900366364 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -637,6 +637,7 @@
SUBDIR += p5-WWW-Mechanize
SUBDIR += p5-WWW-Mechanize-FormFiller
SUBDIR += p5-WWW-Mechanize-Shell
+ SUBDIR += p5-WWW-Mixi
SUBDIR += p5-WWW-Robot
SUBDIR += p5-WWW-Search
SUBDIR += p5-WWW-Search-AltaVista
diff --git a/www/p5-WWW-Mixi/Makefile b/www/p5-WWW-Mixi/Makefile
new file mode 100644
index 000000000000..f21ec8356305
--- /dev/null
+++ b/www/p5-WWW-Mixi/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-WWW-Mixi
+# Date created: 2005-08-06
+# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Mixi
+PORTVERSION= 0.33
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kaoru@kaisei.org
+COMMENT= Perl module of Automated interface to the Mixi
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/RobotUA.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Mixi.3 WWW::Mixi::Cookbook.3 WWW::Mixi::Mixi.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Mixi/distinfo b/www/p5-WWW-Mixi/distinfo
new file mode 100644
index 000000000000..6e66cbb23e42
--- /dev/null
+++ b/www/p5-WWW-Mixi/distinfo
@@ -0,0 +1,2 @@
+MD5 (WWW-Mixi-0.33.tar.gz) = 08fb215ff78759f77ffcb2db840db636
+SIZE (WWW-Mixi-0.33.tar.gz) = 36409
diff --git a/www/p5-WWW-Mixi/pkg-descr b/www/p5-WWW-Mixi/pkg-descr
new file mode 100644
index 000000000000..beff022d806a
--- /dev/null
+++ b/www/p5-WWW-Mixi/pkg-descr
@@ -0,0 +1,4 @@
+WWW::Mixi provides an automated interface to the Mixi <http://mixi.jp/>.
+Mixi is most famous as SNS of Japan.
+
+WWW: http://digit.que.ne.jp/work/?WWW%3a%3aMixi
diff --git a/www/p5-WWW-Mixi/pkg-plist b/www/p5-WWW-Mixi/pkg-plist
new file mode 100644
index 000000000000..830855717f4d
--- /dev/null
+++ b/www/p5-WWW-Mixi/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mixi/.packlist
+%%SITE_PERL%%/WWW/Mixi.pm
+%%SITE_PERL%%/WWW/Mixi/Cookbook.pod
+%%SITE_PERL%%/WWW/Mixi/Mixi.pod
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mixi
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW 2>/dev/null || true
+@dirrm %%SITE_PERL%%/WWW/Mixi
+@unexec rmdir %D/%%SITE_PERL%%/WWW 2>/dev/null || true