aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-12 05:54:28 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-12 05:54:28 +0800
commita119c041197c005cb86dc015720ded081c02a9cc (patch)
treebf2a8855818e950a21204017582734010b1f53b8 /www
parentf5ecee5e32e03b4f7e94a6ca7698317f8bc86b63 (diff)
downloadfreebsd-ports-gnome-a119c041197c005cb86dc015720ded081c02a9cc.tar.gz
freebsd-ports-gnome-a119c041197c005cb86dc015720ded081c02a9cc.tar.zst
freebsd-ports-gnome-a119c041197c005cb86dc015720ded081c02a9cc.zip
Tatsumaki is a toy port of Tornado for Perl using Plack (with
non-blocking extensions) and AnyEvent. It allows you to write a web application that does a immediate response with template rendering, IO-bound delayed response (like fetching third party API or XML feeds), server push streaming and long-poll Comet in a clean unified API. WWW: http://search.cpan.org/dist/Tatsumaki/ PR: ports/153007 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Tatsumaki/Makefile39
-rw-r--r--www/p5-Tatsumaki/distinfo2
-rw-r--r--www/p5-Tatsumaki/pkg-descr9
-rw-r--r--www/p5-Tatsumaki/pkg-plist17
5 files changed, 68 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 40052f8e9e02..5e531cb3c289 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1186,6 +1186,7 @@
SUBDIR += p5-Syntax-Highlight-Shell
SUBDIR += p5-Task-Catalyst
SUBDIR += p5-Task-Plack
+ SUBDIR += p5-Tatsumaki
SUBDIR += p5-Template-Alloy
SUBDIR += p5-Template-GD
SUBDIR += p5-Template-Iterator-AlzaboWrapperCursor
diff --git a/www/p5-Tatsumaki/Makefile b/www/p5-Tatsumaki/Makefile
new file mode 100644
index 000000000000..f9bf6e692d9e
--- /dev/null
+++ b/www/p5-Tatsumaki/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Tatsumaki
+# Date created: 2010-12-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tatsumaki
+PORTVERSION= 0.1010
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/MI/MIYAGAWA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Non-blocking web framework based on Plack and AnyEvent
+
+RUN_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-AnyEvent-HTTP>=0:${PORTSDIR}/www/p5-AnyEvent-HTTP \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-Mouse>=0:${PORTSDIR}/devel/p5-Mouse \
+ p5-Plack>=0:${PORTSDIR}/www/p5-Plack \
+ p5-Text-MicroTemplate>=0:${PORTSDIR}/textproc/p5-Text-MicroTemplate \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-Twiggy>=0:${PORTSDIR}/www/p5-Twiggy
+
+PERL_CONFIGURE= yes
+
+MAN3= Tatsumaki.3 \
+ Tatsumaki::MessageQueue.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Tatsumaki/distinfo b/www/p5-Tatsumaki/distinfo
new file mode 100644
index 000000000000..511315f04dd6
--- /dev/null
+++ b/www/p5-Tatsumaki/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Tatsumaki-0.1010.tar.gz) = 3541fdc6fe7ad700aefd74d6525e044129b72764ceef329d833b3c737026b41c
+SIZE (Tatsumaki-0.1010.tar.gz) = 100348
diff --git a/www/p5-Tatsumaki/pkg-descr b/www/p5-Tatsumaki/pkg-descr
new file mode 100644
index 000000000000..d8b48e9a9487
--- /dev/null
+++ b/www/p5-Tatsumaki/pkg-descr
@@ -0,0 +1,9 @@
+Tatsumaki is a toy port of Tornado for Perl using Plack (with
+non-blocking extensions) and AnyEvent.
+
+It allows you to write a web application that does a immediate
+response with template rendering, IO-bound delayed response (like
+fetching third party API or XML feeds), server push streaming and
+long-poll Comet in a clean unified API.
+
+WWW: http://search.cpan.org/dist/Tatsumaki/
diff --git a/www/p5-Tatsumaki/pkg-plist b/www/p5-Tatsumaki/pkg-plist
new file mode 100644
index 000000000000..e5b59159d20b
--- /dev/null
+++ b/www/p5-Tatsumaki/pkg-plist
@@ -0,0 +1,17 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tatsumaki/.packlist
+%%SITE_PERL%%/Tatsumaki.pm
+%%SITE_PERL%%/Tatsumaki/Application.pm
+%%SITE_PERL%%/Tatsumaki/Error.pm
+%%SITE_PERL%%/Tatsumaki/HTTPClient.pm
+%%SITE_PERL%%/Tatsumaki/Handler.pm
+%%SITE_PERL%%/Tatsumaki/MessageQueue.pm
+%%SITE_PERL%%/Tatsumaki/Request.pm
+%%SITE_PERL%%/Tatsumaki/Response.pm
+%%SITE_PERL%%/Tatsumaki/Server.pm
+%%SITE_PERL%%/Tatsumaki/Service.pm
+%%SITE_PERL%%/Tatsumaki/Template.pm
+%%SITE_PERL%%/Tatsumaki/Template/Micro.pm
+@dirrmtry %%SITE_PERL%%/Tatsumaki/Template
+@dirrmtry %%SITE_PERL%%/Tatsumaki
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tatsumaki