aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-08-23 03:06:03 +0800
committermiwi <miwi@FreeBSD.org>2009-08-23 03:06:03 +0800
commita6075065f2840be96b88f8209bdcc09b46bcf433 (patch)
tree48ef28fe7a1399cac46874052c9c2bcf9bc92072 /www
parent6d3d2421e87b4389b6f8855b9f6c061b17a642c7 (diff)
downloadfreebsd-ports-gnome-a6075065f2840be96b88f8209bdcc09b46bcf433.tar.gz
freebsd-ports-gnome-a6075065f2840be96b88f8209bdcc09b46bcf433.tar.zst
freebsd-ports-gnome-a6075065f2840be96b88f8209bdcc09b46bcf433.zip
net2ftp is a web-based FTP client written in PHP
User features - Navigate the FTP server - Upload files - Download files - Zip files - Unzip files - Install software - Copy, move and delete - Copy or move to a 2nd FTP server - Rename and chmod - View code with syntax highlighting - Plain text editor - HTML editors - Code editor - Search for words or phrases - Calculate size WWW: http://www.net2ftp.com/ PR: ports/137868 Submitted by: Alexander Kriventsov
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/repos-style/Makefile45
-rw-r--r--www/repos-style/distinfo3
-rw-r--r--www/repos-style/files/patch-open-log-index.php11
-rw-r--r--www/repos-style/files/patch-view-log.xsl11
-rw-r--r--www/repos-style/files/patch-view-repos.xsl11
-rw-r--r--www/repos-style/files/pkg-message.in17
-rw-r--r--www/repos-style/pkg-descr20
-rw-r--r--www/repos-style/pkg-plist72
9 files changed, 191 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2b5f48e3dbe1..66273b66caf1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1353,6 +1353,7 @@
SUBDIR += rejik
SUBDIR += rekonq
SUBDIR += reportmagic
+ SUBDIR += repos-style
SUBDIR += resin2
SUBDIR += resin3
SUBDIR += retawq
diff --git a/www/repos-style/Makefile b/www/repos-style/Makefile
new file mode 100644
index 000000000000..486f69875bdf
--- /dev/null
+++ b/www/repos-style/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: repos-style
+# Date created: 12 Aug 2009
+# Whom: Alexander Kriventsov
+#
+# $FreeBSD$
+#
+
+PORTNAME= repos-style
+PORTVERSION= 2.0
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/ \
+ http://mirror.amdmi3.ru/distfiles/
+
+MAINTAINER= avk@vl.ru
+COMMENT= Stylesheet for the Subversion index web page
+
+RUN_DEPENDS= subversion>=0:${PORTSDIR}/devel/subversion
+
+USE_ZIP= YES
+NO_BUILD= YES
+
+USE_PHP= xml
+WANT_PHP_WEB= yes
+
+WRKSRC= ${WRKDIR}/repos-web
+
+SUB_LIST+= PORTNAME=${PORTNAME}
+SUB_FILES+= pkg-message
+
+pre-install:
+# Prevent installation of .orig files by deleting them.
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
+ ${MV} ${WRKSRC}/open/log/index.php ${WRKSRC}/open/log/index.dist.php
+
+do-install:
+ @${MKDIR} ${WWWDIR}
+ @(cd ${WRKSRC} && ${PAX} -r -w . ${WWWDIR})
+ if [ ! -f ${WWWDIR}/open/log/index.php ]; then \
+ ${CP} -p ${WWWDIR}/open/log/index.dist.php ${WWWDIR}/open/log/index.php; \
+ fi
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/repos-style/distinfo b/www/repos-style/distinfo
new file mode 100644
index 000000000000..e7e62d16013c
--- /dev/null
+++ b/www/repos-style/distinfo
@@ -0,0 +1,3 @@
+MD5 (repos-style-2.0.zip) = cbf01422ae18af8a01046e2e01b04111
+SHA256 (repos-style-2.0.zip) = a7f426b524e511902bb231b7fb413930f8cbc8be2f30790cdc8fe68413a1c71f
+SIZE (repos-style-2.0.zip) = 166618
diff --git a/www/repos-style/files/patch-open-log-index.php b/www/repos-style/files/patch-open-log-index.php
new file mode 100644
index 000000000000..63cf7f4be669
--- /dev/null
+++ b/www/repos-style/files/patch-open-log-index.php
@@ -0,0 +1,11 @@
+--- open/log/index.php.orig 2009-03-13 11:39:06.000000000 +0100
++++ open/log/index.php 2009-08-21 22:36:25.000000000 +0200
+@@ -18,7 +18,7 @@
+ // === Print svn log --xml to response ===
+
+ // Set the URL to the stylesheet, must be same host or absolute path from root
+-$xslt = '/repos-web/view/log.xsl';
++$xslt = '/repos-style/view/log.xsl';
+
+ // URL or path to repository, no trailing slash
+ // (note that the log viewer may bypass access control)
diff --git a/www/repos-style/files/patch-view-log.xsl b/www/repos-style/files/patch-view-log.xsl
new file mode 100644
index 000000000000..60da8b5f9fa6
--- /dev/null
+++ b/www/repos-style/files/patch-view-log.xsl
@@ -0,0 +1,11 @@
+--- view/log.xsl.orig 2009-03-12 22:15:36.000000000 +0100
++++ view/log.xsl 2009-08-21 22:39:20.000000000 +0200
+@@ -25,7 +25,7 @@
+
+ <!-- === repos style configuration === -->
+ <!-- static: absolute url to style application -->
+- <xsl:param name="static">/repos-web/</xsl:param>
++ <xsl:param name="static">/repos-style/</xsl:param>
+ <!-- cssUrl: absolute url to css folder -->
+ <xsl:param name="cssUrl"><xsl:value-of select="$static"/>style/</xsl:param>
+ <!-- log viewer does not know the repository URL -->
diff --git a/www/repos-style/files/patch-view-repos.xsl b/www/repos-style/files/patch-view-repos.xsl
new file mode 100644
index 000000000000..b7a9d8d9f85c
--- /dev/null
+++ b/www/repos-style/files/patch-view-repos.xsl
@@ -0,0 +1,11 @@
+--- view/repos.xsl.orig 2009-03-13 09:34:04.000000000 +0100
++++ view/repos.xsl 2009-08-21 22:42:04.000000000 +0200
+@@ -31,7 +31,7 @@
+
+ <!-- === repos style configuration === -->
+ <!-- static: absolute url to style application -->
+- <xsl:param name="static">/repos-web/</xsl:param>
++ <xsl:param name="static">/repos-style/</xsl:param>
+ <!-- cssUrl: absolute url to css folder -->
+ <xsl:param name="cssUrl"><xsl:value-of select="$static"/>style/</xsl:param>
+ <!-- logUrl: empty -> no log tool, absolute url -> enable 'history' link. Must allow appended query param -->
diff --git a/www/repos-style/files/pkg-message.in b/www/repos-style/files/pkg-message.in
new file mode 100644
index 000000000000..c07d26360d0c
--- /dev/null
+++ b/www/repos-style/files/pkg-message.in
@@ -0,0 +1,17 @@
+%%PORTNAME%% has been installed into:
+
+ %%WWWDIR%%
+
+To make repos-web available through your web site, I suggest
+that you add something like the following to httpd.conf:
+
+Alias /%%PORTNAME%% %%WWWDIR%%
+SVNIndexXSLT "/%%PORTNAME%%/view/repos.xsl"
+
+To set up the Very Simple Logviewer in %%PORTNAME%%/open/log/index.php there is a line:
+$repo = '@@Repository@@'; // repository root, no trailing slash
+Replace @@Repository@@ with the subversion url to your repository root.
+It can be any subversion URL, both http:// and file:///. You can use
+"http:" if you have public read access to the repository.
+
+
diff --git a/www/repos-style/pkg-descr b/www/repos-style/pkg-descr
new file mode 100644
index 000000000000..d58bba83d99f
--- /dev/null
+++ b/www/repos-style/pkg-descr
@@ -0,0 +1,20 @@
+net2ftp is a web-based FTP client written in PHP
+
+User features
+ - Navigate the FTP server
+ - Upload files
+ - Download files
+ - Zip files
+ - Unzip files
+ - Install software
+ - Copy, move and delete
+ - Copy or move to a 2nd FTP server
+ - Rename and chmod
+ - View code with syntax highlighting
+ - Plain text editor
+ - HTML editors
+ - Code editor
+ - Search for words or phrases
+ - Calculate size
+
+WWW: http://www.net2ftp.com/
diff --git a/www/repos-style/pkg-plist b/www/repos-style/pkg-plist
new file mode 100644
index 000000000000..26916ffa8191
--- /dev/null
+++ b/www/repos-style/pkg-plist
@@ -0,0 +1,72 @@
+%%WWWDIR%%/Cezanne-LICENSE.txt
+%%WWWDIR%%/LICENSE-2.0.txt
+@unexec if cmp -s %D/%%WWWDIR%%/open/log/index.dist.php %D/%%WWWDIR%%/open/log/index.php; then rm -f %D/%%WWWDIR%%/open/log/index.php; fi
+%%WWWDIR%%/open/log/index.dist.php
+@exec if [ ! -f %D/%%WWWDIR%%/open/log/index.php ]; then cp -p %D/%%WWWDIR%%/open/log/index.dist.php %D/%%WWWDIR%%/open/log/index.php; fi
+%%WWWDIR%%/style/commands/16x16/back.png
+%%WWWDIR%%/style/commands/16x16/download.png
+%%WWWDIR%%/style/commands/16x16/history.png
+%%WWWDIR%%/style/commands/16x16/home.png
+%%WWWDIR%%/style/commands/16x16/parent.png
+%%WWWDIR%%/style/commands/16x16/refresh.png
+%%WWWDIR%%/style/commands/16x16/repository.png
+%%WWWDIR%%/style/commands/16x16/user.png
+%%WWWDIR%%/style/global.css
+%%WWWDIR%%/style/log/16x16/a.png
+%%WWWDIR%%/style/log/16x16/copiedfrom.png
+%%WWWDIR%%/style/log/16x16/d.png
+%%WWWDIR%%/style/log/16x16/m.png
+%%WWWDIR%%/style/log/16x16/message.png
+%%WWWDIR%%/style/log/log.css
+%%WWWDIR%%/style/repository/16x16/binary.png
+%%WWWDIR%%/style/repository/16x16/file.png
+%%WWWDIR%%/style/repository/16x16/folder.png
+%%WWWDIR%%/style/repository/16x16/folder_branches.png
+%%WWWDIR%%/style/repository/16x16/folder_tags.png
+%%WWWDIR%%/style/repository/16x16/folder_trunk.png
+%%WWWDIR%%/style/repository/filetypes/16x16/ai.png
+%%WWWDIR%%/style/repository/filetypes/16x16/bmp.png
+%%WWWDIR%%/style/repository/filetypes/16x16/chm.png
+%%WWWDIR%%/style/repository/filetypes/16x16/doc.png
+%%WWWDIR%%/style/repository/filetypes/16x16/exe.png
+%%WWWDIR%%/style/repository/filetypes/16x16/gif.png
+%%WWWDIR%%/style/repository/filetypes/16x16/gz.png
+%%WWWDIR%%/style/repository/filetypes/16x16/htm.png
+%%WWWDIR%%/style/repository/filetypes/16x16/html.png
+%%WWWDIR%%/style/repository/filetypes/16x16/ics.png
+%%WWWDIR%%/style/repository/filetypes/16x16/jar.png
+%%WWWDIR%%/style/repository/filetypes/16x16/java.png
+%%WWWDIR%%/style/repository/filetypes/16x16/jpg.png
+%%WWWDIR%%/style/repository/filetypes/16x16/log.png
+%%WWWDIR%%/style/repository/filetypes/16x16/mpg.png
+%%WWWDIR%%/style/repository/filetypes/16x16/pdf.png
+%%WWWDIR%%/style/repository/filetypes/16x16/php.png
+%%WWWDIR%%/style/repository/filetypes/16x16/png.png
+%%WWWDIR%%/style/repository/filetypes/16x16/ps.png
+%%WWWDIR%%/style/repository/filetypes/16x16/psd.png
+%%WWWDIR%%/style/repository/filetypes/16x16/qt.png
+%%WWWDIR%%/style/repository/filetypes/16x16/sh.png
+%%WWWDIR%%/style/repository/filetypes/16x16/sit.png
+%%WWWDIR%%/style/repository/filetypes/16x16/sxw.png
+%%WWWDIR%%/style/repository/filetypes/16x16/tif.png
+%%WWWDIR%%/style/repository/filetypes/16x16/tmp.png
+%%WWWDIR%%/style/repository/filetypes/16x16/txt.png
+%%WWWDIR%%/style/repository/filetypes/16x16/vcf.png
+%%WWWDIR%%/style/repository/filetypes/16x16/zip.png
+%%WWWDIR%%/style/repository/repository.css
+%%WWWDIR%%/style/rowbackground.png
+%%WWWDIR%%/view/log.xsl
+%%WWWDIR%%/view/repos.xsl
+@dirrmtry %%WWWDIR%%/view
+@dirrmtry %%WWWDIR%%/style/repository/filetypes/16x16
+@dirrmtry %%WWWDIR%%/style/repository/filetypes
+@dirrmtry %%WWWDIR%%/style/repository/16x16
+@dirrmtry %%WWWDIR%%/style/repository
+@dirrmtry %%WWWDIR%%/style/log/16x16
+@dirrmtry %%WWWDIR%%/style/log
+@dirrmtry %%WWWDIR%%/style/commands/16x16
+@dirrmtry %%WWWDIR%%/style/commands
+@dirrmtry %%WWWDIR%%/style
+@dirrmtry %%WWWDIR%%/open/log
+@dirrmtry %%WWWDIR%%/open
+@dirrmtry %%WWWDIR%%/