aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbofh <bofh@FreeBSD.org>2015-11-21 18:41:58 +0800
committerbofh <bofh@FreeBSD.org>2015-11-21 18:41:58 +0800
commita97acb19cdfdff3d58b864eb551003095078dd7f (patch)
tree0419f19fa43375fdabb19fb2c70bca7bbf65be30 /www
parent98a69b7645ca575714b14dc83b49356c139f34ca (diff)
downloadfreebsd-ports-gnome-a97acb19cdfdff3d58b864eb551003095078dd7f.tar.gz
freebsd-ports-gnome-a97acb19cdfdff3d58b864eb551003095078dd7f.tar.zst
freebsd-ports-gnome-a97acb19cdfdff3d58b864eb551003095078dd7f.zip
[NEW] www/py3-aiohttp: HTTP client/server for asyncio
- Python3 specific version for www/py-aiohttp; although this uses a version 3.3+ but unfortunately the dependent still uses version 2 HTTP client/server for Python asyncio (PEP-3156) Features: * Compression (deflate) * HTTP Basic Authenntication * Chunked Transfer Encoding * Connection Pooling * Session Cookies * Custom Request/Response classes WWW: https://github.com/KeepSafe/aiohttp
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py3-aiohttp/Makefile35
-rw-r--r--www/py3-aiohttp/distinfo2
-rw-r--r--www/py3-aiohttp/pkg-descr12
4 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index cad65ec0f2e2..84e03cf5a92b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1777,6 +1777,7 @@
SUBDIR += py-wsgiauth
SUBDIR += py-wsgidav
SUBDIR += py-zope.app.wsgi
+ SUBDIR += py3-aiohttp
SUBDIR += pyblosxom
SUBDIR += pycarddav
SUBDIR += pydio
diff --git a/www/py3-aiohttp/Makefile b/www/py3-aiohttp/Makefile
new file mode 100644
index 000000000000..dab59ef6c044
--- /dev/null
+++ b/www/py3-aiohttp/Makefile
@@ -0,0 +1,35 @@
+# Created by: Muhammad Moinur Rahman <bofh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aiohttp
+PORTVERSION= 0.16.3
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= HTTP client/server for asyncio
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>0:${PORTSDIR}/textproc/py3-chardet
+TEST_DEPENDS:= ${RUN_DEPENDS} \
+ ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}gunicorn>0:${PORTSDIR}/www/py-gunicorn
+
+OPTIONS_DEFINE= TESTS
+TESTS_DESC= Install test suite requirements
+TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+
+USES= python:3
+USE_PYTHON= autoplist distutils
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/aiohttp/_websocket.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/aiohttp/_multidict.so
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/www/py3-aiohttp/distinfo b/www/py3-aiohttp/distinfo
new file mode 100644
index 000000000000..7e22ed2b048f
--- /dev/null
+++ b/www/py3-aiohttp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (aiohttp-0.16.3.tar.gz) = eaf479acc98ffee0a029882465ebf21f3c302e1b94a41b16c8a5a695bc614900
+SIZE (aiohttp-0.16.3.tar.gz) = 1442720
diff --git a/www/py3-aiohttp/pkg-descr b/www/py3-aiohttp/pkg-descr
new file mode 100644
index 000000000000..4dbd52fa53ce
--- /dev/null
+++ b/www/py3-aiohttp/pkg-descr
@@ -0,0 +1,12 @@
+HTTP client/server for Python asyncio (PEP-3156)
+
+Features:
+
+ * Compression (deflate)
+ * HTTP Basic Authenntication
+ * Chunked Transfer Encoding
+ * Connection Pooling
+ * Session Cookies
+ * Custom Request/Response classes
+
+WWW: https://github.com/KeepSafe/aiohttp