aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-17 09:07:48 +0800
committermarcus <marcus@FreeBSD.org>2004-02-17 09:07:48 +0800
commitad316e4aaa27c7b8e7b9f3e98cfc5383a8bd77ab (patch)
tree0f4b69e90a4cbe8905424f7b1c9f9fb97d97875a /www
parent2943bbc2c81bd8fdde94d2d6fa7b353c04e8edaf (diff)
downloadfreebsd-ports-gnome-ad316e4aaa27c7b8e7b9f3e98cfc5383a8bd77ab.tar.gz
freebsd-ports-gnome-ad316e4aaa27c7b8e7b9f3e98cfc5383a8bd77ab.tar.zst
freebsd-ports-gnome-ad316e4aaa27c7b8e7b9f3e98cfc5383a8bd77ab.zip
Update to 1.3.13.
Diffstat (limited to 'www')
-rw-r--r--www/galeon2/Makefile4
-rw-r--r--www/galeon2/distinfo3
-rw-r--r--www/galeon2/files/mkinstalldirs111
-rw-r--r--www/galeon2/files/patch-bookmarks_bookmarks-add-dialog.c16
4 files changed, 115 insertions, 19 deletions
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index d77c7823bff6..c9b17fd9c63b 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= galeon2
-PORTVERSION= 1.3.12
-PORTREVISION= 1
+PORTVERSION= 1.3.13
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://osdn.dl.sourceforge.net/sourceforge/galeon/
@@ -90,6 +89,7 @@ post-patch:
@${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";|'
+ @${CP} ${FILESDIR}/mkinstalldirs ${WRKSRC}
post-configure:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
diff --git a/www/galeon2/distinfo b/www/galeon2/distinfo
index d7a9609b1890..36daab305024 100644
--- a/www/galeon2/distinfo
+++ b/www/galeon2/distinfo
@@ -1 +1,2 @@
-MD5 (galeon-1.3.12.tar.bz2) = dac3aac7df1169da9b065d053644a69c
+MD5 (galeon-1.3.13.tar.bz2) = d8e33f29fd4b4175eb76bf198e06ab61
+SIZE (galeon-1.3.13.tar.bz2) = 3331104
diff --git a/www/galeon2/files/mkinstalldirs b/www/galeon2/files/mkinstalldirs
new file mode 100644
index 000000000000..d2d5f21b6112
--- /dev/null
+++ b/www/galeon2/files/mkinstalldirs
@@ -0,0 +1,111 @@
+#! /bin/sh
+# mkinstalldirs --- make directory hierarchy
+# Author: Noah Friedman <friedman@prep.ai.mit.edu>
+# Created: 1993-05-16
+# Public domain
+
+errstatus=0
+dirmode=""
+
+usage="\
+Usage: mkinstalldirs [-h] [--help] [-m mode] dir ..."
+
+# process command line arguments
+while test $# -gt 0 ; do
+ case $1 in
+ -h | --help | --h*) # -h for help
+ echo "$usage" 1>&2
+ exit 0
+ ;;
+ -m) # -m PERM arg
+ shift
+ test $# -eq 0 && { echo "$usage" 1>&2; exit 1; }
+ dirmode=$1
+ shift
+ ;;
+ --) # stop option processing
+ shift
+ break
+ ;;
+ -*) # unknown option
+ echo "$usage" 1>&2
+ exit 1
+ ;;
+ *) # first non-opt arg
+ break
+ ;;
+ esac
+done
+
+for file
+do
+ if test -d "$file"; then
+ shift
+ else
+ break
+ fi
+done
+
+case $# in
+ 0) exit 0 ;;
+esac
+
+case $dirmode in
+ '')
+ if mkdir -p -- . 2>/dev/null; then
+ echo "mkdir -p -- $*"
+ exec mkdir -p -- "$@"
+ fi
+ ;;
+ *)
+ if mkdir -m "$dirmode" -p -- . 2>/dev/null; then
+ echo "mkdir -m $dirmode -p -- $*"
+ exec mkdir -m "$dirmode" -p -- "$@"
+ fi
+ ;;
+esac
+
+for file
+do
+ set fnord `echo ":$file" | sed -ne 's/^:\//#/;s/^://;s/\// /g;s/^#/\//;p'`
+ shift
+
+ pathcomp=
+ for d
+ do
+ pathcomp="$pathcomp$d"
+ case $pathcomp in
+ -*) pathcomp=./$pathcomp ;;
+ esac
+
+ if test ! -d "$pathcomp"; then
+ echo "mkdir $pathcomp"
+
+ mkdir "$pathcomp" || lasterr=$?
+
+ if test ! -d "$pathcomp"; then
+ errstatus=$lasterr
+ else
+ if test ! -z "$dirmode"; then
+ echo "chmod $dirmode $pathcomp"
+ lasterr=""
+ chmod "$dirmode" "$pathcomp" || lasterr=$?
+
+ if test ! -z "$lasterr"; then
+ errstatus=$lasterr
+ fi
+ fi
+ fi
+ fi
+
+ pathcomp="$pathcomp/"
+ done
+done
+
+exit $errstatus
+
+# Local Variables:
+# mode: shell-script
+# sh-indentation: 2
+# End:
+# mkinstalldirs ends here
diff --git a/www/galeon2/files/patch-bookmarks_bookmarks-add-dialog.c b/www/galeon2/files/patch-bookmarks_bookmarks-add-dialog.c
deleted file mode 100644
index 8509c7aeffb2..000000000000
--- a/www/galeon2/files/patch-bookmarks_bookmarks-add-dialog.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- bookmarks/bookmarks-add-dialog.c.orig Fri Jan 23 01:53:29 2004
-+++ bookmarks/bookmarks-add-dialog.c Fri Jan 23 01:53:48 2004
-@@ -397,11 +397,12 @@
- gint int1, gint int2)
- {
- GbTreeView *treeview = gb_tree_view_new();
-+ GtkWidget *widget;
-
- g_signal_handlers_disconnect_matched(treeview, G_SIGNAL_MATCH_DATA,
- 0, 0, NULL, NULL, treeview);
-
-- GtkWidget *widget = GTK_WIDGET(treeview);
-+ widget = GTK_WIDGET(treeview);
- gtk_widget_show(widget);
- return widget;
- }