aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-11-11 13:09:03 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-11-11 13:09:03 +0800
commitb764e8a2032b129b6cf3342a3c66933deaa6d88c (patch)
treef4b4eb9ed23d455f1c7729431c91604cfe6627bd /www
parent4e87c9eae0f0627bcf95025bf1ec7770411ab21e (diff)
downloadfreebsd-ports-gnome-b764e8a2032b129b6cf3342a3c66933deaa6d88c.tar.gz
freebsd-ports-gnome-b764e8a2032b129b6cf3342a3c66933deaa6d88c.tar.zst
freebsd-ports-gnome-b764e8a2032b129b6cf3342a3c66933deaa6d88c.zip
This is a port of mod_auth_mellon, which is an apache module built around lasso
that provides a SAML 2 SP endpoint. WWW: http://docs.feide.no/fs-0050 WWW: http://code.google.com/p/modmellon/ PR: ports/152083 Submitted by: Tom Judge <tom at tomjudge.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_auth_mellon/Makefile33
-rw-r--r--www/mod_auth_mellon/distinfo3
-rw-r--r--www/mod_auth_mellon/pkg-descr5
4 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7360b046c20b..dc841f6f1275 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -443,6 +443,7 @@
SUBDIR += mod_auth_kerb
SUBDIR += mod_auth_kerb2
SUBDIR += mod_auth_ldap
+ SUBDIR += mod_auth_mellon
SUBDIR += mod_auth_mysql
SUBDIR += mod_auth_mysql2
SUBDIR += mod_auth_mysql_another
diff --git a/www/mod_auth_mellon/Makefile b/www/mod_auth_mellon/Makefile
new file mode 100644
index 000000000000..5e31c5a37a6f
--- /dev/null
+++ b/www/mod_auth_mellon/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mod_auth_mellon
+# Date created: 2010-20-8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_auth_mellon
+PORTVERSION= 0.3.0
+CATEGORIES= www
+MASTER_SITES= http://modmellon.googlecode.com/files/
+DIST_SUBDIR= apache2
+
+MAINTAINER= tom@tomjudge.com
+COMMENT= Apache auth module for identifying SSO users
+
+LIB_DEPENDS= lasso.8:${PORTSDIR}/security/lasso \
+ curl.6:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-apxs2=${APXS}
+CONFIGURE_ENV+= OPENSSL_CFLAGS="-Wall" OPENSSL_LIBS="-lssl"
+
+USE_APACHE= 2.2+
+
+PLIST_FILES= ${APACHEMODDIR}/mod_auth_mellon.so
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-pthread|-Wl,-pthread|g' \
+ -e 's| -L| -Wl,-L|g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_mellon/distinfo b/www/mod_auth_mellon/distinfo
new file mode 100644
index 000000000000..3663faa463ab
--- /dev/null
+++ b/www/mod_auth_mellon/distinfo
@@ -0,0 +1,3 @@
+MD5 (apache2/mod_auth_mellon-0.3.0.tar.gz) = 3f49d366ec1e4a48880945d57a4f12af
+SHA256 (apache2/mod_auth_mellon-0.3.0.tar.gz) = 35e8b93a35e9b88cff7edcb62f9b6f76162cd843e578887de3ba83533a2bd397
+SIZE (apache2/mod_auth_mellon-0.3.0.tar.gz) = 92252
diff --git a/www/mod_auth_mellon/pkg-descr b/www/mod_auth_mellon/pkg-descr
new file mode 100644
index 000000000000..c70fcf9391ea
--- /dev/null
+++ b/www/mod_auth_mellon/pkg-descr
@@ -0,0 +1,5 @@
+This is a port of mod_auth_mellon, which is an apache module built around lasso
+that provides a SAML 2 SP endpoint.
+
+WWW: http://docs.feide.no/fs-0050
+WWW: http://code.google.com/p/modmellon/