aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-03 14:36:41 +0800
committerbapt <bapt@FreeBSD.org>2013-09-03 14:36:41 +0800
commitba924988158be48f52fe628d4fbe1d11f24c3ba4 (patch)
tree49a1c0a19d2528061ed83095e4acf1b3cab87fe5 /www
parentf0ce14b31f1feae1fbe0f8354dfae3db067a6190 (diff)
downloadfreebsd-ports-gnome-ba924988158be48f52fe628d4fbe1d11f24c3ba4.tar.gz
freebsd-ports-gnome-ba924988158be48f52fe628d4fbe1d11f24c3ba4.tar.zst
freebsd-ports-gnome-ba924988158be48f52fe628d4fbe1d11f24c3ba4.zip
Add an explicit dependency on pkgconf
Diffstat (limited to 'www')
-rw-r--r--www/bluefish/Makefile2
-rw-r--r--www/cssed/Makefile2
-rw-r--r--www/libepc/Makefile9
-rw-r--r--www/libgtkhtml/Makefile8
-rw-r--r--www/mod_auth_mellon/Makefile1
5 files changed, 7 insertions, 15 deletions
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index 5ceb410d2510..b8dc269b408a 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -19,7 +19,7 @@ INSTALLS_ICONS= yes
USE_LDCONFIG= yes
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomeprefix gtk20 gnomevfs2 gnomemimedata desktopfileutils
WANT_GNOME= yes
GNU_CONFIGURE= yes
diff --git a/www/cssed/Makefile b/www/cssed/Makefile
index f67c5bddd358..f2c4706aa389 100644
--- a/www/cssed/Makefile
+++ b/www/cssed/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= An application to help CSS style sheets creation and maintenance
-USES= pathfix
+USES= pathfix pkgconfig
USE_GNOME= gtk20 libxml2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/www/libepc/Makefile b/www/libepc/Makefile
index 8977fcb8985c..7152628e2cb6 100644
--- a/www/libepc/Makefile
+++ b/www/libepc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libepc
-# Date created: 24 Mar 2008
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libepc
PORTVERSION= 0.3.11
@@ -19,8 +15,7 @@ LIB_DEPENDS= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
avahi-ui.0:${PORTSDIR}/net/avahi-gtk
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
USE_GNOME= gnomeprefix gnomehack gtk20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/www/libgtkhtml/Makefile b/www/libgtkhtml/Makefile
index 6885382bb582..79ccca466dd6 100644
--- a/www/libgtkhtml/Makefile
+++ b/www/libgtkhtml/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: libgtkhtml
-# Date created: 2nd June 2000
-# Whom: Ade Lovett <ade@FreeBSD.org>
-#
+# Created by: Ade Lovett <ade@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/www/libgtkhtml/Makefile,v 1.41 2008/08/23 18:23:00 mezz Exp $
-#
PORTNAME= libgtkhtml
PORTVERSION= 2.11.1
@@ -17,7 +13,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Lightweight HTML rendering/printing/editing engine
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomeprefix gnomehack libxslt gnomevfs2 ltverhack
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
diff --git a/www/mod_auth_mellon/Makefile b/www/mod_auth_mellon/Makefile
index b22cff119952..42cbc59d6773 100644
--- a/www/mod_auth_mellon/Makefile
+++ b/www/mod_auth_mellon/Makefile
@@ -14,6 +14,7 @@ COMMENT= Apache auth module for identifying SSO users
LIB_DEPENDS= lasso.8:${PORTSDIR}/security/lasso \
curl:${PORTSDIR}/ftp/curl
+USES= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs2=${APXS}
CONFIGURE_ENV+= OPENSSL_CFLAGS="-Wall" OPENSSL_LIBS="-lssl"