aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2009-10-13 03:55:37 +0800
committerlth <lth@FreeBSD.org>2009-10-13 03:55:37 +0800
commitbabbc28650f67ef1afb6196feecfa4fdddd27f1f (patch)
tree9c4b934485563cc5051b2c5ee5974b6df7bcc08f /www
parenta7ece7fb54860c29012fb620908471334a98201d (diff)
downloadfreebsd-ports-gnome-babbc28650f67ef1afb6196feecfa4fdddd27f1f.tar.gz
freebsd-ports-gnome-babbc28650f67ef1afb6196feecfa4fdddd27f1f.tar.zst
freebsd-ports-gnome-babbc28650f67ef1afb6196feecfa4fdddd27f1f.zip
Avoid segfault on perl 5.10
PR: ports/139259 Submitted by: Vivek Khera <vivek@khera.org> Obtained from: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=537996
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI-SpeedyCGI/Makefile2
-rw-r--r--www/p5-CGI-SpeedyCGI/files/patch-src_speedy_perl.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/www/p5-CGI-SpeedyCGI/Makefile b/www/p5-CGI-SpeedyCGI/Makefile
index d3cb5ffd8cfd..3179c95efd69 100644
--- a/www/p5-CGI-SpeedyCGI/Makefile
+++ b/www/p5-CGI-SpeedyCGI/Makefile
@@ -7,7 +7,7 @@
PORTNAME= CGI-SpeedyCGI
PORTVERSION= 2.22
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/www/p5-CGI-SpeedyCGI/files/patch-src_speedy_perl.c b/www/p5-CGI-SpeedyCGI/files/patch-src_speedy_perl.c
new file mode 100644
index 000000000000..8b2ffeedb094
--- /dev/null
+++ b/www/p5-CGI-SpeedyCGI/files/patch-src_speedy_perl.c
@@ -0,0 +1,15 @@
+Author: Niko Tyni <ntyni@debian.org>
+Description: Closes: #537996
+The SvIV call crashes in on Perl 5.10.0 when warnings are
+enabled and the value is undef.
+--- src/speedy_perl.c
++++ src/speedy_perl.c
+@@ -818,7 +818,7 @@
+ my_call_sv(get_perlvar(&PERLVAR_RESET_GLOBALS));
+
+ /* Copy option values in from the perl vars */
+- if (SvIV(PERLVAL_OPTS_CHANGED)) {
++ if (SvTRUE(PERLVAL_OPTS_CHANGED)) {
+ int i;
+ for (i = 0; i < SPEEDY_NUMOPTS; ++i) {
+ OptRec *o = speedy_optdefs + i;