aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-05-30 16:50:20 +0800
committermarino <marino@FreeBSD.org>2014-05-30 16:50:20 +0800
commitc29141ed58aa9e38d23d08de4da2862194690fb7 (patch)
tree1f9da6ad76e35dfefbb6623edc89279d3f5957de /www
parentf74e27415a189b94bba9309e079d470205668b66 (diff)
downloadfreebsd-ports-gnome-c29141ed58aa9e38d23d08de4da2862194690fb7.tar.gz
freebsd-ports-gnome-c29141ed58aa9e38d23d08de4da2862194690fb7.tar.zst
freebsd-ports-gnome-c29141ed58aa9e38d23d08de4da2862194690fb7.zip
www/firefox(seamonkey)-i18n: explicitly use UNZIP_CMD
The extraction of xpi requires zip (infozip to be precise). Rather than use variables EXTRACT_CMD and EXTRACT_BEFORE_ARGS, use UNZIP_CMD and the default "-qo" arguments to future-proof these ports (depending on the implemention, the original variables may default to tar arguments if they are defined at all). Covered by general infrastructure blanket.
Diffstat (limited to 'www')
-rw-r--r--www/firefox-i18n/Makefile2
-rw-r--r--www/seamonkey-i18n/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/www/firefox-i18n/Makefile b/www/firefox-i18n/Makefile
index f780a5295973..c1287e5047ae 100644
--- a/www/firefox-i18n/Makefile
+++ b/www/firefox-i18n/Makefile
@@ -51,7 +51,7 @@ pre-everything::
do-extract:
@${MKDIR} ${WRKSRC}
@for lang in ${FIREFOX_I18N_}; do \
- if ! (${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$lang.xpi -d ${WRKSRC}/langpack-$$lang@firefox.mozilla.org);\
+ if ! (${UNZIP_CMD} -qo ${_DISTDIR}/$$lang.xpi -d ${WRKSRC}/langpack-$$lang@firefox.mozilla.org);\
then \
exit 1; \
fi; \
diff --git a/www/seamonkey-i18n/Makefile b/www/seamonkey-i18n/Makefile
index c71d8c714d07..d3597f260c06 100644
--- a/www/seamonkey-i18n/Makefile
+++ b/www/seamonkey-i18n/Makefile
@@ -51,7 +51,7 @@ pre-everything::
do-extract:
@${MKDIR} ${WRKSRC}
@for lang in ${SEAMONKEY_I18N_}; do \
- if ! (${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/seamonkey-${PORTVERSION}.$$lang.langpack.xpi -d ${WRKSRC}/langpack-$$lang@seamonkey.mozilla.org);\
+ if ! (${UNZIP_CMD} -qo ${_DISTDIR}/seamonkey-${PORTVERSION}.$$lang.langpack.xpi -d ${WRKSRC}/langpack-$$lang@seamonkey.mozilla.org);\
then \
exit 1; \
fi; \