aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-07-14 06:44:24 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-07-14 06:44:24 +0800
commitcd817c4e5f0b8e9f60c96a1995d9b6fbe2fd15a1 (patch)
tree29748b5f4b0a39f7ccc1485fbe39873eb435413a /www
parent09010300eb602df4548bd0239753f075d219bf7c (diff)
downloadfreebsd-ports-gnome-cd817c4e5f0b8e9f60c96a1995d9b6fbe2fd15a1.tar.gz
freebsd-ports-gnome-cd817c4e5f0b8e9f60c96a1995d9b6fbe2fd15a1.tar.zst
freebsd-ports-gnome-cd817c4e5f0b8e9f60c96a1995d9b6fbe2fd15a1.zip
A Script that automates pasting to a number of pastebin services
relying only on bash, sed, coreutils (mktemp/sort/tr/wc/whoami/tee) and wget WWW: http://wgetpaste.zlin.dk/ PR: ports/136411 Submitted by: Anonymous
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/wgetpaste/Makefile42
-rw-r--r--www/wgetpaste/distinfo9
-rw-r--r--www/wgetpaste/pkg-descr5
-rw-r--r--www/wgetpaste/pkg-plist7
5 files changed, 64 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 67a7761009ea..7b3e4a10e28c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1612,6 +1612,7 @@
SUBDIR += webstone
SUBDIR += webstone-ssl
SUBDIR += wget4web
+ SUBDIR += wgetpaste
SUBDIR += wikicalc
SUBDIR += wikindx
SUBDIR += wiliki
diff --git a/www/wgetpaste/Makefile b/www/wgetpaste/Makefile
new file mode 100644
index 000000000000..095df000293d
--- /dev/null
+++ b/www/wgetpaste/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: wgetpaste
+# Date created: 2 Jul 2009
+# Whom: Anonymous
+#
+# $FreeBSD$
+#
+
+PORTNAME= wgetpaste
+PORTVERSION= 2.13
+CATEGORIES= www
+MASTER_SITES= http://wgetpaste.zlin.dk/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}.example zlin.conf
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Paste to several pastebin services via bash script
+
+RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash \
+ ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+post-patch: .SILENT
+ ${REINPLACE_CMD} \
+ -e 's|/etc/|${PREFIX}/etc/|g' \
+ -e 's|\(INFO_COMMAND=\).*|\1"pkg_info -aE"|' \
+ -e 's|\(INFO_ARGS=\).*|\1|' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/_${PORTNAME} \
+ ${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}.example \
+ ${PREFIX}/etc/${PORTNAME}.conf.sample
+ ${MKDIR} ${PREFIX}/etc/${PORTNAME}.d
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/zlin.conf \
+ ${PREFIX}/etc/${PORTNAME}.d
+
+.include <bsd.port.mk>
diff --git a/www/wgetpaste/distinfo b/www/wgetpaste/distinfo
new file mode 100644
index 000000000000..b36bfdae9685
--- /dev/null
+++ b/www/wgetpaste/distinfo
@@ -0,0 +1,9 @@
+MD5 (wgetpaste-2.13.tar.bz2) = a341c778d745b0a7ad11163a4a2c1ea9
+SHA256 (wgetpaste-2.13.tar.bz2) = c33d97d5f2e3def50f0a316cf4f425037dc69b53016f8fecb6398503258b4854
+SIZE (wgetpaste-2.13.tar.bz2) = 8587
+MD5 (wgetpaste.example) = 77392c788659cc648a59df2d239ebe19
+SHA256 (wgetpaste.example) = cbc0437f7e04d95ffd224011ee2a056a84dfd7143e314e6962688295f68def4d
+SIZE (wgetpaste.example) = 380
+MD5 (zlin.conf) = 68046e6f334258a104c439affa6bb6f7
+SHA256 (zlin.conf) = 8fe8338ebd6716bac1e7e818b26163f899d7609fbac5932aaa1dabe45d6fdb19
+SIZE (zlin.conf) = 971
diff --git a/www/wgetpaste/pkg-descr b/www/wgetpaste/pkg-descr
new file mode 100644
index 000000000000..4900e6513405
--- /dev/null
+++ b/www/wgetpaste/pkg-descr
@@ -0,0 +1,5 @@
+A Script that automates pasting to a number of pastebin services
+relying only on bash, sed, coreutils (mktemp/sort/tr/wc/whoami/tee)
+and wget
+
+WWW: http://wgetpaste.zlin.dk/
diff --git a/www/wgetpaste/pkg-plist b/www/wgetpaste/pkg-plist
new file mode 100644
index 000000000000..f82750c1a176
--- /dev/null
+++ b/www/wgetpaste/pkg-plist
@@ -0,0 +1,7 @@
+bin/wgetpaste
+etc/wgetpaste.conf.sample
+etc/wgetpaste.d/zlin.conf
+share/zsh/site-functions/_wgetpaste
+@dirrmtry etc/wgetpaste.d
+@dirrmtry share/zsh/site-functions
+@dirrmtry share/zsh