aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-08-18 18:14:54 +0800
committertcberner <tcberner@FreeBSD.org>2017-08-18 18:14:54 +0800
commitce08f0d4e1622df51a7f75d8123e98111497e906 (patch)
treed86ef49c44d0dfd3903dcd943393bc4f3465addc /www
parentd06d0c269d79ab7b811c372c51ec761f13022f23 (diff)
downloadfreebsd-ports-gnome-ce08f0d4e1622df51a7f75d8123e98111497e906.tar.gz
freebsd-ports-gnome-ce08f0d4e1622df51a7f75d8123e98111497e906.tar.zst
freebsd-ports-gnome-ce08f0d4e1622df51a7f75d8123e98111497e906.zip
Fix building of www/qt5-webengine if the default python version is not 2.
Reviewed by: rakuco
Diffstat (limited to 'www')
-rw-r--r--www/qt5-webengine/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/www/qt5-webengine/Makefile b/www/qt5-webengine/Makefile
index 6312513ecef5..35bcccf742e8 100644
--- a/www/qt5-webengine/Makefile
+++ b/www/qt5-webengine/Makefile
@@ -16,6 +16,7 @@
PORTNAME= webengine
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= qt5-
@@ -24,7 +25,6 @@ COMMENT= Qt 5 library to render web content
BUILD_DEPENDS= bison:devel/bison \
ninja:devel/ninja \
- python:lang/python \
yasm:devel/yasm \
${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
LIB_DEPENDS= libdbus-1.so:devel/dbus \
@@ -83,7 +83,8 @@ ALL_TARGET= first
# Since we use USES=qmake:norecursive, we also need to pass some variables to
# MAKE_ENV because part of the configuration process happens during the build.
CONFIGURE_ENV+= NINJAFLAGS="-j${MAKE_JOBS_NUMBER}" \
- NINJA_PATH="${LOCALBASE}/bin/ninja"
+ NINJA_PATH="${LOCALBASE}/bin/ninja" \
+ PATH=${CONFIGURE_WRKSRC}/bin:${PATH}
MAKE_ENV+= CC="${CC}" CXX="${CXX}" ${CONFIGURE_ENV}
post-extract:
@@ -102,4 +103,10 @@ post-patch:
${REINPLACE_CMD} -e 's,OS == "linux",(OS == "linux" or OS == "freebsd"),g' \
${WRKSRC}/src/3rdparty/chromium/third_party/ffmpeg/ffmpeg_generated.gypi
+pre-configure:
+# Link in ${PYTHON_CMD} to ${CONFIGURE_WRKSRC}/bin -- the scripts hardcode 'python'
+# in too many places to reasonably patch. So just link in ${PYTHON_CMD} to work around
+# $LOCALBASE/bin/python being python3 if the default versions is set to 3.x.
+ ${MKDIR} ${CONFIGURE_WRKSRC}/bin && ${LN} -s ${PYTHON_CMD} ${CONFIGURE_WRKSRC}/bin/python
+
.include <bsd.port.mk>