aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 14:57:56 +0800
committerreg <reg@FreeBSD.org>2000-10-05 14:57:56 +0800
commitcea38f8422a3eeac06b3ce4a5828580a5812d2cc (patch)
tree9703d7928f2f462fdf308bf7d14164f8f8459828 /www
parent4495def283d3b8c777e1eb5b958cedb25b1aa16b (diff)
downloadfreebsd-ports-gnome-cea38f8422a3eeac06b3ce4a5828580a5812d2cc.tar.gz
freebsd-ports-gnome-cea38f8422a3eeac06b3ce4a5828580a5812d2cc.tar.zst
freebsd-ports-gnome-cea38f8422a3eeac06b3ce4a5828580a5812d2cc.zip
Implement WANT_IMLIB and USE_IMLIB.
Diffstat (limited to 'www')
-rw-r--r--www/bluefish/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index 8fc5a106ab19..28ca859841ff 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -14,27 +14,23 @@ MASTER_SITES= http://bluefish.openoffice.nl/download/ \
MAINTAINER= jim@FreeBSD.org
RUN_DEPENDS= weblint:${PORTSDIR}/www/weblint
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- gdk_imlib.5:${PORTSDIR}/graphics/imlib
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_GMAKE= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_IMLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-install-location="${X11BASE}/lib/bluefish" \
--disable-nls
-CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+
MAN1= bluefish.1
post-install:
- @strip ${PREFIX}/bin/bluefish
.if !defined(NOPORTDOCS)
@${ECHO} "===> Installing bluefish docs in ${PREFIX}/share/doc/bluefish"
@${ECHO} "===> A manual is available online at http://bluefish.linuxbox.com/manual/"
@${MKDIR} ${PREFIX}/share/doc/bluefish && ${CHMOD} a+rx ${PREFIX}/share/doc/bluefish
- @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/bluefish
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/bluefish
.endif
.include <bsd.port.mk>