aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-08-11 06:00:59 +0800
committermiwi <miwi@FreeBSD.org>2008-08-11 06:00:59 +0800
commitcf372bf9e877b44c1d0ec2520715ad5469bb70ce (patch)
tree3a5e22b4ca51349bbee78ffa4ab80914b8c258c0 /www
parentc88958c08e5ce60a90bd0c4351d5056a15daa0a1 (diff)
downloadfreebsd-ports-gnome-cf372bf9e877b44c1d0ec2520715ad5469bb70ce.tar.gz
freebsd-ports-gnome-cf372bf9e877b44c1d0ec2520715ad5469bb70ce.tar.zst
freebsd-ports-gnome-cf372bf9e877b44c1d0ec2520715ad5469bb70ce.zip
Yahoo! GeoPlanet helps bridge the gap between the real and virtual
worlds by providing an open, permanent, and intelligent infrastructure for geo-referencing data on the Internet. WWW: http://developer.yahoo.com/geo/ PR: ports/126292 Submitted by: Steven Kreuzer <skreuzer at exit2shell.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Net-GeoPlanet/Makefile27
-rw-r--r--www/p5-Net-GeoPlanet/distinfo3
-rw-r--r--www/p5-Net-GeoPlanet/pkg-descr7
-rw-r--r--www/p5-Net-GeoPlanet/pkg-plist4
5 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index eed40f1b6a1e..4fa5065540fa 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -908,6 +908,7 @@
SUBDIR += p5-Net-Flickr-API
SUBDIR += p5-Net-Flickr-Backup
SUBDIR += p5-Net-Flickr-RDF
+ SUBDIR += p5-Net-GeoPlanet
SUBDIR += p5-Net-eBay
SUBDIR += p5-Newsletter
SUBDIR += p5-PHP-Session
diff --git a/www/p5-Net-GeoPlanet/Makefile b/www/p5-Net-GeoPlanet/Makefile
new file mode 100644
index 000000000000..80c6c634af64
--- /dev/null
+++ b/www/p5-Net-GeoPlanet/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-GeoPlanet
+# Date created: 2008-08-05
+# Whom: Steven Kreuzer <skreuzer@exit2shell.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-GeoPlanet
+PORTVERSION= 0.1
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@exit2shell.com
+COMMENT= Access Yahoo's GeoPlanet location service
+
+RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
+ p5-XML-Simple>=2.18:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
+ p5-Test-Simple>=0.74:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::GeoPlanet.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Net-GeoPlanet/distinfo b/www/p5-Net-GeoPlanet/distinfo
new file mode 100644
index 000000000000..44680fcf7540
--- /dev/null
+++ b/www/p5-Net-GeoPlanet/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-GeoPlanet-0.1.tar.gz) = d99a2f4da4032b7ae1bd503abe6dcb52
+SHA256 (Net-GeoPlanet-0.1.tar.gz) = e8f15981fd051230c65e4239352688e313787c8c70ba8066c5f7030b80a12515
+SIZE (Net-GeoPlanet-0.1.tar.gz) = 1381
diff --git a/www/p5-Net-GeoPlanet/pkg-descr b/www/p5-Net-GeoPlanet/pkg-descr
new file mode 100644
index 000000000000..9b472fbee5a6
--- /dev/null
+++ b/www/p5-Net-GeoPlanet/pkg-descr
@@ -0,0 +1,7 @@
+Yahoo! GeoPlanet helps bridge the gap between the real and virtual
+worlds by providing an open, permanent, and intelligent infrastructure
+for geo-referencing data on the Internet.
+
+Net::GeoPlanet provides access to Yahoo's GeoPlanet location service.
+
+WWW: http://developer.yahoo.com/geo/
diff --git a/www/p5-Net-GeoPlanet/pkg-plist b/www/p5-Net-GeoPlanet/pkg-plist
new file mode 100644
index 000000000000..d6ea7e08acd1
--- /dev/null
+++ b/www/p5-Net-GeoPlanet/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Net/GeoPlanet.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/GeoPlanet/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/GeoPlanet