aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-06-29 10:17:18 +0800
committerbeech <beech@FreeBSD.org>2008-06-29 10:17:18 +0800
commitd5f886e8ef765944b2afe0683931a8a4d498dd7e (patch)
tree84439d8cfaa17116904b58dc40638286e4b20b3a /www
parenta6ef2041ae6f204cb1708f905df632d4d109c022 (diff)
downloadfreebsd-ports-gnome-d5f886e8ef765944b2afe0683931a8a4d498dd7e.tar.gz
freebsd-ports-gnome-d5f886e8ef765944b2afe0683931a8a4d498dd7e.tar.zst
freebsd-ports-gnome-d5f886e8ef765944b2afe0683931a8a4d498dd7e.zip
TclDOM is a Tcl language binding for the W3C's DOM standard. DOM
provides a tree view of an XML document. TclDOM is a package with several implementations, including one written in pure Tcl, one written in C based on TclDOMPro and another that wraps the Gnome libxml2 library. This port installs the TclDOMPro part. PR: ports/123954 Submitted by: Frank Fenor <frank at fenor.de>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/tcldom/Makefile28
-rw-r--r--www/tcldom/distinfo3
-rw-r--r--www/tcldom/pkg-descr9
4 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2920a99a393b..e3387388ad30 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1274,6 +1274,7 @@
SUBDIR += swish++
SUBDIR += swish-e
SUBDIR += syndigator
+ SUBDIR += tcldom
SUBDIR += tclhttpd
SUBDIR += tclwebtest
SUBDIR += tdiary
diff --git a/www/tcldom/Makefile b/www/tcldom/Makefile
new file mode 100644
index 000000000000..fd1c25a6dfe8
--- /dev/null
+++ b/www/tcldom/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: TclDOM
+# Date created: 28 April 2008
+# Whom: Frank Fenor <frank@fenor.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcldom
+DISTVERSION= 3.1
+CATEGORIES= www tcl
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= tclxml
+
+MAINTAINER= frank@fenor.de
+COMMENT= DOM API for Tcl based on TclDOMPro
+
+BUILD_DEPENDS?= ${LOCALBASE}/include/expat.h:${PORTSDIR}/textproc/expat2
+
+WRKSRC?= ${WRKDIR}/${PORTNAME}-${DISTVERSION}/src
+USE_TCL= 82+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
+ --with-tclinclude=${TCL_INCLUDEDIR}
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I\"${PREFIX}/include\""
+PLIST_FILES= lib/tcldom2.0/tcldom84.so.1 lib/tcldom2.0/pkgIndex.tcl
+
+.include <bsd.port.mk>
diff --git a/www/tcldom/distinfo b/www/tcldom/distinfo
new file mode 100644
index 000000000000..6ad0b354fdbe
--- /dev/null
+++ b/www/tcldom/distinfo
@@ -0,0 +1,3 @@
+MD5 (tcldom-3.1.tar.gz) = b5af0e29e5cf2109d1f1a9b1a6ec2d81
+SHA256 (tcldom-3.1.tar.gz) = 1eabfe884a072f18bd18b1ec9c495145057442e072fe5288d9742058d93278ed
+SIZE (tcldom-3.1.tar.gz) = 395572
diff --git a/www/tcldom/pkg-descr b/www/tcldom/pkg-descr
new file mode 100644
index 000000000000..3784f96b32e9
--- /dev/null
+++ b/www/tcldom/pkg-descr
@@ -0,0 +1,9 @@
+TclDOM is a Tcl language binding for the W3C's DOM standard. DOM
+provides a tree view of an XML document.
+
+TclDOM is a package with several implementations, including one
+written in pure Tcl, one written in C based on TclDOMPro and
+another that wraps the Gnome libxml2 library.
+This port installs the TclDOMPro part.
+
+WWW: http://tclxml.sourceforge.net/tcldom.html