aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-05-15 04:14:52 +0800
committersat <sat@FreeBSD.org>2006-05-15 04:14:52 +0800
commitddde4c736f51b43e2ecef16884e9e1128bf80abd (patch)
tree2fd7da71c24bb790f0954820145a874bdccc8a79 /www
parent9d38c98c7fbb7aeac68bab3e0a857b258bd9b791 (diff)
downloadfreebsd-ports-gnome-ddde4c736f51b43e2ecef16884e9e1128bf80abd.tar.gz
freebsd-ports-gnome-ddde4c736f51b43e2ecef16884e9e1128bf80abd.tar.zst
freebsd-ports-gnome-ddde4c736f51b43e2ecef16884e9e1128bf80abd.zip
Add p5-Template-Provider-Encoding: Template plugin to specify encoding
PR: ports/94066 Submitted by: TAKAHASHI Kaoru <kaoru@kaisei.org> Approved by: krion (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Template-Provider-Encoding/Makefile26
-rw-r--r--www/p5-Template-Provider-Encoding/distinfo3
-rw-r--r--www/p5-Template-Provider-Encoding/pkg-descr8
-rw-r--r--www/p5-Template-Provider-Encoding/pkg-plist13
5 files changed, 51 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index cbdffe7124d7..22764520180a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -705,6 +705,7 @@
SUBDIR += p5-Template-Plugin-Monta
SUBDIR += p5-Template-Plugin-Number-Format
SUBDIR += p5-Template-Plugin-Subst
+ SUBDIR += p5-Template-Provider-Encoding
SUBDIR += p5-Template-Timer
SUBDIR += p5-Template-Toolkit
SUBDIR += p5-Test-HTTP-Server-Simple
diff --git a/www/p5-Template-Provider-Encoding/Makefile b/www/p5-Template-Provider-Encoding/Makefile
new file mode 100644
index 000000000000..c8556935a92a
--- /dev/null
+++ b/www/p5-Template-Provider-Encoding/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Template-Provider-Encoding
+# Date created: 2006-02-28
+# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Provider-Encoding
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kaoru@kaisei.org
+COMMENT= Template plugin to specify encoding
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Provider::Encoding.3 \
+ Template::Stash::ForceUTF8.3 \
+ Template::Plugin::encoding.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Template-Provider-Encoding/distinfo b/www/p5-Template-Provider-Encoding/distinfo
new file mode 100644
index 000000000000..d630904df998
--- /dev/null
+++ b/www/p5-Template-Provider-Encoding/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Provider-Encoding-0.05.tar.gz) = 82a0fe64eea284c49fe47ad7981e8dd6
+SHA256 (Template-Provider-Encoding-0.05.tar.gz) = 57360c4d15e463ff53a081c720b36de64842e6992e87ae2d8f422f45291d88e2
+SIZE (Template-Provider-Encoding-0.05.tar.gz) = 3940
diff --git a/www/p5-Template-Provider-Encoding/pkg-descr b/www/p5-Template-Provider-Encoding/pkg-descr
new file mode 100644
index 000000000000..5454a9dc0567
--- /dev/null
+++ b/www/p5-Template-Provider-Encoding/pkg-descr
@@ -0,0 +1,8 @@
+Template::Plugin::encoding is a Template plugin to declare the encoding of
+template files. This plugin doesn't actually do anything but
+Template::Provider::Encoding scans the usage of this module to find
+the encoding of templates. As a bonus, you can use encoding variable in
+the template to specify file encoding, which might be useful for
+XML or HTML meta tag.
+
+WWW: http://search.cpan.org/dist/Template-Provider-Encoding/
diff --git a/www/p5-Template-Provider-Encoding/pkg-plist b/www/p5-Template-Provider-Encoding/pkg-plist
new file mode 100644
index 000000000000..86e402bd0054
--- /dev/null
+++ b/www/p5-Template-Provider-Encoding/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Provider/Encoding/.packlist
+%%SITE_PERL%%/Template/Provider/Encoding.pm
+%%SITE_PERL%%/Template/Stash/ForceUTF8.pm
+%%SITE_PERL%%/Template/Plugin/encoding.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Provider/Encoding
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Provider
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrm %%SITE_PERL%%/Template/Provider
+@dirrm %%SITE_PERL%%/Template/Stash
+@dirrmtry %%SITE_PERL%%/Template/Plugin
+@dirrmtry %%SITE_PERL%%/Template