aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-04-08 06:39:08 +0800
committerrene <rene@FreeBSD.org>2011-04-08 06:39:08 +0800
commite30e31b96ee8588e035ae57b95dd9262fcf11d53 (patch)
tree78588b76bd97c107618e71691affcadaba05dca8 /www
parentfeb413be292402fecc41b2529997ec599c3b9dc7 (diff)
downloadfreebsd-ports-gnome-e30e31b96ee8588e035ae57b95dd9262fcf11d53.tar.gz
freebsd-ports-gnome-e30e31b96ee8588e035ae57b95dd9262fcf11d53.tar.zst
freebsd-ports-gnome-e30e31b96ee8588e035ae57b95dd9262fcf11d53.zip
Cleanup Makefile a bit more:
- Convert two explicit dependencies to a USE_GNOME and USE_XORG component - Use buildtime SSE2 detection instead of an OPTION - Replace USE_PYTHON by USE_PYTHON_BUILD - Sort knobs Submitted by: danfe
Diffstat (limited to 'www')
-rw-r--r--www/chromium/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 233697232aee..b6fc814a2403 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -20,7 +20,6 @@ COMMENT= A mostly BSD-licensed web browser based on WebKit and Gtk+
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
bash:${PORTSDIR}/shells/bash \
- pkg-config:${PORTSDIR}/devel/pkg-config \
yasm:${PORTSDIR}/devel/yasm \
nss>=3.12:${PORTSDIR}/security/nss
# minimal version of nss, LIB_DEPENDS does not enforce this
@@ -29,7 +28,6 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
cairo.2:${PORTSDIR}/graphics/cairo \
dbus-1.3:${PORTSDIR}/devel/dbus \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- Xss.1:${PORTSDIR}/x11/libXScrnSaver \
asound.2:${PORTSDIR}/audio/alsa-lib \
freetype.9:${PORTSDIR}/print/freetype2 \
nss3.1:${PORTSDIR}/security/nss \
@@ -41,12 +39,12 @@ RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/a
ONLY_FOR_ARCHS= i386 amd64
USE_XZ= yes
USE_BISON= build
-USE_PYTHON= 2.6+ # only needed at build time
-USE_PERL5_BUILD=yes
USE_GMAKE= yes
+USE_PERL5_BUILD= yes
+USE_PYTHON_BUILD= 2.6+
+USE_XORG= scrnsaverproto x11 xproto xscrnsaver xtst
+USE_GNOME= glib20 gtk20 dconf libxslt pkgconfig
MAN1= chrome.1
-USE_XORG= scrnsaverproto x11 xproto xtst
-USE_GNOME= glib20 gtk20 dconf libxslt
LICENSE_COMB= multi
LICENSE= BSD LGPL21 MPL
@@ -70,7 +68,6 @@ GYP_DEFINES+= python_ver=${PYTHON_VER}
OPTIONS= CODECS "Compile and enable patented codecs like H.264" off \
GCONF "Use GConf2 for preferences" on \
- SSE2 "Use SSE2, disable this for PIII or older" on \
VPX "Use system libvpx for VP8 codec" on
.include <bsd.port.options.mk>
@@ -95,7 +92,7 @@ USE_GNOME+= gconf2
GYP_DEFINES+= use_gconf=0
.endif
-.if defined(WITHOUT_SSE2)
+.if ! ${MACHINE_CPU:Msse2}
GYP_DEFINES+= disable_sse2=1
.endif