aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlbr <lbr@FreeBSD.org>2009-03-29 22:17:04 +0800
committerlbr <lbr@FreeBSD.org>2009-03-29 22:17:04 +0800
commite6c9e974882e736e62bc420cfbd244fa5d49c02a (patch)
tree255d3f2e4f870c32e2f3b2c0f902a19df8e10636 /www
parent20fc548efd977b7083f2fe281a6dd99b97aa5f1d (diff)
downloadfreebsd-ports-gnome-e6c9e974882e736e62bc420cfbd244fa5d49c02a.tar.gz
freebsd-ports-gnome-e6c9e974882e736e62bc420cfbd244fa5d49c02a.tar.zst
freebsd-ports-gnome-e6c9e974882e736e62bc420cfbd244fa5d49c02a.zip
New port www/p5-HTML-GenToc:
HTML::GenToc generates anchors and a table of contents for HTML documents. Depending on the arguments, it will insert the information it generates, or output to a string, a separate file or STDOUT. While it defaults to taking H1 and H2 elements as the significant elements to put into the table of contents, any tag can be defined as a significant element. Also, it doesn't matter if the input HTML code is complete, pure HTML, one can input pseudo-html or page-fragments, which makes it suitable for using on templates and HTML meta-languages such as WML. Also included in the distrubution is hypertoc, a script which uses the module so that one can process files on the command-line in a user-friendly manner.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-GenToc/Makefile28
-rw-r--r--www/p5-HTML-GenToc/distinfo3
-rw-r--r--www/p5-HTML-GenToc/pkg-descr17
-rw-r--r--www/p5-HTML-GenToc/pkg-plist3
5 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3739626f8145..b961f476ea58 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -843,6 +843,7 @@
SUBDIR += p5-HTML-FormFu-Model-DBIC
SUBDIR += p5-HTML-FromANSI
SUBDIR += p5-HTML-FromText
+ SUBDIR += p5-HTML-GenToc
SUBDIR += p5-HTML-GoogleMaps
SUBDIR += p5-HTML-Highlight
SUBDIR += p5-HTML-LinkExtractor
diff --git a/www/p5-HTML-GenToc/Makefile b/www/p5-HTML-GenToc/Makefile
new file mode 100644
index 000000000000..e80cbad08229
--- /dev/null
+++ b/www/p5-HTML-GenToc/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: www/p5-HTML-GenToc
+# Date created: 29 Mar 2009
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-GenToc
+PORTVERSION= 3.10
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Generate a Table of Contents for HTML documents
+
+RUN_DEPENDS= p5-HTML-LinkList>=0.1501:${PORTSDIR}/www/p5-HTML-LinkList \
+ p5-HTML-SimpleParse>=0.10:${PORTSDIR}/www/p5-HTML-SimpleParse \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Getopt-ArgvFile>=1.09:${PORTSDIR}/devel/p5-Getopt-ArgvFile
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= 5.8.1+
+
+MAN1= hypertoc.1
+MAN3= HTML::GenToc.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-GenToc/distinfo b/www/p5-HTML-GenToc/distinfo
new file mode 100644
index 000000000000..e614cc696856
--- /dev/null
+++ b/www/p5-HTML-GenToc/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-GenToc-3.10.tar.gz) = 3a212627b8ef2128c1e98e6b722cc915
+SHA256 (HTML-GenToc-3.10.tar.gz) = 5f07810f14301350a37597c044527e27d0db1ac889b5e00cd31ed137b73e831f
+SIZE (HTML-GenToc-3.10.tar.gz) = 45923
diff --git a/www/p5-HTML-GenToc/pkg-descr b/www/p5-HTML-GenToc/pkg-descr
new file mode 100644
index 000000000000..1a9f8e9c7a7e
--- /dev/null
+++ b/www/p5-HTML-GenToc/pkg-descr
@@ -0,0 +1,17 @@
+HTML::GenToc generates anchors and a table of contents for
+HTML documents. Depending on the arguments, it will insert
+the information it generates, or output to a string, a separate file
+or STDOUT.
+
+While it defaults to taking H1 and H2 elements as the significant
+elements to put into the table of contents, any tag can be defined
+as a significant element. Also, it doesn't matter if the input
+HTML code is complete, pure HTML, one can input pseudo-html
+or page-fragments, which makes it suitable for using on templates
+and HTML meta-languages such as WML.
+
+Also included in the distrubution is hypertoc, a script which uses the
+module so that one can process files on the command-line in a
+user-friendly manner.
+
+WWW: http://search.cpan.org/dist/HTML-GenToc/
diff --git a/www/p5-HTML-GenToc/pkg-plist b/www/p5-HTML-GenToc/pkg-plist
new file mode 100644
index 000000000000..9bf854c7d160
--- /dev/null
+++ b/www/p5-HTML-GenToc/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/HTML/GenToc.pm
+bin/hypertoc
+@dirrmtry %%SITE_PERL%%/HTML