aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-08-01 19:18:47 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-08-01 19:18:47 +0800
commitf10eee1065a5fa2cd19d258b7e7dbcbb5c6a9ffa (patch)
treed53f23dc48046c3a9e7d129e442928c0ebf55738 /www
parent593da54165f2aee61bd0ddd63558173c0aa470c9 (diff)
downloadfreebsd-ports-gnome-f10eee1065a5fa2cd19d258b7e7dbcbb5c6a9ffa.tar.gz
freebsd-ports-gnome-f10eee1065a5fa2cd19d258b7e7dbcbb5c6a9ffa.tar.zst
freebsd-ports-gnome-f10eee1065a5fa2cd19d258b7e7dbcbb5c6a9ffa.zip
Maintain session IDs using mobile phone's unique id.
WWW: http://search.cpan.org/dist/HTTP-Session-State-MobileAgentID/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Session-State-MobileAgentID/Makefile27
-rw-r--r--www/p5-HTTP-Session-State-MobileAgentID/distinfo3
-rw-r--r--www/p5-HTTP-Session-State-MobileAgentID/pkg-descr3
-rw-r--r--www/p5-HTTP-Session-State-MobileAgentID/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e1260ffe0ebe..6ba0eaa14934 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1039,6 +1039,7 @@
SUBDIR += p5-HTTP-Server-Simple-Recorder
SUBDIR += p5-HTTP-Server-Simple-Static
SUBDIR += p5-HTTP-Session
+ SUBDIR += p5-HTTP-Session-State-MobileAgentID
SUBDIR += p5-HTTP-SimpleLinkChecker
SUBDIR += p5-HTTP-Size
SUBDIR += p5-HTTP-WebTest
diff --git a/www/p5-HTTP-Session-State-MobileAgentID/Makefile b/www/p5-HTTP-Session-State-MobileAgentID/Makefile
new file mode 100644
index 000000000000..5d2f4f3109be
--- /dev/null
+++ b/www/p5-HTTP-Session-State-MobileAgentID/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: HTTP::Session::State::MobileAgentID
+# Date created: 01 Aug 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Session-State-MobileAgentID
+PORTVERSION= 0.41
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to maintain session IDs using mobile phone unique id
+
+RUN_DEPENDS= \
+ p5-HTTP-MobileAgent>=0.28:${PORTSDIR}/www/p5-HTTP-MobileAgent \
+ p5-HTTP-Session>=0.38:${PORTSDIR}/www/p5-HTTP-Session \
+ p5-Net-CIDR-MobileJP>=0.20:${PORTSDIR}/net/p5-Net-CIDR-MobileJP
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Session::State::MobileAgentID.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Session-State-MobileAgentID/distinfo b/www/p5-HTTP-Session-State-MobileAgentID/distinfo
new file mode 100644
index 000000000000..d30204fa48fa
--- /dev/null
+++ b/www/p5-HTTP-Session-State-MobileAgentID/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Session-State-MobileAgentID-0.41.tar.gz) = beead2395301a2860676f3b936ed9d97
+SHA256 (HTTP-Session-State-MobileAgentID-0.41.tar.gz) = c97d45504e5806d0a43c17d94354a7d37a54af162333f2f70f8743cf0f3c59c2
+SIZE (HTTP-Session-State-MobileAgentID-0.41.tar.gz) = 22047
diff --git a/www/p5-HTTP-Session-State-MobileAgentID/pkg-descr b/www/p5-HTTP-Session-State-MobileAgentID/pkg-descr
new file mode 100644
index 000000000000..416e73909125
--- /dev/null
+++ b/www/p5-HTTP-Session-State-MobileAgentID/pkg-descr
@@ -0,0 +1,3 @@
+Maintain session IDs using mobile phone's unique id.
+
+WWW: http://search.cpan.org/dist/HTTP-Session-State-MobileAgentID/
diff --git a/www/p5-HTTP-Session-State-MobileAgentID/pkg-plist b/www/p5-HTTP-Session-State-MobileAgentID/pkg-plist
new file mode 100644
index 000000000000..ad7e15f3f0c4
--- /dev/null
+++ b/www/p5-HTTP-Session-State-MobileAgentID/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Session/State/MobileAgentID/.packlist
+%%SITE_PERL%%/HTTP/Session/State/MobileAgentID.pm
+@dirrmtry %%SITE_PERL%%/HTTP/Session/State
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Session/State/MobileAgentID
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Session/State